2 Replies Latest reply on Apr 5, 2012 8:44 AM by cwatkin

    Intel HD 3000 and HDMI Monitor refresh rate won't stay set - how to fix?

    cwatkin

      I just purchased an HP DM4-3050US laptop with a Core i5 2.5GHZ, HM67 chipset, and Intel 3000 graphics.  This is replacing an early generation mobile Core i7 and this unit actually scores higher except on the graphics and that isn't by much.  This is a nice unit and don't want to end up smashing it to pieces due to frustation.  Although I love the laptop otherwise, I am halfway considering returning it.

       

      I am using it with an HP 2709m LCD monitor connected through the HDMI port.  This monitor was connected through the HDMI port on my old laptop which had ATI graphics and I didn't have the issue I am about to describe.  Upon connecting the monitor, I noticed that the edges of the displayed area were cutoff which I found is something called "overscan."  I looked and looked and found a few workarounds that seem to work quite well but all have a major problem.  The easiest is to set the refresh rate to 60 Hz vs. the default 59 Hz.

       

      Here is the catch....  I guess that the Intel GPU is seeing this monitor as a TV which it is not and applying overscan.  I understand that 59 and 60 Hz are basically the same thing so this doesn't matter except when specifying a monitor or TV.  No matter how many times I set the refresh rate to 60 Hz in Windows and the Intel HD Control Panel, it keeps reverting to 59 Hz whenever I restart, put the computer to sleep, the monitor sleeps and then wakes, etc.  When this happens, the overscan issue returns in force and my display is cutoff along the sides and top/bottom.  When I return the refresh to 60 Hz, it goes away until the next time...

       

      I have spent all day trying to solve this issue.  The display works great as long as I don't reboot or put the computer/monitor to sleep.  I downloaded the latest drivers released for the product from the HP website and that didn't help.  I then found even newer drivers on the Intel website and they didn't help either.  I have installed/uninstalled the HP monitor .inf several times and nothing worked.

       

      I am wanting to make this work so that my settings stay saved and do not revert.  If I could eliminate the 59 Hz option all together, I would.  Thanks and let me know if you have any solutions.

       

      Conor

        • 1. Re: Intel HD 3000 and HDMI Monitor refresh rate won't stay set - how to fix?
          allan_intel

          Hi there!

           

          I appreciate your feedback on this matter. I will make sure your comment reaches the proper department for future consideration.

           

          Thank you for taking the time to communicate this issue to us.

           

          Thanks

          Allan.

          • 2. Re: Intel HD 3000 and HDMI Monitor refresh rate won't stay set - how to fix?
            cwatkin

            I found a workaround to this issue for now.  Basically, I took one of those DVI to HDMI converters and plugged the cable into the DVI port of my monitor instead of HDMI.   So, I have an HDMI cable coming out of the laptop, then being converted to DVI on my monitor.  The Intel HD no longer sees this as a digital TV and no longer runs at 59 HZ with the overscan issue.

             

            For those of you who have the same problem and have an unused DVI port on your monitor, there are several ways to adapt this without spending much money.  There are plenty of cables and converters to choose from if you look at buying one online.  I cannot say this would work on any monitor but it did on mine.  I have an HP 2709m which is a 27 inch LCD and have seen others referencing the same problem with an HP 2509m so I guess it would work on that one too.  The one issue is if you only have one DVI port and need it, you will then need to convert DVI to HDMI to input that data.  Unless you are using the same Intel HD graphics, it may work fine.  Also, maybe this would also work without overscanning???  I don't know.

             

            Anyway, I thought it was good to share this workaround.

             

            Conor