1 2 Previous Next 15 Replies Latest reply on Apr 24, 2012 7:29 PM by WantsECConDX58SO2

    Firmware update on DX58SO2 resulting to: A bootable device has not been detected


      Hi all,


      I tried to update my firmware to the latest BIOS Update Version 888 yesterday. I proceeded to run the update with the Window package and worked without any warning during the update out of Windows.


      Once the firmware update completed and it tried to boot, it showed the message "A bootable device has not been detected". I tried to load bios default and modified a few items, like disabling integrated audio device, and tried to boot, same message.


      I tried isolating to my boot device only and tried again, same scenario, same message.


      I was able to load clonezilla and make an image of the whole drive before trying a repair with a Winndows 7 64bit DVD, it failed to recognize a working installation.


      The last thing I tried was to revert to the previous BIOS image I had, 817 if I remember correctly, the downgrade went as expected, no failure. After a reset it booted and started my OS like it was before the first update to image 888.


      A quick overview of my configuration:


      Intel Desktop Board DX58SO2

      Intel Core i7 960 3.2GHz

      Boot Storage device: Intel X25-M 80GB 1st generation

      Three native SATA Hard Drives: 1 Seagate and 2 Western Digital.

      LG DVD Writer, also SATA


      All Storage devices are connected to the standard SATA controler, nothing is connected to the Marvel controlers, yet...


      Thank you in advance for your help,



        • 1. Re: Firmware update on DX58SO2 resulting to: A bootable device has not been detected



          I am running BIOS 888 - DX58SO2 with no major issues.


          However, a few weeks ago I had a similiar problem as you have (root cause was a "fat finger" issue when I was playnig with the boot options via msconfig.exe). The boot options got out of sync with the BIOS. I am running UEFI boot (check that this is set to the desired option in the BIOS). The Windows BCD got screwed up - I eventually corrected the issue by booting off the product CD and getting into a command shell and rebuilding the BCD for the UEFI boot volume. This article at Microsoft describes this process:




          Check all your BIOS settings - especially RAID vs ACHI. If you are not using the Marvell controllers try disabling them.


          Just a few suggestions ....

          • 2. Re: Firmware update on DX58SO2 resulting to: A bootable device has not been detected

            Hi there,


            I saw you are running BIOS v888, can you please tell me if they fixed the ECC issue in this version ?


            I know your CPU doesn't support ECC, but at least you should be able to see some greyed feature for enabling/disabling ECC.


            Any new menu in v888, any screenshots ?


            Thanks in advance !


            • 3. Re: Firmware update on DX58SO2 resulting to: A bootable device has not been detected



              To be honest I have not been into the memory settings in the BIOS in a while. I do not remember seeing anything for ECC - but I was not looking for it. I will be re-booting & playing with the BIOS this coming weekend (use it for home ==> work connection during the week and need it stable).


              I will check then and post what I find.



              • 6. Re: Firmware update on DX58SO2 resulting to: A bootable device has not been detected



                Looked around in the BIOS earlier today. I did not see ANY settings for ECC memory. But I am not running ECC memory or a setup that supports ECC (I7-990x with 12 GB GSKILL Sniper). Either there are no settings in the BIOS or they only appear on a setup that supports ECC (XEON & ECC memory).



                • 7. Re: Firmware update on DX58SO2 resulting to: A bootable device has not been detected

                  A quick update ....


                  I was looking for BIOS information in the BIOS GLOSSARY and I came across this :




                  Looks like the only way to find out is to give it a shot.



                  • 8. Re: Firmware update on DX58SO2 resulting to: A bootable device has not been detected

                    Thanks for the feedback it's much appreciated.


                    Well, I have already seen that information in the BIOS glossary, and I am using Xeon & ECC RAM, the info about this board is VERY FUZZY, somewhere they say ECC is supported in BIOS v5390 and later...if you look for BIOS v5390 you'll quickly find out that it does NOT exist for the DX58SO2, it is only available for the DX58SO and this implies that BIOS v603 is newer than v5390 and should support ECC.


                    If you can confirm that BIOS v888 does not introduce any new bug or make the system unstable, then I'll take the plung and upgrade to v888.


                    Thanks !


                    • 9. Re: Firmware update on DX58SO2 resulting to: A bootable device has not been detected

                      Hello Again,


                      The only issue I have had that may be related to BIOS 888 is related to "sleep" transitions. I have had a few problems when either entering or exiting sleep mode. Further investigation has revealed several event ID 12 - HAL - in the event logs. It does not happen all the time I have 15 of these in the event log since Feb 14 - which is around when I upgraded to BIOS 888. More information about this event is here.


                      This is the only issue I can attribute to the BIOS upgrade. I have other instabilities but they are related to driver issues (ATI Radeon) and some start-up conflicts (I run many beta & dev levels of various packages).



                      • 10. Re: Firmware update on DX58SO2 resulting to: A bootable device has not been detected

                        Do you mean the problems are only affecting Windows ?


                        I use Windows mostly for gaming, I think the Sleep mode should not be so important, I rather prefer the hibernation function on Ubuntu, it saves the RAM in the swap partition and turns off the computer completely & it's quicker to restart than a fresh system boot up, I think this problem should not affect Linux.


                        Well, let me know if I'm wrong, and about any other BIOS v888 issue.


                        Thanks !


                        • 11. Re: Firmware update on DX58SO2 resulting to: A bootable device has not been detected

                          Hi DementedCanuck,


                          Thank you for your reply, I just tried what you suggested today, but it didn't work. I tried many approach but none were successful.


                          I am somewhat new to UEFI, but here when I tried to boot from the Windows boot DVD, I was able to boot, but it failed to find a Windows installation, after a few tries, I figured that my problem was around the fact that ALL my storage devices are not available at boot once I flash to Firmware revision 888. Even my internal DVD drive was not properly detected. I pluged in a USB one and was able to boot with it, but Windows 7 boot DVD didn't find any valid installation. In this case, I wouldn't say I am certain, but it looked like Windows could not find any storage device on my system while running Firmware revision 888.


                          Tried loading BIOS default, then readjusting to my settings, disabling the Marvel SATA controler as suggested. So far same results. As for the main SATA controler, it is running as AHCI.


                          I tried to flash to 888 with the Windows executable and with the boot hot key F7. Nothing more useful.


                          I am jumping from revision 817 to 888, is there a need to flash to a in between revision to go around this issue?


                          Thanks again,



                          • 12. Re: Firmware update on DX58SO2 resulting to: A bootable device has not been detected



                            I did check my system by enabling UEFI boot in the BIOS, after reading your post, and I can say that I am facing the same problem you are facing. I updated the BIOS from stock v603 to latest v888. I didn't try it with the stock BIOS.


                            I am not using anything fancy, only two 320GB SATA II HDDs and a LG supermulti DVD burner, and after I enabled UEFI boot, the system wanted to network boot because it did not detect any bootable media (network was unplugged also) and gave a message asking to insert a disk and press any key....blah.


                            I am using a Xeon CPU with ECC RAM and the ECC feature is not working on this board. Now the UEFI boot is also not working...Grrr...I start thinking this is a  Celeron motherboard which got a CPU socket, DDR3 and storage controller upgrade.


                            The skull on the board and its packaging must mean this is a dead board you're buying...unfortunately I didn't think about that before I purchased it


                            Yet another BIOS upgrade to ask for.




                            • 13. Re: Firmware update on DX58SO2 resulting to: A bootable device has not been detected

                              Hi Foxfreejack,


                              I have had various issues in the past related to BIOS and UEFI.


                              1.) BIOS - I had doubts about my BIOS being clean from the last 2 updates (888 and the one previous) - suspected that some of the settings from the Extreme Tuning Utility were still lurking. I initially updated to 888 with the Windows install - no problems. However had some weird issues. Re-flashed 888 with a USB key and the F7 method - was still not happy. Finally did a full BIOS recovery - left the battery out over night and used the "jumper" to force an update. This time it looked good - everything back to default state same as when I first got the board. Only issue I had was that I screwed up setting the date (mm <==> dd reversed). I wanted to make sure the BIOS seemed "clean" before I ordered an Lsi 9265-8i RAID card.


                              2.) My initiall install was to a 120 GB Intel SSD (Elm Crest) in MBR mode. I converted to UEFI on my Hitachi spinners (Raid 1 initially) using Paragon Migrate to uEFI. Worked pretty well - but the "links" in the Windows Libraries set-up in the user home were broken. Never bothered to fix since I intend a full re-install once I have finished playing with the various pieces I have been changing. At this point I had not installed to UEFI from the Windows DVD. I now had 2 copies of WIN 7 to boot - MBR from the SSD or UEFI from the RAID hard disk (Raid was via the Intel controller using RST).


                              3.) I found a good deal on 2 more matching Hitachi spinners (2 TB 7200 SATA III) and when I finished testing them I wanted to convert my RAID 1 to RAID 10. Backed everything up and created a Windows system image (luckily I still had the WIN 7 SSD to boot !). Deleted the RAID 1 and created the RAID 10 (many many hours for that to initialize). Booted one of the copies of the Windows Recovery DVD (After almost 40 years computer OS support I trust nothing - so I had multiple copies). Booted OK - but would not restore!!!!


                              4.) Two (2) days of frustration:


                              Keep in mind - I have a legitimate key (not an OEM key) for Windows 7 64 Professional.


                              I do not remember now all the things I went through to finally get the restore to work but a few points:


                              At one point I tried booting from an OEM Win 7 install CD (with SP1 - my CD is pre-SP1). Seems it did NOT have a UEFI boot set-up on it - looks like not all Windows install DVD are created equal. Lesson learned - the install DVD must be UEFI capable and must be booted in UEFI mode. Use the "F10" during post to get the BIOS to display a list of bootable images. If UEFI is set in the BIOS the list will clearly indicate which of the boot images are UEFI. The DVD I downloaded from MS Tech net at work with SP1 on it was listed twice in the selection list - one "regular" and one UEFI.


                              Do not use a disk that is initialized with an MBR - seems that Windows install will not convert it to  a GPT disk. The EFI partition will only be created on a disk that is initialized as a GPT disk (found this out at one point trying to restore to a non-RAID disk - still unsuccessful at this point). Lesson learned - do not try to install Win 7 to an initialized MBR disk if you want UEFI. Use a disk that is already initialized as GPT or a disk that is not initialized.


                              After almost 2 days of frustration and countless boots (after each attempt I would have to swith to non UEFI boot to boot from the SSD and get on the net to surf more bulletin boards and try to get help). Even used the command shell from the recovery DVD to create all the necessary partitions on the RAID 10 disk (almost 4 TB so it was a definately a GPT disk - but Windows restore insisted that there was no valid disk to restore to. What finally did work - I did a very quick and dirty install on the RAID 10 disk from the UEFI capable SP1 install DVD - did not even bother to change the partition size so it had an almost 4TB "c" drive. Shutdown and booted the recovery DVD - and restored the image in about 12 minutes!!! It even re-allocated the "c" partition back to the initial size. Lessons learned - test your recovery BEFORE you really need it. Things that should be simple and straight forward are not always so on Windows (I could re-install my 50+ AIX servers at work from scratch in less time than it took me to recover my Windows system !!).


                              Try installing making sure your install DVD is UEFI boot capable to a disk that is initialized as GPT or is not initiliazed at all. Another thing I have been using with all the hardware changes I have been doing is to put the BIOS "stop" in place - stops during POST with an option to enter BIOS set-up or continue with boot. Use the F10 key to force the BIOS to give you a list to select the boot device from - this way you can ensure that you are booting the DVD in UEFI mode. Also ensure that your disks have time to spin up and be properly seen - had an issue way back that the POST was so quick that the disks were not spun up in time to be recognized by the BIOS. I have a 5 second delay set (display the splash screen for 5 seconds). Try supplying the latest controller drivers (either Intel or Marvell) for the SATA port your disk is on (option to load drivers during Windows install set-up). Even if they are supposed to have support in Windows install I prefer to supply the latest ones from Intel driver download.

                              Let me know if any of this helps ....


                              Demented (from the Great White North).

                              • 14. Re: Firmware update on DX58SO2 resulting to: A bootable device has not been detected

                                Hi Again Wants....


                                See some pointers in the previous post I just put on this thread. Since I did the BIOS recovery I have not had any issues that look BIOS related (still do not see any options for ECC). I have made substantial hardware changes since then with no problems - swapped 12GB for 24GB (no overclock) GSkill out and GSkill in (neither listed on the official support list). Received my Lsi 9265-8I last week and have been playing with it since then (4 x 120GB Patriot Wildfire and 2 x 120GB Intel Elm Crest). Can you spell F - A - S - T. Lots of issues with RAID cards (especially the Lsi MegaRaid cards) in the PCIE "graphics" slots on X58 motherboards prior to BIOS 888.


                                For the ECC issue - have you opened a ticket with Intel and asked them directly. In the past (PIII days) I used Crucial ECC memory on an Intel 815 based board - with a Celeron processor the ECC did not work. When I swapped in a PIII the ECC was enabled. For the X58 chipset the memory controller is part of the processor chip - not the MB chipset. Have you tried running something like Memtest http://www.memtest.org/#screen - the memtest screen indicates if ECC is enabled or not.


                                For UEFI ... your problem looks like a symptom of a Windows DVD that does not have a UEFI boot capability. Is it an OEM version? So far I have only seen MS ($$) versions of the Windows DVD that have UEFI boot. I was fortunate that I obtained my DVD and key when I took some Windows Vista & Srever 2008 courses from an MS certified training partner (local community college).


                                Another $0.02 (Canadian) worth .....



                                1 2 Previous Next