1 2 3 Previous Next 36 Replies Latest reply on May 15, 2012 7:29 PM by tpi2007 Go to original post
      • 30. Re: SSD Toolbox can't communicate with Intel SSD nor HDD in SATA RAID

        Parsec and Dave-Thank you, all the information you provided and time spent is truly appreciated.


        I too have experience with older version of the SSD toolbox along with other chipsets and am discouraged the X79/c600 chipset does not support the intended features of the SSD toolbox.  I have two x58 boxes with identical storage as the X79.  One Intel SSD for OS and some programs, One CD/DVD, and four 500GB drives in raid 10 partitioned as E and F.  All plug into to the same sata ports 0=SSD 1=CD/DVD 2,3,4,5= Hard drives.  All boards have most current chipset drivers for the option rom (CTRL + I), and the rapid storage manager application.


        X58 chipsets work as expected, no problems, all toolbox functions available and operational.

        X79 chipset exhibits problems as reported.


        One other peculiar bit of info. When installing Windows 7 professional with the sata ports configured as raid in BIOS, the install requests a driver for the storage device as no storage devices can be found.  The driver needed is the "F6" driver associated with the Rapid Storage Technology Enterprise application.  Found that out the hard way-trial and error as the available documentation does not state specifically that the "F6" driver is needed for a X79 chipset with sata configured as raid, even though the SSD is not in a raid array.


        The response from tech support was a bit vague as it appears the rep is not familiar with the X79 chipset.  I cannot independently change the sata mode for each or any of the 6 ports.


        Hopefully Intel will identify this inconsistency and come up with a proper fix.  As I mentioned to support, much time was spent researching the available products and I chose a Intel solution based on the available documentation, my interpretation of that, my experience with Intel and their reputation for rock solid products,


        Once again, Thank you for all the constructive advice and your shared experiences.

        • 31. Re: SSD Toolbox can't communicate with Intel SSD nor HDD in SATA RAID

          You're welcome t53, your posts have added to our information about the X79 platform, and the RSTe driver. I don't have a X79 board, but Dave does (two!), and I'm surprised I haven't seen more about the X79/RSTe issues and the Toolbox, but I must not be looking in the right places.


          Very interesting about the need for a driver during OS installation on the X79 platform in RAID mode. Actually, that is the way it has always been in the past, you had to load the basic iaStor driver when in RAID mode, which is what people still do with Win 7 on Intel 6-series chipsets (P67, Z68, etc, not the C600/X79 chip.) In your case, as long as the SATA mode is set to RAID, Windows will ask for the driver, since it really does not know if a drive attached to it is a single drive or a RAID volume, among other reasons. That was a decision that was made in the Windows installation software's design, and frankly is the correct one.


          I said it's interesting, because I read recently in the Intel RAID/IRST FAQ, that with Win 7 you do not need to load a driver during the OS installation when in RAID mode. That is a nice enhancement. I've never tried that so I don't know if it works, I always load the "F6" Intel IRST driver when that option is presented during the OS install, I didn't know better. Assuming that is correct, that enhancement of Windows didn't last long, at least for X79 boards. I wonder what Windows 8 will do with this?


          The need to load the driver for a X79 board does make sense really, the X79 RSTe driver is a major turn off the smooth path that the IRST driver has been. I use the same IRST driver download file on Intel G45, X58, and P67 chipset mother boards, for both AHCI and RAID modes. IRST/RAID and the SSD Toolbox all work fine on those platforms, with the known limitations of the Toolbox with RAID volumes. The issue with the SSD Toolbox and X79/RSTe must be due to the RSTe driver.


          I have many questions about this in my head, including what will the other 7-series chipsets (that can be used with the first Sandy Bridge CPUs, and others on socket 1155), be using for their RAID driver, RSTe?

          • 32. Re: SSD Toolbox can't communicate with Intel SSD nor HDD in SATA RAID

            I would just add that after reading the response from the Intel tech I am shocked at his lack of knowledge on this subject. He has no right answering the phone if that is his level of expertise.

            I can get my 520's to show in the toolbox just fine, in ide, achi, or even raid mode. Just have to use any driver other that the irste series that's all. Sad that he would provide answers that have no basis in fact, wow.

            Yes sir parsec, you have to load F6 drivers for an install even on W7 or W8 now on the x79. No signed drivers present from MS for raid, how weird is that. Gives us some insight into just how much trouble Intel has had with the x79 don't ya think.


            Message was edited by: Dave

            • 33. Re: SSD Toolbox can't communicate with Intel SSD nor HDD in SATA RAID

              Frankly Dave, that is exactly what I thought about that reply, but since I do not know what the entire conversation was, or the exact question(s) asked of that tech, I kept my opinion and comments to a minimum.


              I'm not surprised about the need to load drivers with X79. Does that mean that msahci does not work with the X79 PCH? Perhaps it's more accurate to say that Intel is having some issues using the X79/C600 chipset and RSTe in the consumer PC environment. It seems the other new 7-series chipsets are very different than X79, but then they are each used with a different CPU/socket architectures, 1155 and 2001.


              Interesting that the 11 series IRST driver (for the other 7-series chipsets) can work with the X79, as you have discovered, although I imagine Intel does not recommend or support that combination. (Readers should note that this combination requires a more advanced, manual driver installation technique, done at your own risk. Or what is your opinion on that, Dave?)


              In a vague way the X79/socket 2001 CPU platform reminds me of AMD's Bulldozer CPU situation, where a CPU that was really designed for the enterprise and server environment was also put into the consumer PC environment, kind of the square peg in a round hole analogy.

              • 34. Re: SSD Toolbox can't communicate with Intel SSD nor HDD in SATA RAID

                I registered because I'm also having problems with RSTe, and no, I'm not using RAID. I have an Intel 320 Series 120 GB SSD and two WD Caviar Black HDDs, one 1TB Sata 3, and one 500 GB Sata 2 for over a year, and recently upgraded to the X79 platform. I'm using an Asus Sabertooth X79 and Windows 7 Home Premium 64-bit edition.


                I have S.M.A.R.T. enabled in the BIOS and SATA is set to AHCI mode.


                I'm using only the SATA ports the X79 chipset provides. The 320 Series SSD is connected to SATA 3 port 1 and the WD Caviar Black 1 TB SATA 3 is connected to SATA 3 port 2, while the WD Caviar Black 500 GB is connected to SATA 2 port 1. I also have the additional SATA controller provided by the motherboard disabled in the Bios given that I don't need more SATA ports.


                I did a fresh install of Windows and initially didn't install Intel's RSTe drivers and all seemed to work well. I installed the latest version of Intel's SSD Toolbox and was pleasantly surprised that it now presents two nice graphs à la SSD Life to show you how healthy the SSD is.


                After installing Intel's RSTe 3.0.03011 that stopped working, and I also couldn't run the Optimizer. HD Tune also couldn't access any S.M.A.R.T. data for either the SSD or the HDDs.


                Intel SSD Toolbox 3.png



                All of this would have probably been ok for now if, for the first time in years, one of my computers didn't have a BSOD, the last time I had a BSOD was with Windows XP if I'm not mistaken, I couldn't take a photograph of it, but I still managed to read "iastor.sys", which is from Intel's drivers.


                I should note that I ran the computer for a few days (can't remember how many) with these drivers, so it didn't BSOD right away. Could it be that RSTe is preventing TRIM from working and therefore leading to these problems ?


                I wasn't doing anything special at all, I was actually watching a youtube video.


                I was using driver version, which I believed were the most  recent ones, except they aren't. Intel has a newer version, which is, that doesn't come in .exe format, instead it comes in a .zip  file, and it looks more like something a developer would get instead of an end user. There isn't even a setup file in the main folder, you have to go to the GUI folder to launch the setup.


                Updating to these latest RSTe drivers didn't allow for the SSD Toolbox to report S.M.A.R.T. values, neither HD Tune either. I didn't experience a BSOD, but then again I didn't stay with these drivers for long, I opted to uninstall them and run the system with Microsoft's generic AHCI drivers.


                Now both Intel's SSD Toolbox and HD Tune work properly, reporting S.M.A.R.T. values for both SSD and HDDs.


                I am disappointed to see that Intel doesn't even say that the RSTe drivers are compatible with the X79 chipset, you have to know that the C600 chipset drivers work. Well, actually, from what I've seen, they really don't, so perhaps Intel should commit more resources to it and release proper drivers for what is the enthusiast platform. In the meantime they should put a note equal to the one you  get when you try to install RST on the X79 platform. Funny enough, some  people manually install this version and it works better than the RSTe.


                Even in the device manager it doesn't say X79 but C600.


                C600 series.png


                It may technically be C600, but then again a Core i5 3570K may technically be a Core i7 3770K with 2 MB of L3 cache fused off and HT disabled, and I don't see Intel calling their CPUs the same. I don't have SAS ports on my motherboard, so this is not the same as C600. Could this also have something to do with these driver problems ? Maybe the drivers are buggy because the X79 chipset has some features disabled compared to C600. These motherboards are not cheap and the platform has been released almost six months ago; I hope Intel releases proper storage drivers for the X79 chipset soon.



                Best regards,



                • 35. Re: SSD Toolbox can't communicate with Intel SSD nor HDD in SATA RAID

                  I feel your pain.  Alot of discussion about the X79 chipset/C600 in this any other sections of the support community.  (SSD, Chipset, Motherboard) sections all have discussion regarding the features or lackof.


                  Here is one that explains some of the mystery http://communities.intel.com/message/155972#155972


                  I use an Intel DX79SI MB/I7 3930k with bios configured as raid even though it also enables AHCI for drives not in a raid set.  Intel 520 240GB SSD in port 0, CD/DVD in port 1, 4 WD Caviar black 500GB drives in ports 2,3,4,5 configured for raid10. In order to use the SSD toolbox with all features available (smart attributes, drive health and SSD optimizer) I must use Intel driver version for the storage controller (C600 chipset). When manually installing this driver in device manager, a windows exception pops up informing me the drive is not valid for the chipset.  However it does work. This also prevents the Intel Rapid Storage Technology Enterprise IAStorUI.exe from running-will not start the GUI.


                  If I use the "recommended C600 driver v I can use the RSTe gui, but the SSD toolbox does not display smart data, health of the SSD, an cannot use the SSD optimizer.  I do switch back and forth ocasionally, but the RSTe GUI has very little value other than some icons of my drive.  It can check the health of my raid10 array and do some detection and repair of physical sectors-maybe, not repair just flagged as bad.


                  The C600 comes in a variety of hardware releases. some are sata, some are sas, some have both.  No conselation though.


                  It is also my conclusion this platform was not quite what I expected. But only the storage controller, which is vital. I went with the Intel board based on my experience as a rock solid platform without some of the added features (bells and whistles) that I don't need.


                  It is curious to note not too much feedback from Intel reps in the forums regarding this problem despite being mentioned in other sections.  Also my discussion with support was fruitless, Seems the support person I opened up the ticket with did not have any valuable or correct information to provide.


                  It really is a shame the limitations of the storage controller.  I've been in the hardware engineering field of IT for over 25 years and have experienced some of the worst nightmares known to the industry and can only say I am quite disappointed.  If I could trade in my $1,200 CPU, motherboard, and SSD, I would.


                  It's hard to say for sure what caused your bsod, but I suspect it was the driver.  Usually is, when the code/driver violates the hadware abstration layer.


                  Good Luck,



                  • 36. Re: SSD Toolbox can't communicate with Intel SSD nor HDD in SATA RAID



                    I think I will install Intel's latest 11 series RST drivers like you described. Microsoft's AHCI drivers work, but I just tried a game that has to fetch a lot of data from the HDD and it stutters every thirty seconds or so. I remembered this behaviour from when I put together a legacy Pentium 3 system a few years ago and I observed the same behaviour until I installed Intel's drivers, which solved the problem.





                    1 2 3 Previous Next