1 2 Previous Next 21 Replies Latest reply on Feb 18, 2013 8:42 AM by merzhinhudour

    Error: RAID array detected... Intel SSD Toolbox

    mmmcdee

      I Just installed my new Intel SSD 520 Series 480GB Drive (SSDSC2CW480A310) and installed the Intel SSD ToolBox.  When I run the SSD Optimizer  I recieve the following Error:  "Error: RAID array detected. If RAID array not present, reboot and try again".  My system is as follows:

       

      Lenovo 4270CTO BIOS: 8BET55WW (1.35 )

      Intel(R) Core(TM) i7-2960XM CPU @ 2.70GHz

      SSD:  INTEL SSDSC2CW480A3 Firmware 400i

      Intel(R) HD Graphics Family 3.76 GB

      NVIDIA Quadro 2000M

      Microsoft Windows 7 Professional (64-bit) SP1

      32GB DDR3-SDRAM (1333 MHz)

       

      I do not have a RAID configuration.

       

      Thanks -

        • 1. Re: Error: RAID array detected... Intel SSD Toolbox
          parsec

          Strange and then maybe not, laptops can have all kinds of odd SATA issues.

           

          Actually, your issue is known to exist on another laptop, a Dell. That is documented in the Toobox Installation Guide, here:

           

          http://downloadmirror.intel.com/18455/a08/Multi-Language_Installation_Guide.pdf

           

          Have you asked Lenovo about this problem? Can you get into your laptops BIOS and see what the SATA configuration is? I assume you tried to reboot, but nothing changed?

          • 2. Re: Error: RAID array detected... Intel SSD Toolbox
            joe

            add to the list an HP pvilion g7-1219wm.  same thing happening with my series 320 120gb...

            • 3. Re: Error: RAID array detected... Intel SSD Toolbox
              parsec

              joe, Sorry to hear that. In other words, you cannot use the Toolbox functions usually available for a single SSD?

               

              In case you don't know, the Toolbox does not offer its usually functions to SSDs in a RAID array, even if they are Intel SSDs. Simply having the SATA mode set to RAID does not cause this, since single (non-RAID array member) Intel SSDs will have all the Toolbox options available to them, they are basically operating in AHCI mode.

               

              Whatever way the Toolbox determines a SSDs configuration, is apparently failing in your case, and for the OP too. Perhaps a protocol not being adhered to, or data missing or corrupted, is causing your issue. Not that you have done that.

               

              If your SSD is connected to a SATA chipset other than an Intel, that usually causes the SSD to be undetected by the Toolbox.

              • 4. Re: Error: RAID array detected... Intel SSD Toolbox
                joe

                thanks for the info parsec.  my laptop has only one drive, and that's the ssd (well, it's also got a card reader and an external usb mechanical storage drive connected, but that shouldn't make a difference).  this drive was formerly in a self-built desktop pc and had no difficulty, but the toolbox was an older version.  this is occurring with ver 3.0.3 of the toolbox, so I may try an older version and see what happens.

                • 5. Re: Error: RAID array detected... Intel SSD Toolbox
                  Kenneth Graham

                  ive the same problem. only ssd installed. set ahci in bios before installing win7. flashed bios with latest. bought programme to get all latest drivers. 3.1.1 toolbox. System is

                                                                       asus m4a89gtd pro m/b

                                                                       amd phenom 11 x4 965

                                                                       4gb ram

                                                                       win7 home edition 64bit

                                                                       ati radeon hd 4800

                                                                       intel 520 ssd 120gb

                  Asus tech could not help. tried everything i know.

                  • 6. Re: Error: RAID array detected... Intel SSD Toolbox
                    oldsow

                    I know for a fact, that these people are not having a problem on their part.  I had the Asus chipset drivers installed, then i updated them with the NEW AMD chipset drivers for my chipset . Mine is set to AHCI in the bios and all was well, toolbox worked.  As soon as i updated the drivers, rebooted the computer and tried the toolbox to run the optimizer,  I got the message that i have an raid array which i do not have.  I have an Intel 320 ssd.  I know what i'm doing on computers so don't even go there.  There is obviously a problem with the toolbox detecting raid , when it should not.  Maybe you all at Intel should setup a computer with a AMD 850FX chipset and see what happens.

                    You will get the same result.  Please let us know when you figure this out.

                    Thank you for listening .

                    • 7. Re: Error: RAID array detected... Intel SSD Toolbox
                      parsec

                      So the Toolbox worked fine on your AMD system (not a given), but when you changed to the new AMD "chipset drivers" (inf files? SATA driver? not clear to me) the Toolbox then sees your single SSD as a RAID volume? That is a common error seen with the Toolbox.

                       

                      Apparently the previous driver communicated fine with the Toolbox, but the new one doesn't. So who's bug is it, driver or Toolbox, chicken or egg?

                      • 8. Re: Error: RAID array detected... Intel SSD Toolbox
                        oldsow

                        Who cares Chicken or Egg, Intel Big Corp.  You sell products.  At least check into it, and quit making excuses.

                        If you don't have anyone there smart enough to figure it out, get someone who can.

                        Why is it that big companys always want to blame someone else instead of doing some investigating of their own?

                        Don't worry I also put it on an AMD forum too.

                        Hey I got an Idea!  who cares if it all works or not , we got our money.

                         

                        Intel 1  the Consumer little guy  0  again.  Tell me is that why the Ivy bridge Processors run Hot?

                        Did we screw up and put the wrong compound on the processor?  Did we fix that too?   NOT.

                        For once give it a try Intel and see where the problem is.

                        • 9. Re: Error: RAID array detected... Intel SSD Toolbox
                          Lophiomys

                          Same here, suddenly happening on a previously smoothly working system.

                          The Problem is, that I DID NOT DO ANY CONFIGURATION on the system.

                          Probably since one week (the last Windows Update) the system first time ever became slow and jittery.

                          Then I want to run the Intel SSD Optimizer as a remedy, and it gave me the

                          Error: RAID array detected. If RAID array not present, reboot and try again. .

                          Absolutely strange. There is no raid whatsoever!

                          Any access to the SDD is slow, and Process Explorer shows "Interrupts and DPCs",

                          while atapi.sys (Intel 14.11.2003, v5.1.1.1001) uses time in the range of milliseconds (RATTV3)!

                           

                          IBM Thinkpad T42p - Intel 82801DBM Ultra ATA

                          Intel 320 1.8" FW 4PC10362 , SMART OK, 1.5 GB free

                          Windows XP, sometimes  ATAPI 9 Errors in System Event Log,

                           

                          Besides, what I have done to exclude a hardware failure.

                          I exchanged the PATA to SATA Adapter in front of the SSD against another hardware piece, no change.

                          I re-installed the old, original HDD (with a one year old status of Windows XP) into the T42p,

                          and everything worked fine without any ATAPI 9 errors.

                           

                          So it is either a slowly dying Intel 320 SSD or som sort of  a bizzare Windows driver problem.

                           

                          Any ideas?

                          • 10. Re: Error: RAID array detected... Intel SSD Toolbox
                            Lophiomys

                            In my case reported above, the source of the problem was, a MicroSoft "feature".

                            For some unknown reason it downgraded the SSD at IDE Port 0 to PIO MODE (from UDMA 5),

                            which caused it to become very slow  ("Interrupts and DPCs" at 80-99% in Process Explorer, caused by atapi.sys).

                             

                            In Windows XP Control Panel, System, Device Manager uninstalling the driver for the IDE Port 0

                            and rebooting twice, as adviced by the system, resolved the problem.

                            The  SSD 320 is now in UDMA 5 again, performace as before, and Intel SSD Toolbox is not complaining

                            about a non-exising RAID: what a poor software!

                             

                            see

                            IDE ATA and ATAPI disks use PIO mode after multiple time-out or CRC errors occur

                             

                            Hopefully the Intel 320 is not dying slowly...

                            • 11. Re: Error: RAID array detected... Intel SSD Toolbox
                              cathulu

                              I have the same issue, exact same motherboard, ASUS M4A89GTD PRO, AMD Phenom II X4 Processor, 12 GB Ram, Windows 7 Home Premium.

                              Intel 520 SSD 120GB Firmware Version 400i.  When I check device manager it says INTEL SS DSC2CW 120A3 SATA Disk Device.

                               

                              When I start the Intel SSD Optimizer I get "Error: RAID array detected.  If RAID array not present, reboot and try again."

                               

                              No amount of rebooting will help, I always get the same error, and I do not have a RAID configuration!  I have two other Western Digital hard drives.

                               

                              I paid more for the Intel SSD because I thought it would be more reliable than other SSD drives.  Not sure about the others but the Intel SSD is not reliable.  I still get the occasional computer freeze even after turning off power management features including the hard drive sleep to never etc.

                               

                              Intel, please update your SSD Optimizer so it works!

                              • 12. Re: Error: RAID array detected... Intel SSD Toolbox
                                parsec

                                So you are using a SATA to PATA adapter, which must change so many things, including protocol, and who knows how good a job it does, and to even what SATA standard it supports, and is stuck running in UDMA5. Then the Toolbox software must try to communicate with the SSD through that old interface, and then through the SATA to PATA adapter. It's a miracle the Toolbox can function at all!

                                 

                                But you call it "what a poor software!"? All it takes is one bit to be not correct in the data identifying the SATA mode for the Toolbox or any software that reads that data, for the result to be wrong. But not only is this not a SATA interface, or IDE, but PATA, and then not even that, PIO! As the old saying about computers goes, garbage in, garbage out.

                                 

                                Hopefully your SATA to PATA adapter is not killing your SSD.

                                • 13. Re: Error: RAID array detected... Intel SSD Toolbox
                                  Lophiomys

                                  @parsec: This is just FUD!

                                  a)

                                  This "raid error" happend also to ohters, who have no adapters, nor raid installed.

                                  b)

                                  The HW combination with SATA-PATA-adapter, was working for a year, nearly 24x7.

                                  It passed all HW Tests, and the Toolbox itself did not indicate even one error,

                                  nor  compained about adapters.

                                  For now, I exchanged every bit of hardware (the laptop, the adapter) around the Intel 320 SSD, and errors only occur with this very Intel 320, and everything is fine with other HDDs or SSDs, or binary compatible laptops.

                                  Also Kubuntu 8.04 stated to report, "ata.01 Emask 0x0 ... frozen" errors.

                                  As far as I got with this SSD, it seems, it has a loose contact, which manifests itself whenever the SSD has cooled down to room tempreature over night, and then is rebootet. If it is at working temperature errors only rarely occur. It is also failing with a direct SATA connection in a Win7 machine.

                                  c)

                                  If this PATA/SATA business should be so important, as you write, then the INTEL SSD Toolbox should cope with it. Additionally a quality SSD by Intel should also cope with an adapter. Aggravating, because of the lack of a bootable image running the SSD Toolbox from USB pen drive, one cannot easily test the Intel SSD with the Toolbox.

                                  • 14. Re: Error: RAID array detected... Intel SSD Toolbox
                                    Eric

                                    I'm getting this exact same error and I have no RAID setup.

                                     

                                    Error: RAID array detected. If RAID array not present, reboot and try again. .

                                     

                                    I installed my SSD 520 last week and ran the SSD Optimizer and it ran fine.  Now it is a week later and I went to run it again and I'm getting this error.  I haven't added anything to my system in the last week.  What do I do now?  I've got half a mind to return this drive and go with another brand.  Intel needs to fix this.  ASAP.

                                     

                                    A good work around would be an override button to run it anyway even if the stupid software thinks it detects the non-existent RAID.  I've rebooted 3 or 4 times already.  I've double and triple checked that my BIOS has my drives set to AHCI.   I'm running Windows 8 Professional.  I'm seriously disappointing in the poor quality of the Intel software, I regret my purchase, and I am heading to Amazon (where I bought it) to write a one star review now.

                                     

                                    How long can I expect this drive to last if I am unable to run the optimization?

                                     

                                    --Eric

                                    1 2 Previous Next