1 Reply Latest reply on Feb 6, 2012 5:15 AM by Flying_Kiwi

    Intel DH67BL

    celt_Q

      Hi everyone

       

      I need some help with a motherboard I just installed .

       

      I recently purchased a DH67BL board with an i5 chip on it and 4Gb of Ram .

       

      I am able to use the two blue sata ports on the board but everything else is not being seen by the BIOS . The other 3 being 2 (black ports ports) and 1 (red port) the eSata . I have 3 hard drives that unfortunatelly are not being seen by the BIOS or the OS .

       

      I have updated the BIOS to the most recent one from Intel and also downloaded all the updated chipset drivers as well , and still nothing .

       

      I have installed WinXP SP3 and the BIOS is looking at the sata drives as IDE and not ACHI .

       

      Is there any advice someone can give me about addressing this issue ?

       

      Thank you so much .

       

      Mike

        • 1. Re: Intel DH67BL
          Flying_Kiwi

          celt_Q wrote:

           

          I have installed WinXP SP3 and the BIOS is looking at the sata drives as IDE and not ACHI .

           

          Is there any advice someone can give me about addressing this issue ?

          You'll need to configure the drive controller to AHCI mode in the BIOS and SAVE changes out of there BEFORE attempting to install Win XP SP3. During the install you'll then need to go by the F6 Floppy Intsallation method (search the Intel site for details and read the readme files on the driver download page) or else you need to 'slipstream' these drivers into your Win XP Installation media. Newer Windows versions don't need this special treatment as the drivers are built in.

           

          Not sure about the port details but have your read the motherboard manual to see what that says about things? Is it a B3 stepping board (not affected by the SATA bug)?