12 Replies Latest reply: Oct 25, 2012 12:50 PM by peterti RSS

DX58SO2: cannot change or clear BIOS/UEFI settings

pimzand Community Member
Currently Being Moderated

My DX58SO2 running BIOS version 0876 is currently locked into its current BIOS settings. And the current BIOS settings do not allow me to boot from anything. Most notably, it is locked into UEFI mode and into "load Setup at boot" or however it is called. I did choose these settings at one point, but cannot revert.

 

I can go into the BIOS setup and change what I want, but the board will boot up with exactly the same settings, that will not allow me to boot anything.

 

I tried all the obvious things:

- load BIOS defaults from the Save and Exit menu. Ignored like any other change

- switch the CMOS jumper from normal to clear

- remove the CMOS jumper and reboot

- press the BIOS Back button and reboot

- remove the battery for five minutes

- remove the battery for half an hour

- remove the battery for 8 hours

 

The board warns me that the CMOS battery is bad, and each time says the settings will be cleared. But every time the board comes back in the "press <ESC> for normal startup and <F2> for setup" mode. Every time UEFI mode is enabled. The best result was that the clock was set back to 2010.

 

How it got this far:

 

I was trying to get my Linux workstation to boot from UEFI. I did not succeed booting from either CD or SSD in UEFI mode, but I could boot from an EFI USB stick containing a Fedora 16 installation image. Shortly after that, I noticed the BIOS was stuck, and I could not get back into booting my BIOS-based Fedora 16 installation on my hard disk. I then managed to hack this USB stick into taking over the boot process of my Fedora 16 workstation. That worked. So I achieved my goal, beit with the help of an USB stick.

 

Had I rested at that point, nothing serious would have happened. But then I started using efibootmgr, a tool that should be able to make named boot entries into the UEFI nvram. That did not work and now I am locked out of everything. When I try to boot, I just get a zero "0" somewhere in the down right corner of the screen.

 

The UEFI nvram ought te be cleared in the same way as the BIOS settings, and none of these are possible right now.

 

Is my board bricked?

 

Thanks,

Pim

More Like This

  • Retrieving data ...