10 Replies Latest reply on Dec 5, 2012 5:17 AM by Ziad Aghar

    DH67CF and USB3 Problems

    Y_Fenni

      I have just put together a nice little PC based on the DH67CF - nothing fancy, just straightforward - see below. Everything is working as it should except for the external USB 3 ports. I have a Western Digital My Passport USB3 external disc on which I store my data, music etc. Essentially, the USB3 ports 'freeze' during use and stop working. Once this happens, it also affects the USB2 ports. Either port type doesn't recognise my disc is plugged in.

       

      'Freezing' happens when the external disc is attached and file copying is taking place. One of several things can then happen. Firstly, and more often than not, the file copy dialog box will appear stuck - no progress occurs. It will remain 'stuck' copying the same file and won't respond when the action is cancelled. The only solution then is to reboot the system as Task Manager won't end the process. When rebooting, the system will then hang on the 'Shutting Down' or 'Logging Off' screen and will only respond to the off switch. On reboot the system will go no further than the Intel flash screen and will hang showing 'EB' in the lower right - it won't proceed to show the boot options nor will it respond to Alt+Ctrl+Del. So, a second switch off is required to get the system to boot properly.

       

      Secondly, at other times, copying will stop and Win7 will show a dialog box with the message, 'Items not found. Could not find this items. This is no longer located in [source drive/directory]. Verify the item's location and try again.' More disturbingly, when this happens all the directories on the USB disc appear to be empty. This is resolved once the system is rebooted.

       

      If I delete the USB3 drivers from Device Manager and just use USB2 the system *seems* to work o.k. But what puzzles me most about this is that I installed an Asus U3S6 adapter in my old system (Intel DX38BT) to give USB3 support and never had a moments trouble from it. Brilliant speed with my disc and very solid. The DH67CF and U3S6 both use a Renesas chip to provide USB3 support, so I can't understand why there is a problem. I have tried earlier versions of the Renasas driver, including the one for my U3S6, but the problems still occur. The original driver was the Intel v.2.1.28.

       

      Any ideas anyone? I don't want to have to leave the USB3 off - it defeats the object of buying this board or indeed a USB3 disc. I am a bit disappointed really. I have only ever used Intel boards and have never had a problem before, which is why I chose this one. Your advice will be much appreciated.

       

      Thank you.

       

      ====== Board ======
      Manufacturer                       Intel Corporation
      Product Name                       DH67CF
      Version                            AAG10215-206
      Serial Number                      BTCF14200217
      BIOS Version                       BLH6710H.86A.0146.2011.1227.1631
      BIOS ROM Size                      1024 KB
      BIOS Release Date                  12/27/2011

       

      ====== Processor ======
      Manufacturer                       Intel
      Processor Name                     Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz
      Processor Speed                    3.3 GHz
      Stepping                           7
      Form Factor                        Socket LGA1155
      Hyper-Threading Technology Status  Enabled
                                        
      ====== Memory ======
      Error Correction                   None
      Maximum System Memory              16 GB
      Memory Slots                       2
                                        
        ---- DIMM1 ----
        Socket Designation               DIMM1
        Current Memory Type              DDR3
        Installed Size                   4096 MB
        Memory Speed                     1333 MHz
                                        
        ---- DIMM2 ----
        Socket Designation               DIMM2
        Current Memory Type              DDR3
        Installed Size                   4096 MB
        Memory Speed                     1333 MHz
                                        
      ====== Onboard Devices ======
      #Device Type                      Video
        Device Description               Intel(R) HD Graphics Device
        Device Status                    Enabled
      #Device Type                      Ethernet
        Device Description               Intel(R) 82579V Gigabit Network Device
        Device Status                    Enabled
      #Device Type                      Sound
        Device Description               Realtek High Definition Audio Device
        Device Status                    Enabled
                                        
      ====== Hard Drive ======
      #Model                            OCZ-AGILITY3
        Max. Transfer Mode               UDMA 6 (ATA/133)
        Active Transfer Mode             UDMA 5 (ATA/100)
        S.M.A.R.T. Status                Enabled
        Size                             55 GB

        • 1. Re: DH67CF and USB3 Problems
          odakim

          Run "USB 3.0 Host Controller Utility" (comes with driver) to check the firmware version of the USB 3.0 host controller. If it it lower than 3028 then you might be able to solve your issue by updating the firmware.

          • 2. Re: DH67CF and USB3 Problems
            Y_Fenni

            Thanks for your reply. The Utility shows the firmware as 3024. Where would I find an update? Thanks for your help.

            • 3. Re: DH67CF and USB3 Problems
              odakim

              You can download the firmware update here. I updated from firmware version 302x to 3028 and have no issues with both my USB3 external disks.

              • 4. Re: DH67CF and USB3 Problems
                Y_Fenni

                Thanks for the link. I tried that out too, but no change: still the same problem.

                 

                Regards

                • 5. Re: DH67CF and USB3 Problems
                  Y_Fenni

                  Well, I solved the problem myself in the end (he says with fingers crossed). As I said in my initial email, the disk had worked brilliantly off an ASUS U3S6 adapter in my DX38BT. So, with a flash of inspiration, I whipped out said card. I then removed all the USB 3.0 drivers from the DH67CF and put the card in the PCI-X slot. Logic going - if my disk works off the old card, then it's the DH67CF's chip that's at fault. Once installed, I then added the controller software from the ASUS CD disk. Result - brilliant! Copied huge gigabyte single files, gigabytes of small ones and big ones from external disk to internal and back. Not a single problem. So, just for luck, I then plugged the external disk again into the onboard USB 3.0 ports. I carried out the same copying routines and not once did the port freeze, crash or otherwise screw up. It worked, and still is working, perfectly! So, it wasn't the chip at all, but the controller driver provided by Intel (v. 2.1.28). The Renesas chip is working on the ASUS driver v.2.0.4.0 and firmware v.3028.

                  • 6. Re: DH67CF and USB3 Problems
                    jessgade

                    Im experiencing the exact same symptoms and problems.

                     

                    Ive upgraded the firmware to the latest version shown below

                     

                    Firmware.jpg

                     

                    Initally I used the original drivers provided by Intel - but the system (disk I/O) froze up constantly.

                    I've then installed the ASUS driver when I discovered this thread - and that one has proven to be much more stable.

                    But Im using several USB3 disks and Snapraid (software raid) which are very I/O intensive and the system STILL freezes .

                    Which totally destroys my intension of using this board as a media server :-(

                    • 7. Re: DH67CF and USB3 Problems
                      harishu

                      hard drives connected to usb3 looses connection.

                       

                      DH67BL with bios 0150

                       

                      usb firm 3.0.2.8

                       

                      win 7 64bit

                      • 8. Re: DH67CF and USB3 Problems
                        hp79

                        I have the exact same problem (losing disk when copying a lot of data from Seagate GoFlex USB 3.0 2TB drive) with my USB 3.0 ports on the back of DH67CF. I'm on intel's driver 2.1.28.0, firmware 3025. I'll try upgrading the firmware and driver from renesas/nec.

                         

                        Edit:

                        I got the firmware updated to 3028. From that Renesas/nec download link, I had to download "Firmware Version 3.0.2.8.0.8 (Windows 32 & 64bits)". None of the more recent ones worked. So I now have firmware 3028. For the driver I downloaded "Version 2.1.36.0 Pour Windows Xp/Vista/7 32/64bits" and it installed fine. I'll have to see if it exhibits the same problem.

                         

                        Edit2:

                        After both the driver and firmware update from Renesas, I am not having any problems. I wonder why intel.com doesn't have these updates because I'm sure many more people will be having the same problem and probably think it's the USB3.0 device's fault or the cable's fault.

                         

                        Edit3:

                        I'm seeing constant drops when moving around large files. This intel board really sucks.

                        I'm on bios 0156, usb driver 2.1.36.0, firmware 3028. Maybe I'll try the Asus driver.

                         

                        Edit4:

                        So I got really ****** off at this USB 3.0 problem and decided to try a replacement. Spent $25, got the replacement, and still had the same problem. This time I also installed Intel Desktop Utilities, and once in a while I see a popup warning saying CPU core voltage is 1.66V. I think it's a fluke so I'm ignoring that at the moment.

                        Then I tried updating the firmware with "Firmware Version 3.0.3.4 pour uPD720200 (Windows 32 & 64bits" dated 9/7/2012 (I think this is July 9th, 2012 version), and so far had no problems moving 16 GB of data from my WD 3TB external HDD. So current driver version is 2.1.28.0 from intel, and firmware version 3034 from station-drivers.com. I also have the "Disable USB 3.0 power management functions" checked.

                         

                        Edit5:

                        While trying to copy 50GB of photo, it fails to copy after about 300 MB. Then I can read the directory/file structures, but can't read anything! What a junk motherboard.

                         

                        I'm NEVER EVER going to buy another intel desktop board again!!!!!!!!!

                        • 9. Re: DH67CF and USB3 Problems
                          hp79

                          Did anyone ever get this motherboard's USB 3.0 ports to work rock stable in Windows 7?

                          • 10. Re: DH67CF and USB3 Problems
                            Ziad Aghar

                            I had the same problems on the P-67 Chipset "DP67BGB3", so I had them disabled.

                            However, I am currently on the X-79 Chipset "DX79SI" & they are working flawlessly.

                            Stressed them with an external SSD & still working on win 7 64 SP1

                            Currently have a 600GB WD VelociRaptor connected via a NewerTech Voyager SATA drive docking

                            Driver Version:2.1.27.0

                            Firmware Version:4015

                            @Y_Fenni

                            Maybe if you try updating to firmware 4015 things will work but don't go above driver version 2.1.27.0

                             

                            Update:

                             

                            Updated my firmware to version 4015 on the DP67BG board & they are working now.

                            tbh I haven't done a stress test just a wireless keyboard & mouse connected in one & an external HDD USB 3.0 in the other "they are working"

                             

                            Hope it works for you

                             

                            Message was edited by: Ziad Aghar