2 Replies Latest reply on Jan 10, 2012 10:29 AM by ILasse

    Network driver problem with Z68 MB

    ILasse

      Hi,

      I've built a new PC to use as a WHS 2011 server.

       

      The PC is based on a ASUS P8Z68-V Pro/Gen3 MB, Intel Core i3-2100 CPU, 4 GB RAM and a 60 GB SSD as the system drive.
      I followed the instructions on various fora to circumvent the 160 GB limitation and it worked really well.

       

      The MB uses the Intel Z68 chipset. It also uses an "Intel 82579 Gigabit LAN - Dual interconnect between
      the Integrated LAN controller and Physical Layer" for the network.
      I don't know how much importance the 82579 chip contra the integrated part has to the driver problems.

       

      After the WHS-installation had restarted a couple of times it continued with an installation (checker?)
      and complained about missing network drivers, giving me an option to install them.
      Through the device manager I saw that several devices where missing drivers, which didn't surprise me.

       

      I had previously downloaded all driver packages I could find on ASUS support pages for the MB and the nearest OS,
      which in this case was Win 7 x64 since no server OS appears as a choice. Otherwise the best choice of nearest OS

      is Windows Server 2008 R2 x64.

       

      I tried to use the downloaded driver packages in various ways to no avail, at least as far as the network drivers go.

       

      This happens with the downloaded driver packages:
      -When running an ASUS written installer it just says the OS is unsupported and quits.
      -when running an underlying set-up program (which I guess the ASUS program would have started) it sometimes works and sometimes not.
        It never works in the network driver case (even in compatibility mode).
        The setup program starts and after a while it stops and says it can't find any Intel network adapters.
        To me this sound like its searching for a network card instead of the integrated network device.

       

      I've downloaded and tried various things from Intels webpage. The chipset drivers (besides the integrated network) seem to be solved this way.

       

      The non-Intel drivers (ASMedia, JMicron, Marvell and Realtek) almost works.
      I think one of them destroys the installation but I haven't found out which one yet.
      (I'm getting used to fixing the cfg.ini file by now  )

       

      Anyway, after all this I wonder if anyone has any idea whats going on here?

      Is there some Intel Win 2008 R2 x64 driver I haven't found?

       

      Ohh, and I have asked ASUS support as well, though I think this will be a better place to ask.

       

      I'd be very glad for any help on this
      And do tell me if I've missed any important information

       

      Regards
      / Lasse