1 Reply Latest reply on Jan 1, 2012 5:04 PM by 2700k

    I7 2700K EIST + TURBO DISABLED BY BIOS

    2700k

      Automatically - despite saving the changes to enable turbo + eist.

       

      I recently upgraded from i7 2600 to i7 2700k on a foxconn rattler motherboard. In the Bios when enabling turbo it shows 38 37 36 35 for all cores when it should be 39 38 37 36. I manually set the numbers for turbo to match the specs of 2700k and click "save changes". Then the system reboots and reverts back to disabling these features. I can see the processor identified in Bios, however I can't save the settings both for the CPU and "incidentally" RAM's timings.

       

      When I downloaded Intel's Turbo Boost monitoring tool, it reported that there's no Intel CPU to paraphrase that therefore the installation did not continue.

       

      I can save voltages, time and other things but for the life of me cannot enable turbo + eist. I've monitored the CPU in the Windows 7 experience index and also tried other apps that should trigger turbo - none did. Turbo does not work, the CPU can stay idle since Windows 7 is set to balance mode.

       

      How can I "force" the bios to save the setting?

       

      Thanks.

        • 1. Re: I7 2700K EIST + TURBO DISABLED BY BIOS
          2700k

          OK I needed to flash the bios - problem solved.

           

          A question for OC mavens if you please:

          Since Foxconn does not have a core multiplier option how are some people able to OC their systems with SandyBridge. This person claims over 5ghz benchmark which is hard to swallow since Foxconn's BIOS are notorious for not having a "core multiplier" option yet they still support i7? I tried to up the FSB at 106 and the system collapsed. False advertising? Am I missing something?

           

          There is no core multiplier in their BIOS. What mb would you recommend for OCing an i7 2700k? Not looking for extremes, I really respect the chip and want to boost it up to 4.4 ghz for stable operation.