2 Replies Latest reply on Jan 2, 2012 1:12 AM by nannaloora

    Computer with DP55KG no longer boots up.

    nannaloora

      Somewhere around a week ago, my computer had issues turning on. First the power button seemed to do nothing, and then when it responded, the power light went on but the computer didn't boot up.

       

      At the same time my extension cord, the one the computer was connected to, had a brief moment of quickly blinking between being on and off.

      Well yesterday, after a week of being able to use the thing as before, there was just suddenly no more response to pressing the power button. I tried changing the power cable, and tried connecting it directly to the socket in the wall. At some point, I managed to get the power on once: The bootup splash screen (with the motherboard info) showed up. However, after maybe 10 seconds, it went off again and didn't come back on again. No BIOS startup screen, no nothing.

       

      The PSU is not completely broken, since when I have the power turned on from the I-O-switch in the PSU itself, there's a green light in the motherboard. Also, when I flick that switch, the fans take a quick roll and there's a flash of blue light.

       

      I read something about the possibility of a broken power button. There's a power switch directly in the motherboard to replace the one in the front panel. Tried that, no help. What also hints to the power button working is that when I have the PSU power switch turned on, pressing the front power button sometimes does the same thing as pushing on the PSU power switch: The fans roll and there's a blink of blue light.

       

      Tried removing everything but the motherboard. To no avail. Just in case, as suggested elsewhere, tried overriding the power switch by putting a screwdriver between the two pins for the power switch. To no avail.

       

      I'm going to try borrowing a PSU from somewhere to see if my problem lies there. However, all kinds of helpful suggestions are welcome.

       

      My motherboard is an Intel DP55KG with a i7 860 processor. The power is Enermax Pro87 500W. Cased in a Fractal Design R3.                   

        • 1. Re: Computer with DP55KG no longer boots up.
          Flying_Kiwi

          nannaloora wrote:


          I'm going to try borrowing a PSU from somewhere to see if my problem lies there. However, all kinds of helpful suggestions are welcome. 

          Your hunches are exactly on the right track. Problems with unreliability turning on leading to eventual total failure to power up are classic signs of a failed PSU. PSUs are actually the most common part to fail in desktop computer systems and during my time working as a computer technician in a school, that was definitely the part I changed most often (followed some way behind with hard disk drives). Fortunately you have a well known brand but they can be a great pain if they're a poor design and if they fail spectacularly because in that sort of situation they sometimes end up taking other parts with them. Modern, well designed PSUs have all sorts of protection measures built in to help minimise the chances of this happening though.

           

          Make sure the replacement PSU has adequate power for your system and you should be up and running again. You mentioned you noticed the extension light was flickering - if you are having problems with an irregular power supply, you should definitely consider buying an Uninteruptable Power Supply (UPS) which will keep your PC running in the event of power cuts or brown outs (at least for a few minutes, long enough to safely shut it down) A UPS will also help reduce the strain on the PSU during normal operation by providing a smooth stable power supply to the PSU at all times. If you want to be really safe, you could also buy a surge suppressor and put that before the UPS and that will help protect you if there are lightning strikes or other situations that cause the mains to run in an over voltage situation.

          1 of 1 people found this helpful
          • 2. Re: Computer with DP55KG no longer boots up.
            nannaloora

            Thanks, yes it was the PSU all right. Tried with a friend's unit and got it working. Thanks for your post Flying_Kiwi!