6 Replies Latest reply on Jan 11, 2012 3:11 PM by Flying_Kiwi

    DG45ID onboard RAID broken after BIOS update.

    WoodyTX

      My copy of MS Server 2008 on a homemade box was having hardware failures (no BSOD, no memory dump, nothing but a hard reboot). It's a Core2Quad CPU on an Intel DG45ID board, with 8 GB of Patriot memory. The OS is on a two disk RAID 1 mirror on the Intel ICH10R chip, and the data is on a five-disk RAID 5 via a PCIE HighPoint controller.


      I checked memory for over 24 hours with MemTest, and found a (since lost) note online that a bios revision might make it more compatible with the Core2Quad CPU. Here was my mistake. The RAID was rebuilding after (yet another) failure, but was not rebuilt. The BIOS update (from 0077 to 0135) reset the SATA drives to IDE from RAID, which apparently broke the RAID when I rebooted after the update.


      I can boot from CD and read the C: drive from Windows Server setup, but I can't 'repair' it or boot to it. I strongly suspect I need to re-identify the drives as part of a RAID, but I'm not sure how. Windows Server setup either fails to install the drivers or tells me to use signed 64 bit drivers (which I'm pretty sure I'm doing). I suspect the unrebuilt RAID is preventing the OS from properly writing the drivers...


      I was thinking of breaking the RAID on the Intel ICH10R setup, and then rebuilding it, but I'm not even sure which drive is the 'bad' one (from the OS's point of view). Another option is to slave the RAID drives to another system, and see if it can't repair them from a booted OS (Win7 64bit).


      I have also replaced the power supply and UPS with more powerful devices, since seven drives, a quad core, and eight gig might be pushing a three year old 600 watt PS. These were replaced after the broken RAID.


      Any assistance on this would be greatly appreciated. I'm normally pretty good with computers, but this one has me stumped. 

        • 1. Re: DG45ID onboard RAID broken after BIOS update.
          Flying_Kiwi

          My DG45ID is only running a E8500 Core 2 Duo but I've got 4 HDDs, a TV card, 2 sticks of DDR2 Corsair memory and an LG GGC-H20L Optical drive all working fine with a quality 350 Watt Nexus PSU so I do not think more than 600 Watts should be needed - don't throw the old PSU out before testing it to ensure it definitely has failed!

           

          I recall that very old BIOS updates to current versions on the DG45ID need to have an intermediate step - was yours so affected? How did you perform the upgrade (using which method and was it progressive or in one go)? Even if it did work under your OS, as it's not a supported OS for the board, I wouldn't use the express method - much safer to remove all non-essentials like the RAID card (leave the cables plugged in and just unplug the card from the PCIe slot and tuck to one side - remembler to unplug power from the connected drives though), unplug any non-essential USB devices such as printers and memory stick readers and use the file on a USB thumb drive method. FWIW I'm using 0131 because I've found issues where IDU flags up warnings under 0135 which aren't there under previous versions. It offers nothing newer for my system (and no fix for my E8500 CPU C1 power state related issue) so with 0131 I remain.

           

          What drivers and version of Intel RST are you using for the OS mirror? I found I was getting bogus RAID warnings with earlier versions of RST so I went without any Intel RAID software for a long time. A few months ago I installed the latest version for the series 4 chipset. Since then 10.8.0.1003 and it's immediate predecessor have been working fine with my board - with no crying wolf anymore. Maybe the software you have got installed is getting confused with the RAID card installed so I'd try everything you can with that RAID card removed (as above) to try and get things working again for the bootable volume. My hunch though is that because you interupted it during a rebuild, you may have to reinstall the OS volume. In the end though that should be straightformward enough to reinstall. It's a long time since I last had an RST warning (and my setup is RAID 0+1) but I recall a specific drive (by serial number) was flagged up as faulty (as well as the whole array of course being under threat) in the POST screen - does yours not tell you?

           

          If you do have to reinstall, I'd first break the RAID and reset back to IDE then in order to find out which drive is faulty, I'd download the HDD manufacturers diagnostic software and run it with one drive connected to the PC at a time - it'll soon detect if there's a faulty drive and even when it does, you may find a zero fill (what used to be termed a low-level format) will sort things out nicely and help prevent those repeating RAID errors coming back (if they are legitimate).

          1 of 1 people found this helpful
          • 2. Re: DG45ID onboard RAID broken after BIOS update.
            WoodyTX

            Thanks for the reply; it's pretty much the only useful one I've gotten, after posting this on a number of message boards. When I break 'em, I break 'em good.  :-)

             

            I updated through the OS, probably not my brightest move, but I've been emboldened by success on desktop OSs. Expensive lesson learned.

             

            The RAID card in question is integral to the system; the data is on a PCIE card, and is untouched. The OS drives are readable, but not bootable. I suspect that I just need to write something on the boot sector, and we're back to where we were, but I don't know what to write, or what software to use...

             

            As it stands, I'm using this an an excuse to shift everything over to Home Server 2011. It frankly does more that we need from this box than Server 08, and has less management overhead.

             

            Thanks for the advice on drive-checking. I'll do that before installing MHS11. The PS was replaced; the seven HDDs were the power hog in this system, and according to a few calculators, I was behind the curve with a three-year-old PS.

            • 3. Re: DG45ID onboard RAID broken after BIOS update.
              Flying_Kiwi

              WoodyTX wrote:

               

              I updated through the OS, probably not my brightest move,

              To the contrary, I've found updating BIOS versions through Windows to be a safe way to go - where you went wrong was interrupting things (and if you don't have a backup from just before flashing, that as well). Don't be put off using the Express method with further updates in the future.

               

              The OS drives are readable, but not bootable. I suspect that I just need to write something on the boot sector, and we're back to where we were, but I don't know what to write, or what software to use...

              I can't speak from experience here but I've read of cases where people have performed a repair on the Boot Sector Code within he Master Boot Record and that's got things booting again. If you search for MBR repair or similar, it should yield helpful results.

               

              The RAID card in question is integral to the system; the data is on a PCIE card, and is untouched.

              All the more reason to remove the card from the system when performing any BIOS upgrades or MBR repairs - what's not connected into the system, can't be interfered with.

               

              The PS was replaced; the seven HDDs were the power hog in this system, and according to a few calculators, I was behind the curve with a three-year-old PS.

              Surprisingly, regular SATA HDDs use very little power. You'd think as they have movable parts and a motor they'd hog the power but generally not. I tried a power calculator to get an approximate figure for your system and it suggested that even with 7 HDDs, you'd still get away with a 400 Watt PSU. The big consumer of power in modern PCs tends to be graphics cards. Fortunately the DG45IDs built in graphics hardware is very miserly on power.

              • 4. Re: DG45ID onboard RAID broken after BIOS update.
                WoodyTX

                More fun: I installed WHS2011 and everything worked fine until I installed the Intel RST program, at which point it was back to 'no boot device'.  I reformatted the disks, and am reinstalling WHS2011 again.

                 

                The odd part for me is that the OS recognized the RAID1, and installed just fine. I'm curious if I should try to get a backup, and then reinstall the RST software to see if that truly is what breaks this.

                • 5. Re: DG45ID onboard RAID broken after BIOS update.
                  WoodyTX

                  Last post - I got an error on installing the OS, so I formatted both RAID disks, and got it again.  I am pretty sure I have a failing or faulty southbridge, as both drives check out on their 'long test' diagnostics.

                   

                  If I have time, I may play with swapping SATA cables and ports, but I think this is a lost cause.  I ordered a true server motherboard from Newegg today; it uses the Intel 3210 chipset, and all of the components will fit just fine.

                   

                  Thanks for the information, Flying_Kiwi.  May all your landings be soft.

                  • 6. Re: DG45ID onboard RAID broken after BIOS update.
                    Flying_Kiwi

                    WoodyTX wrote:


                    I ordered a true server motherboard from Newegg today; it uses the Intel 3210 chipset, and all of the components will fit just fine.

                    If you can afford it and circumstances justify it, that's definitely the best option because of course Intels current policy is not to support server operating systems on desktop boards.

                     

                    FWIW I think it's very unlikely your DG45IDs bridge hardware has failed (although possibly it's a cable issue) and if you want to revive it with these drives, you may want to try zero filling the drives (using the DOS utility from a bootable DOS partition) and as mentioned already, swapping cables with known good ones. If you relegate your DG45ID back to regular use with a desktop os and use optical out for your audio, please report the bug with the latest (and all on the website) audio drivers locking up, to Intel tech support. I've done so and Intel/IDT have worked on new drivers but they won't release them signed - very annoying as they are so near and this would solve this problem. Unsigned drivers are a nightmare with the x64 versions of Windows and besides, I expect better from Intel!

                     

                    [Edit: Even though I reported the audio prob to Intel and assisted by testing unsigned newer IDT versions on my DG45ID, Intel didn't notify me they'd released signed new audio drivers last month - these address the above problem. Better late than never as they say.]

                     

                    Message was edited by: Flying_Kiwi