4 Replies Latest reply on Jan 17, 2012 4:17 AM by Vippe

    82579LM won't link at 100 Full Duplex on Cisco 6500 (modules WS-X6148-RJ45V)

    Vippe

      Hello

       

      In my company we have discovered that all the computers we have with the ethernet controller Intel 82579LM (HP Z210 & Lenovo Thinkpad T420) are unable to link at 100 MB Full Duplex when connected to certain Cisco Switch modules.

       

      All the switches have all their ports set to forced 100 MB Full Duplex, and all computers are configured to forced 100 MB Full Duplex.

      This configuration works fine for all other computers in the company (6000+) and also on the other switch modules we have.

       

      On the client computers with the 82579LM we have tried to connect them directly to the switch modules we have and so far this is what we have found.

       

      Switch ModuleClient settingLink speed result
      Cisco 6500 WS-X6548-GE-TX100 MB Full Duplex100 MB Full Duplex
      Cisco 6500 WS-X6348100 MB Full Duplex100 MB Full Duplex
      Cisco 6500 WS-X6148-RJ45V100 MB Full Duplex100 MB Half Duplex
      Cisco 6500 WS-X6148-RJ45VAuto100 MB Half Duplex
      Cisco 4506 WS-X4146-RJ100 MB Full Duplex100 MB Full Duplex

       

      The client computers are all running Windows 7 Enterprise x64 SP1, and we tested this with the default Windows driver and Intel's newest Proset 16.7 (11.13.51.0) & Proset 16.8 (11.15.12.0) but the same result every time. For compability reasons with other equipment the switch ports have to be set at 100 MB Full duplex so that can't be changed. I also tried setting the "Wait for link" to auto, off, and on but no change.

      Also we have checked that the computers we tested on where on the newest BIOS version available from HP & Lenovo.

       

      This is either a bug in the driver or an hardware defect in 82579LM.

       

      How do we fix this? We have about 1000 of these HP Z210 and about 300 Lenovo T420's