3 Replies Latest reply on Jan 17, 2012 8:14 AM by NACIT

    Centrino Advanced N 6230 keeps disconnecting

    jbuy

      I recently purchased a Toshiba Satellite Z830, which has an Intel Centrino Advanced N 6230 wireless adapter.  At first I had trouble with the internet connection, but I was able to solve that by changing the `Power Saving Mode` to `Maximum Performance`. Everything was good, wireless signal was excellent and internet speeds were fast. But recently my connection keeps disconnecting.  The tray icon shows that it is acquiring network address, then it would disconnect from the network, and the icon showing would be the one where it shows that there are available networks to connect.  It continues cycling between acquiring network address and disconnecting.  I`ve tried re-installing the driver and software for the adapter to no avail. Under 'Device Manager', I can see that the wireless adapter is enabled, and apparetly working correctly. I`ve also tried a USB network adapter, and the usb adapter works fine.  Can someone give me suggestion as what to do to fix this issue, or if there is a driver update coming?  Thanks

        • 1. Re: Centrino Advanced N 6230 keeps disconnecting
          lorne123

          I have the same problem, and so far there is no solution, but you can improve it by setting your router bandwidth to 20 Mhz from Auto or 40.

          • 2. Re: Centrino Advanced N 6230 keeps disconnecting
            jbuy

            Thanks but I still have the same problem.  I tried re-installing the driver and software again, everything worked, but the next time I used the laptop the same problem occurred.  Hopefully someone from intel can chime in and suggest some fix or new drivers to install.

            • 3. Re: Centrino Advanced N 6230 keeps disconnecting
              NACIT

              I have the same problem with a Toshiba Tecra R840. I have changed the "Ad Hoc Qos Mode" from WMM disabled to WMM enabled having seen this on another blog for Dell machines with similar problems. The symptoms my user is getting is that his machine is slow to connect to wireless networks and Skype calls etc are disjointed. I also noticed that in Device Manager one of the two WiFi Adapters had a red cross against it for a while but when I looked again it was OK perhaps indicating an intermittent problem. Any light anyone can shed on this gratefully received!