6 Replies Latest reply on Apr 3, 2012 7:08 PM by Wolf6

    Intel DX79SI Raid Issue

    rickwjenn

      Always use Intel MBs and just moved up to a DX79SI with 3960X processor.   Doing the same set up as my DX58S02 with i980X.

       

      No matter what I tried, Windows cannot see the drives in RAID mode.

       

      My bootable Raid device shows up in BIO and in Intel Raid Manager, but no-go in Windows Installation.

       

      Drives ONLY show up in Windows Install when set to AHCI.  Tried cables, BIO re-flash, etc.

       

      Any suggestions?

        • 1. Re: Intel DX79SI Raid Issue
          rickwjenn

          I got the Raid to finally work late yesterday.

           

          My fix reminded of the F6 "load raid drivers" from the Vista days...

           

          1. I set the SATA devices to RAID
          2. Set up the Raid Volumes in Intel Raid Manager (Crtl-I)
          3. Boot Windows ISO from USB (the machine can't see ANY Sata Drives at this point)
          4. Get to the Windows Set up where it asks for drivers because "No drives found"
          5. Load the Raid Driver from the Intel Download site via ANOTHER USB
          6. BOOM - all the drives show up
          7. Loaded WIndows on my new Raid 0 Drive
          8. Life it good.

           

           

          Ran  some more Passmark tests last night.  The 79SI and 3960X Extreme  processor are a good 30% faster than my DX58S02 and 980X setup.

           

           

          Benchmark.JPG

          • 2. Re: Intel DX79SI Raid Issue
            Wolf6

            What raid drivers did you use?  Tried all I could find to no avail.

            • 3. Re: Intel DX79SI Raid Issue
              t53186

              I had a similar problem that has been corrected.  Found thru trial and error and reading all the Intel documentation very carefully, over and over until my head hurt.  Here you go step by step as well as I could write at the time.  The key is to load the drivers for the c600 sata chipset when windows reports no drive availabe to install.  It's just like like th F6 method in older versions of window.  I used the most currecnt versions from Intel DX79SI support site.

               

              Good Luck

               

              My configuration = 1 Intel 240GB 520 SSD and four WD500 GB drives for raid 10

              First, I updated bios to v430

              Need:

              Windows 7 CD, I used clean install of OEM disk with SP1

              USB drive/stick with folder containing extracted RSTE_3.0.0.0320_F6-Drivers (download from Intel)

               

              Insert WIN7 CD

              <F2> to enter bios and configure sata for raid

              <F10> to exit bios and save changes

              Early in repost <ctrl+i> to enter raid configuration utility

              Create raid volume

              Exit raid utility

              Allow Boot from win7 CD, may have to hit any key to boot from CD or DVD

              Install starts

              Error message states no drivers on installation media-browse to media with drivers

              Insert USB and browse to folder “RSTe_f6iaStorA_64” and select

              Compatible driver shows up =Intel® C600 Series Chipset SATA RAID …

              Click next

              Progress bar at bottom indicates drivers are loading

              License terms displays, accept and pull out USB with drivers (if you leave it in and setup restarts it may try to boot from the USB causing install to fail)

              Select SSD (or your drive) for install

              Click next

              Windows 7 starts loading

              First boot during setup showed scrambled graphics so I needed to reboot and continue setup

              Then insert  the Intel CD and load chipset drivers first and any other drivers you may want

              I also had another USB with most current drivers to load as well along with video driver

              Rapid storage technology driver enterprise failed but all other drivers and utilities loaded

              Second boot after installing the CD resulted in scrambled video again, rebooted in safe mode with networking and loaded video driver

              Loaded latest RSTenterprise, it detected 4 drives in raid 10 volume, needed to initialize volume for WIN 7 to recognize. Created two drives (partitions) E: for programs and F: for data, just because I like to separate programs I won’t install on SSD with OS and data.

              Continued load of all up to date drivers and utilities. Ran windows update

              Make a backup and system image of SSD.

              • 4. Re: Intel DX79SI Raid Issue
                Wolf6

                Beginning to think I may have defective board.  Tried everything suggested to no avail.  When set to Raid (using 2 intel 520 series 240GB SSD in Raid 0), hardware sees the raid array but win 7 Ult x64 won't see the array to install.  About to give up and return the board.

                 

                One odd thing, Win sees the 2 SATA DVD drives.

                • 5. Re: Intel DX79SI Raid Issue
                  t53186

                  Well, I've done quite a bit of reading about this particular problem, mostly in the SSD forum.  Officially with the drivers I suggested Intel does not support SSD raid as a boot device.   Or at least that is the conclusion I came to.  You can read more about it in the SSD section. Others have apparently been able to make it work without using the recommended drivers.

                   

                  I thought my board was bad, but refused to give up and was able to load WIN 7 x64 on one ssd configured as raid in bios with 4 hard drives configured as raid 10.  When I did that I had to initialize the raid 10 array before windows could see it, that was after installing windows to a single ssd. It also works when configured as AHCI, but then there is not raid.

                   

                  I still can't get the SSD toolbox to view or optimize my SSD as advertised.  My overall conclusion is either the chipset drivers, or the "F6" array drivers, or the SSD toolbox cannot communicate to the SSD when configured as raid, either one drive or two in an array.  However with my setup win 7 boots and appears to run fine.

                   

                  Sorry for the news, but that's what I have learned.  I doubt you have a bad board.  Nothing stopping you from getting a replacment though.

                  • 6. Re: Intel DX79SI Raid Issue
                    Wolf6

                    Thanks for all the info.  I was trying to move the Raid 0 array of 2 Intel 520 Series SSDs (240GB each) from my Intel DX58SO MB (where they work fine to the new DX79SI.  I can get the new MB to boot with single drive, but want the array to be the boot device. Can't believe Intel has screwed this up so badly for their top-of-line chipset.  Have been exclusively using their boards since they brought out the Extreme series, but after this will likely go back to ASUS or Gigabyte.