5 Replies Latest reply on Jan 14, 2013 6:05 PM by vigen

    Toolbox Version 3.0.1 not working due to non raid on amd laptop?

    esteckis

      I installed my Intel 320 SSD on my HP DM1Z amd-350 processor laptop.  The cleaning function of the toolbox errors out stating that raid is enabled. I called HP they stated my laptop does not have a raid set up. I only have 1 hard drive in the laptop and it is only the Intel 320 SSD.  Is it that intel Toolbox is incompatible with AMD prcoessor laptops?  I downloaded and checked the firmware on the SSD, it has the latest firmware.  Thanks for your help.

        • 1. Re: Toolbox Version 3.0.1 not working due to non raid on amd laptop?
          esteckis

          Ok, I read on other posts that the AMD ACHI controller driver had to be removed and let windows install it's own generic controller driver. The Optimizer worked BUT to let the tool set up a monthly schedule to run caused a critical memory corruption and the tool box froze. (per windows) I restored computer back using AMD controller driver. Intel please fix this toolbox program.  Even though I checked  and trim is active, Intel, please correct this problem or state when buying this product that the tool box optimizer program will not work with AMD.  Thanks

          • 2. Re: Toolbox Version 3.0.1 not working due to non raid on amd laptop?
            wild_one

            That seems incredibly odd, since the Intel 320 Series 160 GB in my Lenovo X120e with AMD SATA driver v1.2.1.252 doesn't seem to have an issue with running.  From the error you got, it sounds like a fluke more than anything else (memory cells can randomly switch, causing corruption).  As much as I might or might not care for Intel, you can't place memory corruption at Intel's feet and expect for them to say they can fix it when it just might be your own hardware that's going bad.

            • 3. Re: Toolbox Version 3.0.1 not working due to non raid on amd laptop?
              esteckis

              Well it's not my laptop because if I use the AMD stata driver it works fine (which is what the laptop came with HP DM1Z) but the Intel Tool box does not work. If I uninstall the AMD sata driver and let windows assign it's own generic driver, that is where the problem starts. My laptop is les than a year old and works fine. If I had known that Intels Toolbox would not work properly with my HP DM1Z, I would not have spent $ 180.00 for this SSD and I could have stayed with my Kingston SSD.  With the AMD Sata driver, Intel Toolbox states it cannot clean because I have a Raid array which I do not and HP verified it.

              • 4. Re: Toolbox Version 3.0.1 not working due to non raid on amd laptop?
                wild_one

                I have no idea why you'd be having this issue at this point.  As long as TRIM is enabled, it shouldn't matter if the Toolbox does or doesn't work outside of looking at the SMART values for the drive.  All I know is that the Intel SSD that I've placed in my Lenovo X120e with the AMD AHCI drivers has no issues running pretty much whatever I want.  Best guess would be even though there's no physical way of setting up a RAID in your DM1Z, the engineer that set up the BIOS/UEFI went and set the chipset to RAID instead of Legacy or AHCI and you can't access that setting to change it.

                • 5. Re: Toolbox Version 3.0.1 not working due to non raid on amd laptop?
                  vigen

                  Hello,

                   

                  The issue is on..

                   

                  With the lastest toolbox version or AMD AHCI driver, the optimiser don't run...

                   

                  "As long as TRIM is enabled" is not sure in this case..Because détecting RAID system..

                   

                  Please fix-it.

                   

                  (bug of one year...^^ )

                   

                  Thanks