5 Replies Latest reply: Apr 24, 2012 1:59 PM by cmamet RSS

HD 3000: Starcraft 2 gamma issue

cmamet Community Member
Currently Being Moderated

Hi,

 

in a previous post I already reported the following bug:

 

while running Starcraft 2, if I use the Alt+Tab shortcut to switch to a diferent program, and if I switch back to Starcraft, then, after a couple of seconds, Starcraft suddenly becomes very dark, making the game practically unplayable.

 

At first I thought this was just a minor issue, I just have to avoid switching from SC2 to a different application.

But, as I'm playing this game more and more, it happened many times that I hit the Alt+Tab shortcut by mistake during a game.

Such a mistake means the loss of the game and no need to say that it's a source of great frustration.

 

Starcraft 2 being in the list of the games officially supported by the HD 3000, I'd like to know if there's an official way to report the bug to intel.

Maybe posting to this forum is enough ?

 

(FYI, I'm running Windows 7 64 bits and the version intel driver is 2509)

  • 1. Re: HD 3000: Starcraft 2 gamma issue
    allan_intel Community Member
    Currently Being Moderated

    Hi there!

     

    I have tested the game myself using default game settings and I was able to play it smoothly. I just made sure to install the latest graphics driver version

     

    8.15.10.2559

    Try downloading drivers here:

    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20676&ProdId=3319&lang=eng&OSVersion=Windows%207%20Enterprise%2C%2064-bit%20version*&DownloadType=%0ADrivers%0A

     

    Thanks

    Allan.

  • 2. Re: HD 3000: Starcraft 2 gamma issue
    messerli_mike Community Member
    Currently Being Moderated

    It seems the Intel driver applies desktop color settings to your game,

    which is a bug, I guess. It was not present with build 2361, as far as I can tell.

     

    I observe the same effect with Bioshock 2 and Gothic 3, Forsaken Gods.

    I dont have it with Oblivion, though.

     

    My System: Core i7 2600K, Intel DH67GD, Win 7 64 SP1, driver build 2559

     

    Once you reapply your brightness settings ingame, it stays that way, until,

    well, you hit Alt-Tab, then the driver enforces desktop settings again.

     

    To sidestep the problem, you could try to change your desktop color settings

    beforce starting to play the game, that is, reset brightness and gamma values.

     

    @allan_intel:

     

    Another bug seems to have been introduced with build 2509:

     

    CPU Test 1 in 3DMark2003 shows a lot of overlapping, black rectangles

    emitting from some airplanes where actually smoke textures should be.

    (Core i7 2600K, Win 7 64, driver build 2509 and 2559)

     

    It seems to be confined to Sandy Bridge, since the same scene looks

    OK on a Clarkdale System (Core i5 661, Vista 64 SP2, driver build 2509).

     

    Hope this helps.

     

    Message was edited by: messerli_mike

  • 3. Re: HD 3000: Starcraft 2 gamma issue
    cmamet Community Member
    Currently Being Moderated
    I have tested the game myself using default game settings and I was able to play it smoothly.

    Yes, the game plays quite smoothly, that gamma issue is the only glitch I noticed so far.

    I just made sure to install the latest graphics driver version

     

    8.15.10.2559

    I installed that new version, but unfortunately it didn't bring any improvement.

     

    Thank you for your help.

  • 4. Re: HD 3000: Starcraft 2 gamma issue
    cmamet Community Member
    Currently Being Moderated
    To sidestep the problem, you could try to change your desktop color settings

    beforce starting to play the game, that is, reset brightness and gamma values.

    I tested that and it works.

    Of course, that's not really the kind of solution I was expecting, but that's better than nothing.

    Thank you.

  • 5. Re: HD 3000: Starcraft 2 gamma issue
    cmamet Community Member
    Currently Being Moderated

    I seems that this bug has been fixed in the 2696 drivers, as well as the quake gamma bug.

    I took time, but that really made my day.

    Better late than never.

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points