3 Replies Latest reply on Nov 25, 2011 8:02 PM by bvz

    d510mo cannot flash bios

    bvz

      I am trying to flash the bios of my intel d510mo board.  I have downloaded the MO0542P.BIO file and saved it to a FAT formatted USB thumb drive.

       

      I boot the machine and hit F7.

       

      It finds the drive and asks me to hit enter.

       

      I hit enter and it finds the .BIO file on the drive (and asks me to hit enter again).

       

      I hit enter again and it prompts me as to whether I really want to flash the BIOS.  I hit "enter" again to indicate that I do want to flash the BIOS.

       

      The computer then INSTANTLY reboots (no pause whatsoever) and goes back to the BIOS splash screen (the one where you can hit F2 or F7 from).  This then disappears for a moment, and then it reappears.  It then disappears again and I get the following message:

       

      The firmware has detected that the system memory has decreased.

      Press the Enter key to continue

       

      I press enter and then I get:

       

      Non-system disk

      Press any key to reboot

       

      pressing enter again then drops me into my normal boot process. At no time did it appear to update the BIOS and checking the BIOS shows that it is still the same as before.

       

      What am I doing wrong?  Is it a problem with my RAM?

       

      Thanks for any and all insight.

        • 1. Re: d510mo cannot flash bios
          bvz

          bump.  Anyone ever run into this?

           

          Even though it appears to not have flashed my BIOS, now my machine is acting all flaky.  Ubuntu stopped working after a bit (it would boot for a day or two after I tried to update the BIOS, but now it refuses to work as long as my RAID array is plugged in).  Occasionally it locks up trying to boot into recovery mode.  I have no idea if this is related, but I need to get a new, clean BIOS on this board to make sure.

           

          I tried the instructions listed here:

           

          http://www.intel.com/support/motherboards/desktop/sb/CS-023360.htm

           

          but when I remove the bios jumper block and boot the machine, I get a completely black screen.  No BIOS messages.  No POST messages.  Nothing.  It is as though the machine were off (but I can hear the fans).  I let it sit for a while (several hours) but when I re-install the jumper and reboot, I'm back to the old BIOS.  Wtf is going on with this machine?  It is making me completely crazy.

           

           

          I was wondering whether anyone had any clue as to what I should do next.

           

          Thanks

          • 2. Re: d510mo cannot flash bios
            bvz

            Oh wow!

             

            Now when I rebooted, I get a blank screen with the letters ZC?gH$ in the upper right corner!!!  (the C g and H are all in red)

             

            Rebooting again seems to fix it (though all the other issues are still there).

             

            I should never have tried to flash the bios on this thing...  Now I am completely stuck and I don't know where to turn to for help.  My google searches have been fruitless and so far nothing on these boards has helped.  The official Intel instructions are obviously completely worthless to me because I followed them to the letter and get nothing happening the way they describe.

             

            Help!

            • 3. Re: d510mo cannot flash bios
              bvz

              Just more info in the saga...

               

              managed to create a bootable DOS USB disk (no small feat if you only have a Mac - and one dead Intel PC)

               

              Downloaded the latest BIOS and the iflash2.exe and tried flashing my bios using that.

               

              Well, it barked and complained:

               

              BIOSID’s do not match
              Currently installed BIOS ID:  blah blah blah
              Attempting to install BIOS ID:  blah blah blah
              Error: Flash update was unsuccessful. Remove diskette and reboot your system to continue.

               

               

              So I decided that maybe I am trying to jump too far from the original BIOS to this one (though why they couldn't tell you that on the website...)

               

              So I downloaded the BIOS version JUST after the version on my board.  I flashed that in the same way and it seemed to get further.  It rebooted and I started seeing messages that it was updating this and that.  Success!

               

              Or so I thought.

               

              Now I have an error that says:

               

              The firmware has detected that a cmos checksum error occurred.

              Press the Enter key to continue.

               

               

               

              Checking the BIOS, however, it does seem to have updated.

               

               

               

              this is the most awesome fun I have ever had.

               

              So I have now downloaded all 14 BIOS updates since the version that is on my board and am applying them one by one using the iflash2.exe under freedos.  Hopefully that works.