2 Replies Latest reply on Nov 23, 2011 5:21 AM by Valentin_N

    Skyrim: Only allows 2 threads on my 4-thread processor?

    BarneeL

      It has come to my attention that the new Elder Scrolls V: Skyrim game only allows the use of 2 threads on my 4-thread i5-2410M processor.

       

      Is there a way I can temporarily disable the 4 threads and convert it to 2, thus allowing the game to gain full access to the full processor?

       

      Thanks!

        • 1. Re: Skyrim: Only allows 2 threads on my 4-thread processor?
          Prof

          There is no need to disable the 'extra' two hardware threads on your processor, as they aren't consuming significant resources and in fact they might be saving you a bit of compute power by handling the infrequent background operations required by the operating system. On a hyper-threaded processor with N physical cores and 2N hardware threads, it is often better to limit the number of 'busy' threads to N for extremely compute intensive applications (like Skyrim). This is because hyper-threading shares the resources of a single core between two hardware threads and if both of these threads are trying to run highly compute-intensive operations they compete (sometimes inefficiently) for the resources of that single core - often ending up running more slowly than a single thread running unimpeded on that single core. So what happens to the other hardware thread if you do this? Not much - it mostly just 'sleeps', servicing the occasional interrupt in the background but consuming almost no resources (and by servicing those background interrupts, it keeps the busy thread from having to switch context to service them). So you're best off to leave things alone and let Skyrim utilize the processors the way it is designed to do...

          • 2. Re: Skyrim: Only allows 2 threads on my 4-thread processor?
            Valentin_N

            What you could try to do is to disable HT, try to play and see if the cpu is on 100%. What gpu do you have? If you have nvidia you should download the latest beta drivers, make sure that the pre-frame rendering is maxed out

             

            Tell me how it goes.

             

            Regards,

                          Valentin N