12 Replies Latest reply on Jan 26, 2012 6:37 AM by Wickham

    Trouble with Intel PRO/Wireless 3945ABG

    jeffvcs

      I work at a K-12 school and have 75 Dell D620 laptops that are experiencing issues with staying connected to our wireless network.  All are running Windows XP SP3 (Updated from SP2), after being connected to a WPA2-TKIP wireless network anywhere from 10 – 45 minutes the PC will disconnect from the network and require a disable/enable of the wireless card or a reboot to regain connection.

       

      The issue is only affecting the D620's with Intel PRO Wireless 3945ABG network cards.  Some of them are the cards that were in the laptops when we got the from Dell, some were added later.

       

      I have updated to the lastest version of drivers available from Intel.  It does not seem to make any difference if I let Windows handle the wireless connection or if I use the Intel PROset tool.

       

      I am primarily running Ubiquity Networks UniFi UAP access points, but I have tested on a Linksys WRT54G and a Linksys E1000

       

      Has anyone seen similar issues with this card?

       

      All of the PCs having this issue display one of the following error message in their System event log, or a version of it, about 3 - 4 times a second, every few seconds, going back for days:

       

       

      Event Type: Information
      Event Source: NETw5x32
      Event Category: None
      Event ID: 5005
      Date:  11/15/2011
      Time:  10:05:46 AM
      User:  N/A
      Computer: I1DL01
      Description:
      The description for Event ID ( 5005 ) in Source ( NETw5x32 ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: , \DEVICE\{9742720F-F9C3-4D6E-B42B-BD94DD0B9314}.
      Data:
      0000: 00 00 08 00 02 00 62 00   ......b.
      0008: 00 00 00 00 8d 13 00 60   ......`
      0010: 00 00 00 00 00 00 00 00   ........
      0018: 00 00 00 00 00 00 00 00   ........
      0020: 00 00 00 00 00 00 00 00   ........
      0028: 48 4d 41 43 20 00 00 00   HMAC ...

      ---------------------------------------------------------------

       

      Event Type: Information
      Event Source: NETw5x32
      Event Category: None
      Event ID: 5005
      Date: 11/15/2011
      Time: 8:32:29 AM
      User: N/A
      Computer: I1DL07
      Description:
      The description for Event ID ( 5005 ) in Source ( NETw5x32 ) cannot be found. Either the component that raises this event is not installed on your local computer, or the installation is corrupted. You can install or repair the component on the local computer, or contact the component manufacturer for a newer version.

      If the event was saved from another computer or forwarded from a remote computer, you might have to include display information with the events when saving them or when setting up the forwarding s , \DEVICE\{606553C9-4178-40B0-A5A8-52CF998D8CAE}.
      Data:
      0000: 00 00 08 00 02 00 62 00 ......b.
      0008: 00 00 00 00 8d 13 00 60 ......`
      0010: 00 00 00 00 00 00 00 00 ........
      0018: 00 00 00 00 00 00 00 00 ........
      0020: 00 00 00 00 00 00 00 00 ........
      0028: 4d 4d 41 43 20 00 00 00 MMAC ...

        • 1. Re: Trouble with Intel PRO/Wireless 3945ABG
          KSMike

          I have exactly the same problem with the same card in a Dell D830.  It was perfect for 2 years and started doing this sometime after I installed SP3 - but I believe it worked fine for awhile on SP3 before it started.

          • 2. Re: Trouble with Intel PRO/Wireless 3945ABG
            jeffvcs

            Interesting.

             

            What version of the drivers are you using?

             

             

            I have a support ticket out with Intel, since I have so many of the laptops.

            • 3. Re: Trouble with Intel PRO/Wireless 3945ABG
              KSMike

              I had tried every combination of drivers & PROSet/Wireless software I could, both from Intel and from Dell (especially since everyone, including Intel, recommends using whatever the vendor supplies).  Nothing I tried worked any better, and some were worse.  I've been getting not only the dropped connections, but also BSOD's upon wakening from sleep or hibernation (usually with "multiple_IRP_complete_requests).

               

              Tonight, right after I replied to your fist post, I discovered that Intel posted v14.2xx back in September.  I've been on v12.x for some time.  I did a thorough uninstall (using Revo Uninstaller in order to get the registry remnants and system files cleaned out), then installed the 14.2 stuff.  It hasn't been long enough to say anything for sure, but just before installing this update I was disconnecting every minute or so.  It's now been a couple of hours and I haven't had a disconnect yet.  Fingers are crossed.

               

              The specific package I installed (remember, this is for a D830, not sure if it's the same for a D620) was "Wireless_14.2.0.10_x32.exe."

              This package resulted in device driver v13.4.0.139 and PROSet/Wireless v14.2.0.0.

               

              It does seem to be important to install both the driver and PROSet/Wireless application that are packaged together in order to avoid incompatibilities between the application and the driver.  For example, for this update I could have chosen between two downloads:

               

              Wireless_14.2.0.10_x32.exe

              Wireless_14.2.0.10_Dx32.exe

               

              The "D" version is the drivers only, the non-D is the drivers and the application.  Just to be safe, I used the non-D package.

               

              How did you do the upgrade to the latest drivers?  I wonder if some remnant of a previous version was still on the machine.  If in doubt, try Revo Uninstaller.  The freeware version is all you need to get rid of every registry entry and file that may have been left.

               

              I'm in IT also, and am very glad I'm not trying to manage 75 machines (and their angry users) with this problem. :-)

               

              Update, I've now been on the 14.2 package for 24 hours and haven't disconnected once.  It's been months since I've been able to do that.

              1 of 1 people found this helpful
              • 4. Re: Trouble with Intel PRO/Wireless 3945ABG
                jeffvcs

                Yeah...managing a lot of these with that issue has been a pain.  At first I thought it was new WiFi equipment that we installed, but when I was able to narrow the problem down to the Wireless card, that was a pretty big red flag.

                 

                I've used both the D version an the non-D version.

                 

                To uninstall, used Add/Remove programs, sounds like I'll have to give Revo Uninstaller a shot.

                • 5. Re: Trouble with Intel PRO/Wireless 3945ABG
                  KSMike

                  Let me know what you find out.  Revo did find remnants both in the registry and in the file system, with every version of the drivers & application that I've uninstalled.

                  • 6. Re: Trouble with Intel PRO/Wireless 3945ABG
                    jeffvcs

                    I did an uninstall with Revo, then resinstalled the lastest drivers.

                     

                    Looks like that did the trick.

                     

                    It's been 3 hours since doing that and the laptop is still connected.

                    • 7. Re: Trouble with Intel PRO/Wireless 3945ABG
                      KSMike

                      Awesome.  I fought this problem for nearly a year and am glad there finally seems to be a solution.  I still haven't had a drop since doing this.  I know there are MANY others fighting the same thing, hopefully some of them will find this.

                      • 8. Re: Trouble with Intel PRO/Wireless 3945ABG
                        jason78

                        Hello, I am having the same problem with the 3945ABG installed on my Dell D830. I downloaded the new Intel Software pack to fix the problem. I unstalled the WiFi Adaptor, deleted the driver. I then ran the Intel Wireless Software Tool. As far as I can tell it did not give me the new driver. It keeps re-installing the old driver which is named netw5v32.sys. I cant figure out what is going on. Can anyone point me in the right direction? I tried to install REVO pro but it does not give me any option to Unstall any of the Intel drivers. This is driving me crazy. Running Windows 7 32bit Thanks!!

                        • 9. Re: Trouble with Intel PRO/Wireless 3945ABG
                          KSMike

                          Did you uninstall Intel PROSet/Wireless using Revo?  It won't ask you if you want to delete drivers specifically, it just scans for registry and file system leftovers from the installation.  If you did that, did you reboot after the uninstall?  That's all I did.  I never got down to the level of even knowing specific driver file names.

                           

                          I will say, I've had about 2 connection drops and 3 BSOD's upon waking from "sleep" since I first thought it was fixed.  I've lived with it since I was having connection drops every 1-2 minutes and BSOD's nearly every time I woke it up.  So it's been dramatically better, but for some reason still not 100% perfect.

                          • 10. Re: Trouble with Intel PRO/Wireless 3945ABG
                            jeffvcs

                            Here's what I ended up doing:

                             

                            1. Install the full Intel driver + WiFi manager package

                            2. Run REVO and fully uninstall it.

                            3. Uninstall the card from device manager

                            4. Reinstall the Intel driver only package (since I'm not using the Intel WiFi manager application in my environment.)

                             

                            It's worked for every PC I've tried this on.  No BSODs, no problems waking up, nothin.  It just works.

                             

                            By installing the driver package first, even though I then uninstall it, it worked better.  I'm guessing it gave REVO something more to hook into.

                            • 11. Re: Trouble with Intel PRO/Wireless 3945ABG
                              jason78

                              Yes, I unstalled the Wireless PRO with REVO and reinstalled the Intel PRO once again, Unstalled it again and tried the drivers only several times with the same result. Not sure what the problem is but I think is something with the new drivers not liking Windows 7so it installs the older driver. It looks like everyone who has got it working here is on XP or Vista. After Googling around, these issues seem to be all too common with this adaptor. I have another Dell D830 with the next newest Intel adaptor running with same Driver and it works fine. Not too happy Intel cannot just provide a Driver for this Adaptor that works with Windows 7 and just "installs" but I guess that is how it goes with an older adaptor. I think at this point I will just spend $20 at newegg and get a USB Adaptor and be done with it. Thanks for the feedback though!

                              • 12. Re: Trouble with Intel PRO/Wireless 3945ABG
                                Wickham

                                Since you have similar symptoms, take a look at this!

                                 

                                Event ID 5002 (many) followed by 5005. Tried updating driver. Newer ones would hang the adapter causing re-boot to reset it; older ones would recover, but still 5002's and 5005 in the log. Only happened when streaming (like watching a ball game, etc.). Bought a Mini USB-connected wireless N adapter for $10 and the problem(s) went away - must be in the adapter or driver(s), I thought! Continued searching for answer (techies do this by nature). 'net searches on OEM sites and general showed MANY folks having same/similar problem with Intel wireless adapters. Decided to try enabling/disabling stuff in my router. Noticed an option for WMM. Researched it on the 'net. Seemed to only apply to streaming, and other bandwidth-hogging xmissions. Was advised that WMM is sometimes called Ad Hoc Qos Mode. Disabled it in the router Was called WMM there). Found Ad Hoc Qos Mode option under the Advanced Tab in the Configuration Option for my 4695AGN adapter. Changed it to WMM disabled! Re-booted and did some streaming every day for 3 days. No more symptoms!

                                 

                                Changed everything back! Within 15 minutes had an adapter hang while streaming! My driver is ver. 13.4.0.139, which is current distribution for W7 64-bit.

                                 

                                I am soooooo happy! Hope this will help you not to go through a month of maddening trials, or throwing out a perfectly good adapter! I still think the driver is not handling something properly, because the older ones (12.0... and below) keep working without hanging, although you still get a boatload of 5002,5's every 1 - 60 minutes in your System event log!

                                 

                                P.S. I am NOT saying this is your problem; but it sure fixed mine!