1 2 Previous Next 18 Replies Latest reply on Nov 6, 2013 5:03 PM by AndyFum

    Fan controll on DQ67EP board doesn't work

    makl

      Hello,

       

      I have some problems with the CPU fan control on my DQ67EP motherboard. Obviously the CPU temperature have no influence on the fan speed. I stress my CPU with 100% so the CPU temperature increase up to 86°C but the FAN doesn't change the speed. Fan speed always toggle between 1278 RPM and 1454 RPM. Because the CPU temperature remains constantly at 86°C (at full CPU load) with no fan speed increasing I assume that the ECU decreases the power dissipation by them selves. Can anyone help me to find out why fan control doesn't working?

       

      I always tried to change the FAN speed with the BIOS configuration "Control Mode <Manual>" and "Minimum/Maximum Duty Cycle 100%" but even then the fan speed doesn't change.

       

      Here some system data and configurations:

       

      Fan:                   Silverstone Nitrogen NT07-1156 (4-pin PWM Fan), connected to CPU header

      BIOS-Version:     SWQ6710H.86A.0055.2011.0921.1044

      BIOS values:     Configuration CPU FAN

                                    FAN Usage <CPU>

                                    Control Mode <AUTO>

                                    Under Speed Threshold <250> RPM

                                    Minimum Duty Cycle 20 %

                                    Maximum Duty Cycle 100 %

                               Configuration Processor Temperature

                                    Over Temperature Threshold 65°C

                                    All-On Temperature 65°C

                                    Control Temperature 60°C

       

      Regards

      Makl

        • 1. Re: Fan controll on DQ67EP board doesn't work
          spearson

          Try this with a different (4-wire) fan plugged into the CPU fan header and see if that fan will speed up properly. You could use the heatsink/fan unit that originally came with your processor for this test. If this fan responds properly, the culprit would then be the Silverstone unit. If not, then there is likely a board issue...

          1 of 1 people found this helpful
          • 2. Re: Fan controll on DQ67EP board doesn't work
            makl

            Hello Spearson,

             

            sorry, for late response. Unfortunately I have no 4-Pin FAN. Because my Motherboard comes with an PC. I have already send the PC back to the PC manufacturer. He said all is fine and send the PC back to me. Shall I by an chep 4-Pin FAN or is there a other options to find out if the failure is located in the main board or in the FAN.

            • 3. Re: Fan controll on DQ67EP board doesn't work
              spearson

              Well, I personally think that there is something wrong with this cooling unit; the temperatures being reached are much too high; likely at the point where throttling is occurring. I consider it likely that the cooling unit is not reponding properly to the PWM signal. If they aren't as concerned as us by these temperatures, you may have to prove it to your manufacturer by testing with a different 4-wire fan. If you cannot borrow one from anyone (though someone you know should have a heatsink-fan unit that came with an Intel processor over the past few years (they were all 4-wire PWM controlled), you can purchase a 4-wire chassis fan to use for less that $10...

              • 4. Re: Fan controll on DQ67EP board doesn't work
                makl

                The Fan is definitely not the problem. I test the fan at the red system header and it works like a charm. The automatic control works like I expect that from a closed loop unit. When I change back to the white CPU header the FAN works only in idle speed. Either the CPU header is defect or the setting in the BIOS are wrong. Which setting must be used to get the CPU header working?

                • 5. Re: Fan controll on DQ67EP board doesn't work
                  spearson

                  From your original posting, it sounds like you have already played with the parameters that can affect this fan. Unfortunately, plugging this fan into another header on the board doesn't prove anything; the other headers have support for handling both 3- and 4-wire fans and it is possible that your fan, when plugged there, is being operated as a 3-wire fan (i.e. not recognized as a valid 4-wire fan and controlled as a 3-wire fan using voltage scaling). This is not possible on the CPU header, however; this header supports only 4-wire fans. This is why I didn't suggest that you try testing this fan using the other headers; the only way to know, one way or another, is to test with another 4-wire fan on the CPU header. I can only suggest that you go back to your manufacturer and have them verify whether the problem is the heatsink/fan unit or the motherboard and replace whichever is necessary. By your description, it is obvious that their assertion that everything is ok is not correct (not if you are seeing temperatures in the Tcontrol range)...

                  • 6. Re: Fan controll on DQ67EP board doesn't work
                    makl

                    Because of the successful system header test, I don't mentioned an additional test I have done. Due to the information you given about the system header I think I should mention this test now. Well, I connected the fan to an 12V (constant) power supply (black and yellow wires) and the PWM input (blue wire) to an frequency generator (25kHz/5V). When I changed the duty cycle the fan changed his speed as expected. There fore I still believe, that the fan is not the problem. Remains only an defect of the CPU header or wrong bios settings which I don't set correct. Can you confirm this?

                     

                    Before I go again to the customer with that problem, I wan't to rule out that I don't make a mistake with the bios settings. Are there additional setting, which I have to consider beside of these one's which I mentioned in my first posting?

                     

                    Playing around with FAN bios settings I'm a little bit confused of the function of this settings. First issue I recognize is that the settings under the menu "Outlet (Rear Header) Fan speed" control the header in the front (red header) of the board. Wrong designation?

                     

                    Is my understanding correct that the setting "Outlet (Rear Header) Fan speed->FAN Usage <PCH>" assign the red FAN header to the chipset temperature setting in the menu "PCH temperature", or is the setting "FAN Usage <PCH>" only for correct labeling in the Desktop Utilities?

                    • 7. Re: Fan controll on DQ67EP board doesn't work
                      spearson

                      I was trying to avoid going down into the details but I guess I will have to. The issue is that, by specification, 4-wire fans are required to provide a pull-up on the PWM signal. We have seen a significant number of cases, however, where fans either do not provide this pull-up or the pull-up is insufficient (i.e. the fans are not compliant with the 4-wire fan specification). In the face of a missing/insufficient pull-up, the fan is going to misinterpret the PWM signal and not respond as expected. Being a software guy, I had to get with the hardware folks to get an understanding of whether your bench test is in any way conclusive. Here was their response:

                       

                      "I can’t really tell if his function generator test is conclusive of the fan having a pull up or not. It would depend on the output buffer configuration of the function generator and how it was connected to the fan. The 4 wire fan spec specifically mentions how to check the pull up resistor. He mentions using a bench power supply and a frequency generator so this test in section 2.2 should be easy for him to perform..."

                       

                      Here is a link for the 4-wire fan specification: http://www.formfactors.org/developer/specs/4_Wire_PWM_Spec.pdf; please look at section 2.2...

                       

                      Ok, back to the software issues. I will presume that you have the latest BIOS installed (update it if you don't). I will have to go back and check whether the BIOS is properly associating the headers with the SIO's PWM controllers correctly; you certainly should not see the front/inlet fan reacting to changes made in the rear/outlet configuration scene...

                       

                      The CPU fan header is controlled based upon the CPU (primary) and VR (secondary) temperatures. The front/inlet and rear/outlet fan headers are controlled by separate PWM controllers, but both are configured to respond to the PCH (primary) and Memory (secondary) temperatures. Response to primary temeprature, from PWM minimum to PWM maximum, occurs over a 15 degree temperature range below the Control temperature. Based upon the Responsiveness parameter, the shape of the control curve over this temperature range varies from directly linear (Aggressive) to exponential (Normal) to very exponential (Slow). Response to secondary temperature is implemented as an upshift in the primary response (the SIO's circuit implements this as an ambient relationship). This follows a linear curve whose temperature range (below the target temperature) varies from 12 degrees down to 8 degrees based upon the Responsiveness parameter.

                       

                      The Fan Usage parameter is utilized only as an indicator of what you are using the fan for. It is a label; nothing more. Changing the Fan Usage should not, in any way,shape or form, affect what temperatures the fan responds to or how the PWM controller implements its response...

                      • 8. Re: Fan controll on DQ67EP board doesn't work
                        makl

                        Indeed, the frequency generator have an push/pull output stage. So I agree to the HW guy that frequency generator test do not prove if the fan has an sufficient pull-up or not. Due to that I made the test described in the 4-wire fan specification section 2.2. This is the result:

                         

                        Voltage between pin 1&4: 1.72V  @Supply voltage 13.2V
                        Current between pin 1&4: 85.1µA @Supply voltage 13.2V

                         

                        Pull-up voltage and current are very small and far away from the specification. So I bring oneself to buy the 4-pin fan "Artic F8 PWM"

                         

                        I also measured the pull-up values for the Artic F8 Fan:
                        Voltage between pin 1&4: 11.96V  @Supply voltage 12.0V
                        Current between pin 1&4: 660µA @Supply voltage 12.0V

                         

                        Looks better and should work. But when I tested I have to recognize that even this fan not response to the PWM signal at the white CPU fan header in the rear area of the board.

                         

                        When I look in the Bios there are only two fan header menus:
                            a) "Processor (CPU Header) Fan Speed"
                            b) "Outlet (Rear Header) Fan Speed"

                         

                        My test shows that a) have no influence at any fan header. b) control the red header near supply connector front area of the board and response to following control temperature:

                         

                        Memory
                        CPU

                         

                        This behavior is contrariety to your last post.

                         

                        So obviously neither the header assignment nor the control temperature assignment are correct. And a) does not work at all may be due to a defect header or a wrong assignment.

                         

                        However I have less delight to go to the customer or make further tests as long as the assignment in the bios is not correct. Please test it by your self. The Bios version is V60 (it is topical).

                        • 9. Re: Fan controll on DQ67EP board doesn't work
                          spearson

                          The acid test is going to be a test using a standard Intel boxed processor heatsink/fan unit. If this works, then the other fans are to blame. If it doesn't work, then you have a defective board...

                          • 10. Re: Fan controll on DQ67EP board doesn't work
                            pmulligan

                            Just bought a retail box DQ67EP and i5-2400 and finding the same problems.

                            With BIOS at defaults, CPU fan idles around 998 -1024 rpm and will not increase when running bench test software.

                            Set the fan control to manual and pushed to 100%. You can hear the fan throttle up and then down during boot, settling in at about 2010 rpm (but definitely not 100%).

                             

                            Ordering a quality aftermarket CPU cooler to test if it's the board or the stock cooler but I suspect it's the board.

                             

                            Will update soon.

                            • 11. Re: Fan controll on DQ67EP board doesn't work
                              spearson

                              Patrick,

                               

                              I am unable to reproduce this scenario. What process did you follow? Did you update to latest BIOS? If so, one thing to check is whether the BIOS update upset the Fan Speed Control default configuration. To do this, go into  BIOS Setup and navigate to the fan speed control menu. Select Restore Defaults and then Exit with Save and reboot the PC. Hit F2, enter BIOS Setup and navigate to the fan speed control menu again. This time, change any one parameter - the usage for a fan or a health threshold for a fan, voltage or temperature sensor - and then Exit with Save and reboot again. Now run a load test that heats the processor to roughly 80 degrees and see whether the CPU fan responds...

                               

                              ...Scott

                              • 12. Re: Fan controll on DQ67EP board doesn't work
                                pmulligan

                                Scott.

                                Status @ original post:

                                Board: DQ67EP Version: AAG12529-309

                                Current BIOS version: SWQ6710H.86A.0064.2012.0626.1003

                                Test was run with BIOS defaults(auto fan control) and set to 100% (manual) as I indicated before.

                                 

                                Today:

                                Updated BIOS version to: SWQ6710H.86A.0065.2012.0917.1519

                                Set BIOS to defaults(auto fan control)

                                Burn in test PASSED! Auto-fan control working properly.

                                 

                                I'm happy that the updated BIOS resolved my issues but I also take exception to this.

                                Intel's own documentation states...

                                • Update the BIOS on your computer only if the newer BIOS version specifically solves a problem you have. We do not recommend BIOS updates for computers that do not need it. You can view all new BIOS fixes in the Release Notes.

                                And when you look at the BIOS release notes, the only mention of a CPU fan issue fix is BIOS Version 0052 and since the board was already at BIOS Version 0064, I didn't update.

                                So apparently the CPU fan issue was either...

                                • never fixed.
                                • fixed and broken again

                                Either way, you should look at updating the release notes to include the fan issue for BIOS Version 0065.

                                I don't really care if Intel Engineers broke functionality in the BIOS, just as long as they own up and document it!

                                • 13. Re: Fan controll on DQ67EP board doesn't work
                                  spearson

                                  Patrick,

                                   

                                  First of all, I didn't tell you to upgrade (or downgrade) your BIOS; I only asked you if you had. Secondly, there's nothing in the release notes about this issue because there's been no fix released that relates to this issue; our release notes only document what has been changed/fixed (not my decision; don't shoot the messenger who's trying to help).

                                   

                                  I believe - but have not yet proven - that the issue is something that is occurring during the BIOS upgrade/downgrade process. We are working to ascertain what is causing this but have not identified it as yet. My (many!) personal attempts to reproduce this issue have all failed; it has worked properly for me every time.

                                   

                                  What we know is that, (a) upgrading/downgrading your BIOS will not necessarily fix the issue - but, as you've seen, it could, (b) doing a FSC-level Restore Defaults or doing a BIOS-level Restore Defaults will not necessarily fix the issue - but it could and (c) making a specific change to one of the FSC parameters is also not guaranteed to do so - but has the greatest chance of doing so...

                                   

                                  ...Scott

                                  • 14. Re: Fan controll on DQ67EP board doesn't work
                                    pmulligan

                                    No need to get defensive because I'm not attacking you personally.

                                     

                                    I've just got three more of these boards in and planned on getting around 20+ more for a desktop refresh project.

                                    I will test each OOB, and see how many of them are experiencing the same issue.

                                     

                                    I'll document each, including the methods I attempted to correct any issues that appear, and send it to you.

                                     

                                    The BOM for our build is as follows...

                                     

                                    MBOARD: Intel DQ67EP (retail box)

                                    CPU: Intel i5-2400s (retail box)

                                    HDD: Intel 330 series SSD (retail box)

                                    RAM: Kingston or Crucial (2 x 8GB)

                                    CASE: Chenbro PC78338-250

                                    1 2 Previous Next