7 Replies Latest reply on Mar 24, 2014 3:22 AM by ComputerUser

    WIDIApp has stopped working


      Hello all,

      I have a new ASUS laptop with Core I 7, 64 bit, Bluray etc... and a D Link wireless adaptor to project on large TV screen through home theater sound that was working fine after initial installation today and in trying to adjust speaker configuration to surround, (I just had front stereo) I accidentally disabled the WIDI device thinking I was disabling the PC speaker in order to access WIDI surround options. I now get an error message; ''WIDIApp has stopped working'' ''close program''?


      Anyone know how to rectify this problem?




        • 1. Re: WIDIApp has stopped working



          Thanks for the post. I would suggest starting with the most simple solution first. I would uninstall everything and perform a reinstall. It will probably save you time from having to troubleshoot everything. Here is a link to the install page for Intel® Wireless Display.




          Follow the steps on that page to get everything re-installed.





          Intel® Product Support Engineer

          • 2. Re: WIDIApp has stopped working

            Hello Paul. I had this same issue with my Sony Vaio VPCS132FX - i3 - Windows 7 - 64bits a couple of weeks ago. I have tried all steps you reccomended over and over again. Uninstallation of the Intel Pro Set Wi-fi Adapter, Intel Graphics and finally the Intel Widi. All with the latest updates as well. Nothing solves it, the same message "WidiApp has stopped working" keeps popping up everytime I try to load the Widi software. I must remind you that I don't recall any incident/update/problem happening to this machine when this problem started to occur. And yes, it did work fine for months after I purchased it and installed the PTV2000 from NetGear. Please help me with something realistic, once all the steps with installations and updates were already made. I bought this laptop exclusively because of this feature! Thanks.

            • 3. Re: WIDIApp has stopped working

              I ran into a similar issue / same message after reinstalling.  The solution on my end was to right click the program and "run as administrator".

              • 4. Re: WIDIApp has stopped working

                Thanks for the reply to this message.


                Thanks for sharing something that fixed this issue for you.



                Intel® Product Support Engineer

                • 5. Re: WIDIApp has stopped working

                  I too have the same problem after a recent update that broke bluetooth and Widi functionality.  I then used system restore to before the update and bluetooth was fixed, but widi is not.


                  This is really frusterating as I`ve spent almost 2 days out of my life trying to correct this, uninstalling and re-installing.


                  Still, no fix.


                  I must also say that everywhere I`ve searched, Intel`s answer for this problem is a complete JOKE!

                  I mean, the links in the ``suggestions`` are the first google hits, and even when followed EXACTLY.....the problem persists.


                  I don`t believe this software will ever take off as Intel has intended, the installation process is too finicky, and dependant on other software or drivers from manufactures.  This all boils down to a complicated install even from scratch that the average user won`t even bother with or understand.


                  Even the Intel driver update site is confusing, listing driver versions as latest with different version numbers and the exact same description......


                  again, I am very upset with Intel on this implementation, and will continue to speak honestly of my experience on all forums, friends discussions, FB, twitter, etc. until this is fixed, because in the end the customer should have some sort of say in the support process, and simply pointing problems to a download page that DOES NOT WORK is a joke, and I believe Intel has really gotten thier heads enlarged during this undertaking.


                  If I have to revert to my stripped down backup and re-install all my software without any support from Intel, my next machine, and everyone I ever come into contact with again will be going with non Intel based machines.....PERIOD!

                  • 6. Re: WIDIApp has stopped working
                    Michael Szabo

                    So I had the same problem on my HP Envy 6t that I just got, but I was able to fix it!


                    What caused the issue I found was that I had gone into "Turn Windows features on or off" and had removed Microsoft .NET Framework 3.5.1.  I re-enabled this feature, restarted the computer, and now I no longer have the WIDIApp has stopped working issue!!


                    Hope this helps you!!

                    • 7. Re: WIDIApp has stopped working

                      I realise this thread is 3 years old and the OP is history, but I had the same problem recently and I would like to share what I did to correct it - for others who might have stumbled upon this forum with the same problem.



                      I am using the Netgear Push2Tv PVT3000. For the record it was working a few months ago when I first brought it and set it up, then I stopped using it for a while. It has the latest firmware. I tried using it again on yesterday and I could not get the Intel WiDi software to start on my laptop/ultrabook. Note the problem is obviously not with the Netgear Adaptor as I managed to share the screen of my Samsung S3 smartphone.



                      Basically my Widi would start up and then after about 30 seconds I would get a Windows dialogue box pop up saying "WiDiapp has stopped working". It would then ask me if I wanted to submit a crash report to Microsoft. I uninstalled and reinstalled WiDi several times, even using Revo Uninstaller Pro to remove the registry settings and residual files etc. Same result every time.



                      Samsung S9 - Windows 7 (64bit) - WiDi



                      Go to Control Panel > System and Security > Device Manager and on the following devices;


                      • Display Adaptors
                      • Intel WiUSB (all of them)
                      • Network Adapters (all or most of them, you'll need to decide which ones)


                      Go the Drivers tab on each device and select UPDATE. Reboot and try WiDi again. This seemed to do the trick for me. Good luck.