2 Replies Latest reply on Nov 8, 2011 12:48 PM by ComputerX

    Extraneous drive activity on Latitude E5420 with Rapid driver

    ComputerX

      Hi,

       

      I have a bunch of Dell Latitude E5420 laptops.  These use the Mobile Intel® HM65 Express Chipset and the drive controller reports in Windows as the Intel® Mobile Express Chipset SATA AHCI controller.  They are running Windows 7 Professional in both 32-bit and 64-bit versions.

       

      With a generic Windows install (or booted to BackTrack) they behave as expected.  Once a Rapid Storage Technology driver (either version 10.1.0.1008 as distributed by Dell or version 10.6.0.1022 (which reports to Windows as 10.6.0.1002)) is installed I get a quick flash of the activity light about every second.

       

      I understand that Windows does a lot in the background; I expect activity when "I'm not using the computer."  This is different than that.  I booted the computer to safe mode and left it over a weekend.  When I came in on Monday it was still showing the same pattern of a quick flash about every second.  The same computer with a fresh Windows 7 does not do that.  The extraneous activity starts immediately after the Rapid Storage Technology driver is active.

       

      I tried setting Windows to power down the hard drive after one minute.  That did not make a difference.

       

      Interestingly neither DiskMon nor ProocMon show activity to match the drive activity light.

       

      Any idea what is going on?  In addition to the light being annyong, I'm concerned about battery life if the drive really does have constant activity.

       

      Thanks in advance,

       

      Dan