2 Replies Latest reply on Oct 22, 2011 8:53 PM by JimboBi

    Can someone advise about a CPU issue? Perhaps SpeedStep?

    JimboBi

      Trying to determine why my wife’s laptop is operating so slowly. It is a Dell Vostro 1500 with Intel Core 2 Duo T7250 CPU rated at 2.0GHz. It is running Win XP Pro using the latest BIOS (A06) with the Intel GM965 chipset on the motherboard. With everything running under AC power, I ran CPUID, and the results indicated that the cores were running at only 800MHz. When I benchmarked the CPU using PC Wizard 2010, the core speeds never changed and the resulting CPUIDMark score was 7832 marks. It took about 6 minutes to run the benchmark tests.

      For comparison, my Dell Latitude D620 with Intel Core Duo T2300E (1.67GHz) and Intel 945 chipset (A10 BIOS) jumped from 1.0GHZ to 1.66GHZ core speeds as soon as the benchmark test started, took about 4 minutes to run, and scored 10379 marks. My desktop Dell Vostro 400 does the same: with E6850 it jumps from 2.0GHz to 3.0 GHz as soon as the benchmark test starts.

      I started by reflashing the BIOS just to make sure there was no corruption, but there was no change in the behavior.

      I tried turning off the SpeedStep function in the BIOS (which is supposed to force CPU to run at low speed) and the benchmarking test ran at 1.2GHz core speed, took about 3 minutes to run, and scored 11864 marks. About what I would expect. Then I reenabled SpeedStep and the benchmark test ran slowed to 400MHz core speeds throughout, took 15 minutes to run, and scored 1896 marks!

      I reset the BIOS settings to default values (SpeedStep is enabled by default) and the benchmark again ran at 400MHz core speeds. I checked the CPU driver in Device Manager, and it indicated everything was working correctly, with the driver intelppm.sys version 5.1.2600.5512 (xpsp.080413-2111).

      I again disabled SpeedStep, and as expected the core speeds stayed at 1.2GHz throughout the benchmark test, took about 3 minutes to run, and returned a score of 11835 marks.

      What else can I test or look for to resolve this issue? Ideas?