7 Replies Latest reply on Oct 20, 2011 8:13 AM by tomf

    SSD Optimizer Won't Run

    ibri009

      I have a 120GB Intel 320 SSD. My setup is:

      • HP dm1z laptop
      • Windows 7 Home Premium 64-bit
      • 8 GB RAM

       

      When I try to run the optimizer it says, "Cannot run the Intel SSD Optimizer on RAID configurations."

       

      I don't think I have a RAID setup. Do I have an HP propriatary setup? Or could this be a problem with an Intel SSD on AMD chipset?

       

      Thanks in advance for any help!

       

      Brian

        • 1. Re: SSD Optimizer Won't Run
          Dryne

          I have a similar problem on my Intel DX58SO2 motherboard.  The SSD Toolbox does not state I am running RAID though.  It shows that the tool is not supported for my drive and will not allow me to use it.

           

          The problem for me was that I installed the Marvel SATA3 driver under Windows.  After installing it, the SSD Toolbox refuses to allow optimize to execute.

           

          Do you have any third-party disk drivers installed on your system?

          • 2. Re: SSD Optimizer Won't Run
            ibri009

            Thanks, Dryne. I am not running any third party disk drivers that I know of. I'm running the system as it came stock from HP (I migrated the original HD onto my Intel SSD 120GB and have been using that ever since).

            • 3. Re: SSD Optimizer Won't Run
              Dryne

              Try this:

               

              Click your start button under Windows 7 followed by entering the following in the Search programs and files input box:

               

              SystemPropertiesAdvanced.exe

               

              On the System Properties window that appears, click the Hardware tab followed by clicking the Device Manager button.

               

              You will see the Device Manager window appear showing a tree view of your computer name at the top with several items under.  Look for the Storage controllers item in this tree view then expand it.  What do you see listed under it?

              1 of 1 people found this helpful
              • 4. Re: SSD Optimizer Won't Run
                DuckieHo

                Under Search programs and files input box: "Device Manager". 

                 

                Most likely you are running AMD Drivers.  If you revert to the W7 generic ACHI drivers, you will be able to run the SSD Optimizer.

                1 of 1 people found this helpful
                • 5. Re: SSD Optimizer Won't Run
                  ibri009

                  Yep, running AMD SATA driver version 1.2.1.269. Thanks!

                   

                  So my last question is how do I switch the driver to Microsoft's msahci generic driver?

                  • 6. Re: SSD Optimizer Won't Run
                    Dryne

                    If you right click it in the Device Manager where you see it, you can then click uninstall.

                     

                    Running Windows 7, there is no need to use the optimizer though, so I wouldn't uninstall it if I were you.

                     

                    Here is text from Intel's own documentation:

                     

                    Note: If your computer uses Microsoft* Windows* 7 and the standard Microsoft AHCI driver

                    (the default setup for normal configurations without RAID), the Intel SSD Optimizer works;

                    however, you do not need to use the Intel SSD Optimizer because Windows 7 implements

                    the Trim functionality natively.

                    • 7. Re: SSD Optimizer Won't Run
                      tomf

                      Dryne wrote:

                       

                      If you right click it in the Device Manager where you see it, you can then click uninstall.

                       

                      Running Windows 7, there is no need to use the optimizer though, so I wouldn't uninstall it if I were you.

                       

                      Here is text from Intel's own documentation:

                       

                      Note: If your computer uses Microsoft* Windows* 7 and the standard Microsoft AHCI driver

                      (the default setup for normal configurations without RAID), the Intel SSD Optimizer works;

                      however, you do not need to use the Intel SSD Optimizer because Windows 7 implements

                      the Trim functionality natively.

                       

                      Omigosh, I didn't know this! I've been running my 510 for 3mos and running the Optimizer every week or so. But I use the MS AHCI driver, so don't have to do this!?!? Maybe that's why Optimizer always runs so fast then (takes just a few seconds)?