1 2 Previous Next 27 Replies Latest reply on Nov 24, 2015 7:35 AM by Error32

    Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back


      Ive got the Intel DQ67EP board with the Intel 82579LM onboard NIC.  Ive got the machine running Windows7 64bit.  Ive got this problem where randomly it drops from Gigabit to 10Mbps and will never negoiate back to gigabit.  I can disconnect the cable, reconnect it, dont work.  I can plug that same cable into another machine like my Lenovo T420 laptop, and it has no issues connecting gigabit, so I know its not the cable, or port, or Hub.  However still plugged into a different port of the hub, still dont work.  Plugged it into a different hub, still dont work, still keeps sitting at 10Mbps.


      Ive rebooted it, still negoiates at 10Mbps.  Shut the PC down, wait 1min, turn it on, still sitting at 10Mbps.  So at this point dont believe its driver.  I have the latest 16.5 running on the Windows.


      ONLY way I can get this working is one of two ways.  I have to unplug power, not just shut it down.  I need to kill power from the board entirely.  Wait 10secs, then plug it back in.  Then upon starting up, its set to gigabit with no issues.  Other way is to change a setting in Bios which when you exit/save it causes it to kill power to the board for a second.  So the fact that killing power to the board fixes it, tells me its some hardware or firmware level issue, clearly not the driver.


      Now to explain when it happens, I do have the machine set to sleep and wake at certain times.  Most of the time it sleeps fine, wakes up fine and still sits at Gigabit.  Theres no explanation on how many times it takes before it decides to go into some stuck state of only negoiating at 10Mbps.  Even going into Device Manager and setting it to 100Mbps, or 1000Mbps, Half or Full duplex does nothing.  It disconnects the Link and Reconnects but only sits at 10Mbps.  Im normally connected via the IntelAMT via RealVNC.


      Ive updated from the 0054 bios to 0055 last week so Im also on the latest Bios revision.


      What causes this to get in such a stuck state that only killing power to the board fixes this?



        • 1. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

          To further provide detail and more testing.  Reverting to 0054 bios didnt help at all either.


          This is where I think I see the problem. When it boots and starts on gigabit fine, its all great.  Then when the computer is put to standby mode, I can see that the link (just by looking at the Hub port light) changes color which means it just dropped from Gigabit to 10mpbs.  If I wake the computer (either by WOL or Manually via power button) it will resume from standby and be in Windows, however its now stuck in 10mpbs mode only.


          Turn off the computer now, and the hub port light still shows its in 10mpbs mode.  So clearly this is a hardware or bios issue where for some reason it just drops the link speed and gets stuck in that state.


          I did forget to mention that I use and configured IntelAMT.  So I thought that might explain why the NIC is still powered and linked to the network hub even though the machine is completely off (but still plugged in).


          Again only way to solve this is to kill power on the board for at least 10secs, then power it up.



          • 2. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

            Hello Dixit,


            This does not sound like a familiar issue.  I just dropped one of these boards off at our validation lab to see if we can reproduce this behavior in-house.


            Could you please provide some information about the switch or other device that you are plugged into?




            • 3. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

              The switch Ive tried two different types, one was a standard 8port gigabit hub/switch by TrendNet.  Exact model is G1008D.

              Then Ive tried directly plugging it into a Wireless Router which is the Linksys E3000 (Its a gigabit capable 4port wireless hub/router)


              Ive tried as I mentioned multiple different cables so I know its not the cables since the same cables work on a Lenovo T420 laptop (gigabit capable), Gigabyte X58 based motherboard desktop (with intel gigabit lan).


              Im just slightly at a loss on why when this happens it gets in this stuck mode where like I said only way to "reset" it is to basically unplug power from the board by disconnect power plug, simply turning it off dont work as power is still going to the board.  


              I think I mentioned previously that I went to 0055 Bios update and thought that was the cause, then backed it down to 0054 and still reproduced it.  But its not reproducable all the time lately.  I know that doesnt help.  But most of the time when its put to sleep it will go into 10Mbps mode and refuse to come out.  Sometimes it works.



              • 4. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

                Our initial attempts to reproduce this issue have been unsuccessful.  Are you using the onboard video or a discrete adapter?  Which processor are you using?

                • 5. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

                  Since this initial post, Ive also lately been unsucessfull in replicating it as well.  When I first posted this, I was able to replicate this on demand.


                  Since then I basically downgraded to 0054, then was able to replicate it.  Then I moved back upto 0055 and thought let me see if its the Bios, and since then have been unsuccessull at replicating it.  I goes to sleep every night at 1am and wakes at 11am.  So maybe this will be closed cause I cannot for the life of me get it to replicate either.



                  • 6. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back



                    We have exactly the same behaviour, this o HP dc7800 (older desktop) but also on latest and greatest HP 8460p notebook from 2011. Whenever we make a remote connection either using the Intel Developper tools console or VNC Plus, the speed goes down to 10Mbps. We have HP Procurve switches.



                    • 7. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

                      Well Im the original author of this thread and I have to reopen this issue.  Its back.


                      I have 0061 Bios and latest 16.8.1 Intel network driver.


                      Everytime I now sleep the computer, and then wake it, can be waking it say in 1min or even 10hrs, the link always drops to 10Mbps now.  Only way to get it to come back is by completely shutting down, not just shutdown the computer.  Like I said before power plug has to come out or in my case flip the power switch on the back of the power supply itself which truly kills power to the Motherboard.  You have to leave it disconnected until the network light stops blinking or goes away.


                      Then you can plug it back in and turn it on and it negoiates properly to gigabit.


                      I have Windows 7 SP1 64bit Ultimate.  Nothing fancy on this.  It was just reloaded 3days ago.


                      What can we do to analyze this?  Can I put some kind of logging on this?


                      Or is there a way to keep the link from going to 10Mbps when it goes to sleep mode?  Cant the board maintain the link at say Gigabit even when its sleeping?  Something is not right here on why it keeps doing this.


                      To answer the questions from Intel previously, Im using the onboard video only, no discrete card.  There is no video monitor hooked up on this.  It really just has power, and network. All work is normally done through IntelAMT/RealVNC on this machine.  The processor is the i7 2600, not the i7 2600k which doesnt support vPro (which then I wouldnt get IntelAMT to work either).



                      • 8. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

                        So I tried to use the "load bios defaults" three times in a row, like load the defaults, reboot, go back into bios, load the defaults, reboot, repeat.  I know when programming NVRAM and other things that many times its recommended to clear it 3x but there is no real option in the Bios loading or anywhere to clear it all to make sure you get a clean base and no artifacts are left behind.


                        That didnt help, I can still reproduce the problem.


                        I dont want to go back to the previous version because like before I know its not going to fix it since I was able to replicate it before.  Something seems to be an issue with the NIC hardware itself.


                        What I did notice is that I did a test where I have my machine set to sleep (scheduled task in win7) at 1am, then it wakes again (scheduled task) at 11am.  I did this 3 days in a row and didnt have an issue.  Today before it woke, I decided to RealVNC (using IntelAMT) into the box a few minutes before it was to wake.  It woke as scheduled, however it retained only a 10mpbs link now.  So seems like being remoted in also causes the issue.


                        Sometimes its fine like the 3days in a row.


                        There has to be some hardware level or bios level info directly against the NIC causing this.


                        Again, is there not a way to just tell it to retain the link speed at all times?  Why does it need to drop to 10mpbs during sleep mode?  Can it not just run at say gigabit speed which in sleep mode?  I think thats part of the problem or temporary workaround.  Because it seems its clear when it goes to 10mpbs speed mode in sleep and when it wakes, it attempts to renogiate to higher speed and sometimes fails.  Where its mind boggling is why it refuses then even after a reboot, or even power down (without killing power to the board) to renegoiate at a higher speed?  Even if I force the option in Windows to say set at 1000mbps it refuses.


                        Maybe it has something to do with WOL or IntelAMT keeping that link always active or something, im speculating here.  But Id love to run some debugs for you folks to help nail this.  Something is clearly wrong here.



                        • 9. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

                          Hi Dixit,

                          Sorry to hear about the issues you are having with the speed negotiation. The speed cannot be set higher in sleep mode, because the power to maintain a gigabit connection is too high. Of course, the ideal thing of course is that when you wake back up the speed and duplex negotiation would work properly. I have a few ideas for you, but I do not recall anything specific as to 10Mbps instead of negotiating a higher speed.


                          1. We just refreshed the driver for your network connection. See if the new driver will help. You can get the latest driver at http://downloadcenter.intel.com/Detail_Desc.aspx?lang=eng&DwnldID=18713.
                          2. Make sure you have the latest BIOS and/or management engine updates available for your desktop board.
                          3. If the switch or router that you are linked to has newer firmware, upgrading the firmware is probably worth a try.
                          4. Are you using auto for your speed setting, or are you using a "forced" speed setting? If you are using a configured speed instead of auto, try auto. If you must configure a fixed speed then see my posting at http://communities.intel.com/message/148594#148594 for a utility that might help.


                          I hope one of these helps with the issue. Let me know what happens.


                          Mark H

                          • 10. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

                            I noticed the new 17.0 driver a week ago and updated it, so far its been fine.  But like I said before its been fine as long as I dont remote into IntelAMT via RealVNC before the machine wakes.  I will test to see what happens if it still has this issue if I remote in before the machine wakes.


                            As far as the auto, I always have it set to that, I dont believe in forcing a speed unless the switch/hub Im using is too old to know how to negoiate but thats not the case for me.


                            If I can reproduce the issue again, is there any debug tools I can get?  Id love to know why it refuses to negoiate at any other speed.  Like I said, I dont understand why even a reboot doesnt fix that.  That tells me it cant be the Intel Network Driver (which you referenced to try out).  That driver isnt loaded until Windows boots.  Even a shutdown doesnt fix it since the board still has power.  Its almost something at the hardware/firmware level that gets in some loop or stuck state that refuses to negoiate anything higher than 10mpbs.  Only way to solve that is to truly power down the board by cutting off the power on the Power Supply or pulling the plug entirely, waiting about 10secs (or until I see the network light go out on the machine) then plug it back in.  Thats why I think its something at the hardware/firmware level.


                            Im on the latest 0061 bios as well.



                            • 11. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

                              Hi Dixit,

                              I don't know of anything you could enable on your board for troubleshooting. I was wondering if you know the version of the Management Engine (ME) driver on your board? I see that the ME drivers are posted at http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20584. If the issue is related to the ME, then maybe updating this driver would help. This is just an educated guess on my part. The management engine is outside of my area of expertise.


                              Another thought as to resetting the connection if you get stuck at 10 Mbps. You could try unplugging the Ethernet cable for 10-15 seconds to see if that helps. I don't know if that will work, but it might be easier than pulling the power plug.


                              Mark H

                              • 12. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

                                Thanks Mark.  I will try the unplugging of the cable for 10-15secs.  I cant remember if that worked last time, I want to say no because awhile back I remember taking it out and plugging it into my laptop just to make sure it got a sync to Gigabit and it did (which coincidently has the exact same 82579LM NIC - Lenovo T420).  Then I remember plugging it back into the DQ67EP and still wouldnt connect to Gigabit.  But that was months ago, I will try again and see.


                                As far as the ME driver, I honestly dont even think I have this driver.  Didnt think you needed it.  My RealVNC connects straight to the IntelAMT directly so I see KVM like features (bios to boot usability).  I know the Bios updates the Intel AMT/ME firmware as well cause I see that flash by during the update.


                                I will try to install this see if it has any effect on this situation.  BTW what exactly does this driver do?  Since I seem to have full capabilities right now from a Remote Management.  I dont see any Readme or Notes on this.



                                • 13. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

                                  I don't know the details, but I assume since the package uses the term "drivers" then this is the software that provides the interface between the management engine and the hardware. Like I said before, the management engine is outside my area, so I am really making an educated guess here. The latest drivers might already be installed or included with any Intel AMT updates you made. Also, I don't know if updating the drivers will help at all.


                                  After my last reply I did some checking with one of our other engineers about getting stuck on 10 Mbps. Apparently the driver in the OS will not overide Intel(R) Active Management Technology (Intel AMT) sessions, which would explain why you get stuck at the slow speed after an Intel AMT session. The Windows driver is designed not to interfere with the Intel AMT session.


                                  Since I never used Intel AMT, I am wondering if there is a logoff or logout or an "end" option that you can use after the session. If there is, maybe that will help when you return to a Windows session. I am just "thinking out loud" about what might help here. I was told that resetting the system was the way to reset the speed, which is what you are doing when you remove the power. So my suggestions for ending the Intel AMT session might not be of any help.


                                  Since the Windows drivers will not overide the Intel AMT drivers, I cannot think of any other possible workarounds. You might be stuck with removing the power unless you can find another way to do a cold restart.


                                  If you run into any better solutions, I would be interested in hearing about what you find.


                                  Mark H

                                  • 14. Re: Intel 82579LM drops to 10Mbps from Gigabit, refuses to go back

                                    Well at least we now know the reason I have this "stuck" state.  Guess its by design that Windows never messes with the IntelAMT session.


                                    That would also explain why when I am not remoted into it it works flawless (when it wakes from sleep).  So for now I guess I will leave it be and chauk this upto "works as designed" even though I may not entirely agree with the concept.


                                    Would be nice to have an option in Windows on the driver side to let it take over the IntelAMT session if it needs and it that causes a disconnect thats fine.  But I can see from the IT side why someone would not want this either.


                                    I guess also if this ****** me off too much, I could always maybe just use a 2nd NIC for my main feed to the network and the onboard NIC just for IntelAMT use (and if that drops or stays at 10mpbs I can live with that).  But being this board has limited expansion since its a small board, I wanted to keep that last slot open for expanding past the 4 SATA ports that I have not to maybe 6.


                                    Again thanks Mark for taking the time in looking into this with your engineers.  As far as finding another option on the cold restart, I did find one way.  Since many times walking over to this machine is pain I figured out a workaround (not the best but saves the walk).  I go into Bios, change something thats small like say the real time temp monitoiring by bumping the temp setting by 1F or down.  Or even adjust the RPM speed by 1RPM.  Then save and exit, this causes the board to actually shutdown entirely and restart, my IntelAMT session drops, and the entire NIC link even resets too.  So for others that have this issue and cannot get to the box easily, you can use that Bios trick to "force" a cold restart that completely kills power to the board.



                                    1 2 Previous Next