10 Replies Latest reply on Nov 5, 2011 7:12 AM by Cabadam

    Intel i3-2105, no 1080p on Samsung LED TV via HDMI

    Cabadam

      I just upgraded my HTPC from an AMD 780g based motherboard.  Current setup is now:

      ASRock H67M

      Intel i3-2105

      Samsung UN55D6000

      Windows 7 x64 Professional

       

      With the newest drivers (15.22.50.64.2509, Sept 7 2011), the highest resolution I could get to display on the TV was 1600x900 at a refresh rate of 60Hz.  Good news there is - it matches up almost perfectly to the TV (as far as overscan is concerned).

       

      Anything higher (such as the 1920x1080 it should be at) and my TV displays "No Signal".  I note that I only have one option for refresh rate on these drivers at this resolution - 75.

       

      Going back to the previous drivers (15.22.1.64.2361, April 13 2011), I now get 3 settings for refresh rate at 1920x1080.

      29 - (Default when I selected this resolution) - Gives "Mode Not Supported" error displayed on the TV.

      30 - Displays, although with decent chunk of the screen cutoff by overscan.

      75 - Gives "No Signal" error.

       

      I then tried again to install the new drivers, and it's settings now match those of the old drivers.  That is, I have the three refresh rates of 29, 30, 75.

       

      My TV is recognizing the 1920x1080 at 30Hz as 1080i, not 1080p. Any ideas how to get this thing running at the right resolution / refresh rate (which I'm guessing is supposed to be 60Hz)?  I tried adding an "custom resolution" for it... but then that resolution doesn't show up anywhere else, so there is no way to actually apply that resolution!

        • 1. Re: Intel i3-2105, no 1080p on Samsung LED TV via HDMI
          allan_intel

          Hi there!

           

          It looks like the monitor's EDID is not been detected properly. In order for all supported resolutions to be available, the monitor drivers need to be loaded.

           

          Contact the monitor manufacturer in order to obtain the .INF file to install the driver.

           

          If you are interested in additional information please check below:

           

          http://support.intel.com/support/graphics/sb/CS-022544.htm

           

          Thanks

          Allan.

          • 2. Re: Intel i3-2105, no 1080p on Samsung LED TV via HDMI
            Cabadam

            That seems to be very focused around "monitors."  Is the term monitor being used very loosely here, because this is a 55" TV I'm connected to

            • 3. Re: Intel i3-2105, no 1080p on Samsung LED TV via HDMI
              vlewis

              Cabadam,

               

              I had the exact same issue as you and after an hour of searching I found the answer in the user manual! This TV (UN55D6000) supports 1920x1080 at a 24Hz refresh rate. I changed mine in the intel display properties and TV switched over to 1080p instantly.

              • 4. Re: Intel i3-2105, no 1080p on Samsung LED TV via HDMI
                Cabadam

                Sorry for my late reply here, been swamped lately with other things.

                 

                Where did you see this about 24Hz refresh rate?  My printed TV manual, on page 13 has the list of resolutions on it.  The only row with 1920x1080p selected has a vertical frequency of 60Hz listed.

                 

                Even given that, I can't find 24Hz displayed anywhere.  Even if I go into the Windows settings for the monitor and uncheck setting that hides unsupported frequencies, it still doesn't show up.

                • 5. Re: Intel i3-2105, no 1080p on Samsung LED TV via HDMI
                  Cabadam

                  Something I did not mention in my original post, in case it becomes relevant:

                  I am connected using the HDMI out on the motherboard, through an audio receiver (which also supports HDMI), and then also as HDMI from the receiver to the TV.

                   

                  The HDMI video resolution setting on the receiver is set to "pass through" (other options are choosing a sepcific resolution)

                  • 6. Re: Intel i3-2105, no 1080p on Samsung LED TV via HDMI
                    vlewis

                    The latest user manual can be found here: http://www.samsung.com/us/support/downloads/UN55D6000SFXZA

                    The supported formats are on page 166. The manual is used for the entire lineup so just ignore the fact that it says 3D.

                     

                    I am connected the same way, through a receiver via HDMI then to my TV via HDMI and everything works great. If you are using intel graphics try this:

                     

                    Right click desktop -> Graphics Properties

                    General Settings -> Refresh Rate -> 24Hz

                     

                    The refresh rates I have listed are 23, 24, 29, 30, and 60.

                     

                    Here is a picture of my settings, sorry for the bad color im remoting in:

                     

                    graphics.jpg

                    1 of 1 people found this helpful
                    • 7. Re: Intel i3-2105, no 1080p on Samsung LED TV via HDMI
                      Cabadam

                      Thanks for the quick reply.  When I get home this evening, I'll look again, but I'm almost positive 24Hz does not appear in that dropdown list.

                      Also, check page 76 of the manual - that also seems to suggest 60Hz.

                       

                      Either way, will update this after I get home tonight.

                       

                      Thanks,

                      • 8. Re: Intel i3-2105, no 1080p on Samsung LED TV via HDMI
                        Cabadam

                        OK, so when I got home, I noticed there was a newer set of drivers out (apparently came out right after I started messing with this originally).

                         

                        Uninstalled those, rebooted, installed the new ones, rebooted.

                         

                        It defaulted me to 1920x1080 @ 75Hz (!).

                        The receiver (and TV) both indicated this was 1080p (despite the higher refresh rate - which the TV refused to display earlier...).

                         

                        If I open the intel app - the ONLY refresh rate available to me is the 75Hz.

                        So, I'm basically in one of those "I don't know why this is working, but the picture looks nice and crisp, I don't want to touch it" states.

                         

                        Which just leaves me with one more question - what did you do to adjust the overscan?  Some places I read said to set the Intel software to Custom aspect ratio and adjust the sliders down to compensate.  However, every time I've done this, the TV just gives me a blue-ish screen.  The intel software does NOT apparently revert this setting if I don't confirm after 15 seconds or whatever.  My only option then is to reboot it into safe mode, uninstall the drivers, reboot normal, then reinstall and reboot again.  That gets me back to the "good" state.

                        • 9. Re: Intel i3-2105, no 1080p on Samsung LED TV via HDMI
                          vlewis

                          I didn't touch the overscan settings in the intel control panel. I set the TV to "Screen Fit" using the P.SIZE button the Samsung remote. If you set the TV to 16:9 it cuts off some of the picture, but Screen Fit seems to fit perfectly. It even lets you move the screen with the arrow buttons one line at a time so on the SD channels you can get rid of that top line of blinking white that a lot of Samsung TV + DirecTV users experience.

                          • 10. Re: Intel i3-2105, no 1080p on Samsung LED TV via HDMI
                            Cabadam

                            Screen fit worked perfectly.  And doesn't do too much to the normal 16:9 HD content that comes from cable.

                             

                            Thanks for your help getting this sorted out!