1 Reply Latest reply on Oct 8, 2011 3:16 PM by shiroi_kage

    DX58SO2 Not powering up

    shiroi_kage

      Hello everyone,

       

      I just got a DX58SO2 motherboard and am having issues with it.

      The motherboard refuses to power up at all. It does, however, go into standby when the PSU is powered up but it won't go past that. The power logo-shaped LED on the motherboard is red and the thing just won't send power anywhere.

       

      I have tried disconnecting everything apart from the motherboard, processor and RAMs and it still did not power up. I even tried shorting the PSU seperatly and it did deliver power normally.

       

      I'm usnig an i7-980 and a 850W PSU. I tried looking for any stray screws or anything of that sort but I found nothing.

       

      Please advice.

        • 1. Re: DX58SO2 Not powering up
          shiroi_kage

          Update: Since I have a liquid cooling system, I did not plug in the CUP fan the first time. I did and the motherboard ran, and continued to power on and off fine after removing the thing.

          I still have a problem, seemingly, with a pair of RAM sockets. I have 6 RAM cards and tried installing all of them but go the 3 beeps pause bios error. I tried shuffeling them around, but whenever I have the rams installed in those sockets, Channel A, the error resumes. When nothing is installed there the system boots up normally.

           

          More specs:

          CPU: i7-980

          GPU: AMD HD radeon 6990

          PSU: Black Widow 850W

          RAM: 9 GB total (3 1GB cards and 3 2GB cards)

           

          Everything else works as it should apart from when the RAMs are installed in said channel (the one closest to the CPU in location)

           

          Please help!