3 Replies Latest reply on Oct 12, 2011 2:00 AM by drwho

    Intel Data Migration SW (Acronis): No manual alignment possible?!

    GrandAdmiralThrawn

      Greetings!

       

      I have just bought an Intel 320 SSD 600GB to replace my good old 300GB Velociraptor harddrive. The running operating system is Windows XP Pro x64 Edition (so, the 64-Bit version with NT 5.2 kernel).

       

      Now, XP is supported by the Intel Data Migration Software, which in turn is based on Acronis. So I thought this would be fine for cloning my HDD onto the Intel 320 SSD, since that's what it's for, right?

       

      But the Migration Software simply copies the current cylinder boundary alignment 1:1, which means my SSD is aligned to sector 63 after cloning. So I tried the manual mode, which just copied the sector 63 alignment and gave me the option of shifting the partition start with 1MB granularity left and right. But this won't fix the alignment. Why can't I just tell the tool to align the target partition to sector 1024 (+512k) or 2048 (+1MB)??

       

      Now, what I did was to do the clone and afterwards re-align the existing partition including ALL the data using a gparted CD, which generated a total host writes sum of 788GB. After that, a quick boot from my XP x64 CD and some fixboot/fixmbr repaired the bootsector for the newly aligned partition start. Note that gparted allows the user to key in sector numbers for manual alignment, and can also auto-align to both HDD cylinder boundaries and 1 MiB boundaries useful for SSD and 4k AF HDDs. After that procedure, it finally looks good:

       

      fixed-alignment.png

       

      My question is: Is the software really as stupid as I think it is, or did I just miss something that I should have done differently? If it really is that broken, then the official Windows XP support should probably be cancelled or the tool fixed. If I did something wrong, please let me know what I should have done differently, so I don't have to go through all this again.

       

      Thank you!