1 2 3 4 Previous Next 48 Replies Latest reply on Nov 4, 2011 5:52 AM by HASPT

    Help recovering BIOS of bricked DH67CF


      Hello all,


      I just tried to update my DH67CF(G10215-203) BIOS to the recently released 0131 version(BLH6710H.86A.0131) but bricked my board. The updating process seems to be fine, as at least I used to see the screen showing flashing modules with version 0131 showed upon. BUT then, after an automatically reboot, the case fan runs at full speed, nothing appear on the screen - in short, POST failed(or even not initialized), so I have to push power button for few seconds to shut the system down.


      Then I tried these:

      1. Clear settings, first by moving the jumper to the next pins, then by unplugging the battery on board(plus unplug the PSU). No help.

      2. Then I noticed there're beeps by forced shutdown. Tested & results will be stated below.

      3. Follow the BIOS recovering process found on Intel site(and also in this forum). Remove the jumper head, unplug all peripherals, copy BL0131P.BIO(yes, 0131 ver. at first I thought it would be something wrong when transferring binary, so re-downloaded & tried) to empty USB stick (I can only found at minimal 4GB ones, not someone said below 2GB, so I made a 502MB partition to use FAT16), power on and wait almost half an hour. Nothing happened.

      4. Then I tried to recover to the version 0125, the latest one I sucessfully flashed. Still nothing.

      5. Tried few times, with the recover jumper at pin 2-3(clear configure) as some posts here introduced, with different partition scheme and format. Seems no hope...


      Some further investigations:

      0. The failed flash process

      I made my USB stick bootable to FreeDOS to have some DOS utilities run on raw machines. So I run IFLASH2.EXE instead of using F7 method. I think the failure may because of this, maybe FreeDOS' modern kernel? But IIRC FreeDOS stuffs don't alter BIOS int functions, and IFLASH2 should run fine.

      1. On beeps

      While forcing shutdown(pressed the power button), the board beeps seems in the manner of "memory error": beep - beep - beep, then the system shuts down. Even without repeat, I can identify because the last stop lasts longer than inter-beep stops(noticeable to me). So I removed 1 DIMM then 2 DIMMs(all for this board), but the system behaviours same. I think the board should beep without any DIMM, but not.

      Another thing about beeps is, at sometimes, the beeps are like not initialed fast enough, so I can hear a long silent, then sequence beeps but not finished all 3 because the system is already powerred off.

      2. On basic I/O

      After the reboot of that failed flash process, the case fan rotates at full speed(according to its spec, no input or full high-level input on PWM pin). I've unplugged it, then I realized that CPU fan(from Intel) is not at full speed. Seems like improper functional of the SuperI/O chip?



      Any suggestions on what should I do next?


      Thanks and regards,




      Intel offered a RMA as I have "No Video after BIOS Update". I received the replacement on Okt. 15th Thank you all for your followups.

        1 2 3 4 Previous Next