2 Replies Latest reply: Dec 1, 2011 1:35 PM by jwsink RSS

Intel Bluetooth Service View Has Stopped Working

yoallwyn Community Member
Currently Being Moderated

This MSI GT683R notebook, with the Intel Centrino Wireless-n 130 is not even a month old yet, so I haven't done much to it. I fire up bluetooth to connect a Wii Remote to it last night, it paired successfully, but when I go to connect the two devices I get the error stated in the title. When I go to try to update the drivers, I get "There's a problem with Windows Installer Package" or when I try to repair it, "Bluetooth Service failed to start. Verify you have Sufficient Priviliges to start the service." And it even went from Intel Centrino to Generic Bluetooth Adapter. I don't understand why the world doesn't want me to use Bluetooth? O.o

  • 1. Re: Intel Bluetooth Service View Has Stopped Working
    StrongerThanAll528 Community Member
    Currently Being Moderated

    I had this problem for a long time, starting back when I got my Dell XPS laptop in April. I started researching it shortly after I got the computer, but gave up after a while. I started looking again when I went to update my drivers yesterday, and thanks to a few great folks, I FINALLY got everything working how it should be again...

     

    Basically the issue is that in the folder C:\Program Files (x86)\Intel\Bluetooth, there should be a file called "devmonsrv.exe." For some reason, a lot of virus scanners pick this up as malicious and remove the file. Apparently, this is the missing file that causes A LOT of problems, namely the "Intel Bluetooth Service View Has Stopped Working" error, as well as the issue when trying to update drivers and the issue when trying to repair the installation. Your post covers the EXACT same error messages and problems that I had with my Intel Centrino Card. The only difference is that I did not have the last issue where it changed to Generic Bluetooth adapter, but our problems were extremely similar, so this solution should hopefully work for you too. This is the exact order I did things in order for them to work:

     

    1. Check the C:\Program Files (x86)\Intel\Bluetooth directory (this is the default location) to make sure that the "devmonsrv.exe" file is, in fact, missing

    2. Turn off your real-time scanning on your antivirus software. I'm not sure if its totally necessary, but I think its a good idea in case it just deletes the file like it did in the first place, which is how the problem originated. I have McAfee, but I know other AV programs had this same issue as well.

    3. Go to the following link and download the "devmonsrv.rar" file (it is on page 2) and extract it to get the actual "devmonsrv.exe" file (and while you're at the link, check out both pages for a deeper explanation of the problem):

    http://forum.notebookreview.com/networking-wireless/568924-dell-xps-15-laptop-bluetooth-nokia-mobile.html

    4. Next I copied and pasted the "devmonsrv.exe" file into my C:\Program Files (x86)\Intel\Bluetooth directory

     

    STEPS 5-7 MAY BE ABLE TO BE DONE INTERCHANGABLY, AND ITS POSSIBLE THAT IT MAY WORK BY SKIPPING STEP 5 OR 6, BUT THIS IS THE WAY I DID IT WHEN IT CORRECTLY FIXED THE PROBLEM:

    5. I paired the devices and tested to ensure that I was able to pick up on the "Bluetooth Services" for my Phone (this is where I was previously received the "Intel Bluetooth Service View Has Stopped Working" error, so I knew it was a good sign when it didn't come up this time). I was able to file transfer now and had access to the picture, sound, and video directories of my phone.

    6. Choose the repair option on your Bluetooth installation again, as you had done in your problem statement. This time, it shouldn't give you the same error, and at the end should ask you to restart the computer. Do so...

    7. Download and install the latest Bluetooth driver, as you were trying to do when you got the "There's a problem with the Windows Installer Package" error. For some reason, I think I had some sort of small error during this operation, but at the end it asked me to restart my computer again, so I did.

     

    8. Once my computer was restarted, I tried to install the new driver again to make sure it actually installed (because I had gotten the error) and this time when I tried to install, it gave me a different screen (because the new driver had already been installed) with two options "Repair" and I think "Remove" (could have been "Change" though). THIS STEP IS TO MAKE ENSURE THAT THE DRIVER INSTALLED CORRECTLY.

    9. Once I made sure that the driver was installed correctly, and that all the functionality worked,  I turned my AV Software Real-Time Scanning back on. The "devmonsrv.exe" file was still there, everything was functioning properly, and the driver was updated

     

    This is what fixed the problem for me, so I hope it works for you too. Please let me know if all or part of this solution was helpful in solving this problem, because I had this problem for months and it drove me nuts!!!! Good luck!!! :-)

  • 2. Re: Intel Bluetooth Service View Has Stopped Working
    jwsink Community Member
    Currently Being Moderated

    Thanks for this...it's incredibly helpful!  However, my problem is slightly bigger.  My antivirus software didn't JUST delete that one file.  I've lost THREE files:

     

    1.  DEVMONSRV.EXE

    2.  MEDIASRV.EXE

    3.  OBEXSRV.EXE

     

    Best I can tell, it took them all out at once.  I downloaded DEVMONSRV from the link you provided and pasted it according to your directions, so that's now taken care of.  I'd hoped that I could fake it with that one file.  Unfortunately, I'm still getting the same error.  Any idea where I can find the other two missing files?  Any help would be appreciated!

More Like This

  • Retrieving data ...

Legend

  • Correct Answers - 4 points
  • Helpful Answers - 2 points