3 Replies Latest reply on Nov 21, 2011 1:41 PM by dlayknee

    Install issue with Gig ET quad-port & Server Core

    dlayknee

      I have a 2008 Server Core system I'm trying to install a new Gigabit ET Quad Port Server Adapter on.  I've tried installing it by simply running the PROWinx64.exe from Intel's site, using the setup files from the CD that came with the card, and manually extracting the drivers and using pnputil to install them (and yes, between each attempt I'm running the uninstall, removing all the Intel NIC drivers from the system, and rebooting).  Regardless of the method chosen however, I end up with 1 or possibly 2 of the interfaces ok in Device Manager and the other 2 (or 3) reporting that Windows couldn't load the driver ("Code 31").  It's odd combinations as well - not simply 1 & 2 are ok (ie, possibly a bad chipset for 3 & 4) - if more than one interface shows up OK it will be something like 1 & 4 will show up ok while the others have the yellow triangle.  It's different ones on each re-install too, which serves to confuse me even further.

       

      Intel's prosetcl adapter_enumerate gives me an accurate list of the 8 ports on the server (4x integraded Broadcom, working fine, and 4x from this Intel card), while _enumerateproperties on one of the malfunctioning ports shows something such as:

       

      1) Intel(R) Gigabit ET Quad Port Server Adapter #2
          Supported Properties:
              Adapter GUID                   - {12483627-0557-46C5-A42D-1AE4A2274702}
              Adapter Status                 - Disabled
              Availability                   - Unknown
              Bus Type                       - Unknown
              Controller ID                  - Unknown
              Duplex                         - Unknown
              EEPROM Version                 - <No Data>
              Hardware Address               - <No Data>
              Hardware Status                - Unknown
              Link Speed                     - Unknown
              Max Link Speed                 - 1000 Mbps Support
              Media Type                     - Unknown
              Modified Name                  - Intel(R) Gigabit ET Quad Port Server Ad
      apter #2
              Name                           - Intel(R) Gigabit ET Quad Port Server Ad
      apter #2
              Negotiated Lane Width          - <No Data>
              Part Number                    - <No Data>
              Port Number                    - <No Data>
              PCI Device ID                  - VEN_8086&DEV_10e8&SUBSYS_8086a02c&REV_0
      1&25&0
              Slot ID                        - 34
              Status                         - <No Data>
              Status Info                    - Unknown
              WMI Path                       - \\[redacted]\ROOT\IntelNCS2:IANet_PhysicalEthernetAdapter.CreationClassName="IANet_PhysicalEthernetAdapter",DeviceID="{12483627-0557-46C5-A42D-1AE4A2274702}",SystemCreationClassName="Win32_ComputerSystem",SystemName="[redacted]"

       

       

      This is a brand-new Dell R715 server with a fresh OS install.  I've tried two of these NICs, both brand new, both with the same results.  I'm pretty sure this is an issue of PEBKAC, but I can't for the life of me figure out how to get these drivers installed properly!  Does anyone have any experience with this NIC/OS combo?

       

      - Chris