1 Reply Latest reply on Sep 19, 2011 10:22 AM by allan_intel

    Updating Intel Graphic Drivers on an Nvidia Optimus System

    ksdehoff

      All:

       

      I wanted share my learnings from a recent, fairly frustrating support experience.  The background:  I have a Lenovo T420s with Optimus and since it supports Widi 2.0 I had wanted to get that working.

       

      The first issue I had was that playback of a video on the widi monitor hung after 5-15 minutes of playback.  The initial post on Intel's communities website suggested I needed to update my video driver.

       

      The problem I had was that both the Lenovo packaged video driver and also the Intel packaged driver both complained and would not install on my new laptop.

       

      I finally got a helpful tip from the Intel WIDI engineer that corrected a misperception of mine - Intel drivers should be upgradable on an Optimus system - there is nothing special about that driver (contrary to what the nvidia and lenovo sites were telling me).

       

      The good news is that I have been able to install the Intel Driver package.  Let me explain what worked.

       

      step 1 is to uninstall the currently installed Intel and nvidia graphic drivers

      step 2 is to disable optimus in the bios - boot to only the intel graphics adapter

      step 3 - the OS boots with no video device found - using windows update it got me a 'vanilla' intel hd driver and installed fine

      step 4 - after the reboot, the latest intel driver loads fine

      step 5- reenable optimus in the bios

      step 6 - reload the nvidia drivers (I use the verde drivers from the nividia web site)

       

      Hopefully most folks dont have this level of trouble with their optimus drivers but this worked for me and is worth a shot if anyone is struggling with the intel driver update.