1 Reply Latest reply on Sep 13, 2011 10:53 AM by allan_intel

    Problems switching from on-board Intel GPU to NVIDIA GPU on Win7

    Opran

      Hi there folks!

      I am having trouble with my new Fujitsu laptop. I have an onboard GPU  (Intel® HD Graphics Family) and a non-onboard NVIDIA GeForce GT 525M  GPU. I have Windows 7 Home Premium (Service Pack 1) and the latest  drivers for my NVIDIA video card. I also obviously have DirectX 11  installed, since I have Win7.

      Now, the problem is that although Windows detects both GPUs, it uses the  Intel one (this was true both before installing the latest NVIDIA  driver and before that).

      I know it's using the Intel one since: 1. If I go to Control  Panel->Display->Change display settings->Advanced settings, the  Properties window for the Intel GPU pops up; 2. If I go to Intel®  Graphics and Media Control Panel, under Options and  Support->Information Center, it says "Processor Graphics In Use:  Intel® HD Graphics 3000"; and 3. Graphics quality/performance is way too  low for the NVIDIA GPU.

      I tried disabling the Intel HD thing in Device Manager, but all that  happened was that the screen went blank, so I restarted my computer,  booted into Safe Mode (the screen wasn't blank there), re-enabled the  Intel, and then restarted Windows into normal mode (and obviously I  still had the problem with Windows not using the NVIDIA GPU.

      Also, if I go into NVIDIA Control Panel (click the system tray icon and  click "Customize which programs use the GPU"), under "Manage 3D  Settings", if I add a game to the list of "programs to customize" (in  the Program Settings tab) and then click Apply, the game still behaves  as if it was using the Intel on-board GPU (as in, nothing changes in  terms of quality and/or performance, regardless of the graphics  settings). Also, in the Program Settings tab, under "2. Select the  preferred graphics processor for this program", the selected setting is  "Use global setting (Auto-select: NVIDIA GPU)" and it doesn't allow me  to change that (the drop-down list is greyed out).

      So could you guys please help me solve this little issue? Pretty please?