2 Replies Latest reply on Jan 30, 2015 12:29 PM by Dave_Samuels

    Reinstalling the Chipset Device Software

    Kwyjor

      I was setting up a system recently and thought I could get away with installing a bunch of drivers at once without restarting Windows XP (32-bit), including the Intel Chipset Device Software.  This proved to be a big mistake, as XP started bluescreening during startup immediately thereafter.

       

      I was able to get XP running again by selecting the Last Known Good Configuration from the startup boot menu.  Obviously, the next step would be to install the drivers one by one, more carefully this time.

       

      Unfortunately, the Intel Chipset Device Software refuses to be re-installed!  Attempting to run the installation program brings up a message box stating "You must have administrator rights to install this software", which is of course incorrect since I have the same rights re-installing the software as I did the first time I installed it.

       

      Now, when I rebooted XP, it did manage to identify a lot of the system components, but I have no idea if it is using the best drivers for them.  In particular, I still have an "SM Bus Controller" listed as an unknown device (yellow question mark) in my device manager, and I'm pretty sure that was identified when I previously installed the Chipset Device Software – which is why I still want to do it agian.

       

      The last few lines in D:\Intel\Logs\IntelChpset.log are

       

      [InstallDev]
                [Device]
                  Driver = D:\Intel\INFUpdate\All\2008s4el.inf
                  INF = D:\Intel\INFUpdate\All\2008s4el.inf
                  Installed INF = D:\WINDOWS\inf\machine.inf
                  Previous driver package = D:\WINDOWS\system32\DRVSTORE\2008s4el_A9B4D64813DEBEEAEB8B98DF96F15BD321B40B84\2008s4el.inf
                  Updating driverstore package.
                  0x0: ENTER:  DriverPackagePreinstallW
                  0x0: Copied '2008s4el.inf' to driver store...
                  0x0: Copied '2008s4el.cat' to driver store...
                  0x0: Commiting queue...
                  0x0: RETURN: DriverPackagePreinstallW  (0x5)
      !!!         ERROR 0x0: DriverPackageInstall generated an unexpected error

      [ResponseResult]
      ResultCode = -1

        • 1. Re: Reinstalling the Chipset Device Software
          allan_intel

          I see you have SMbus issue; this is reported at this URL:

           

          http://www.intel.com/support/chipsets/sb/cs-013541.htm

           

          Try installing Chipset Software Installation Utility manually, see installation instructions here:

           

          http://www.intel.com/support/chipsets/inf/sb/cs-009272.htm

           

          Thanks

           

          Allan.

          • 2. Re: Reinstalling the Chipset Device Software
            Dave_Samuels

            I know I am replying to an old thread - but I have the answer and resolved this error, and since this message comes up first n search results, have registered to help someone else as this took an extra 12 hours and a lot of technical insight to resolve.

             

            My original issue was that iTunes didnt reinstall. generating this error that said I am trying to access an unavailable network resource and to browse to find itunes64setup (again)

            that led me to completely uninstall apple products and reinstall per their instruction and fixed the issue with iTunes. see Remove and reinstall iTunes and related software components for Windows Vista, Windows 7, or Windows 8 - Apple Support

             

            The SAME error happened not just updating itunes, but uninstalling it from my Windows 7 SP1 system...so I went to microsoft Fixit and attempted to correct and it properly uninstalled iTunes.

             

            Now for the intel chipset issue...my new Iphone wasn't recognizing, and there was an error with installing the device drivers for my new iphone. Manual applications didn't work, even though a generic device showed in control panel - device manager

             

            Per another blog answer - I tried to remove and reinstall my USB controller or update the drivers (I have an Alienware M15 laptop - a few years old.) I discovered that the USB host controller - an Intel(R) 5 Series / 3400 Series Chipset family USB Enhanced Host controller - (port) was not covered by current Intel chipset programs which are Series 6 and later, but did have an update (8/20/2009 v9.1.1.1020)  that supported USB 2.0 (and therefore 3.0 backwards compatibility which as an issue with my new iPhone and some USB thumb drives.) To find this I had to look at the Support - Downloads and Drivers - browse for drivers and somewhere found an option to look for older no longer supported drivers. I found infinst_autol.exe for my case.

             

            Once downloaded I tried to install and failed. Found the log in C:\Intel\Logs and contains:

            [InstallDev]

                      [Device]

                        Driver = C:\Users\DAVIDS~1\AppData\Local\Temp\IPMx7\WIN7\ibexusb.inf

                        INF = C:\Users\DAVIDS~1\AppData\Local\Temp\IPMx7\WIN7\ibexusb.inf

                        Installed INF =

                        Previous driver package =

            !           Warning 0xE0000235: DriverPackageGetPath failed.

                        Difx = 64 bit

            Execute command: C:\Users\DAVIDS~1\AppData\Local\Temp\IPMx7\x64\Difx64.exe -DriverInf "C:\Users\DAVIDS~1\AppData\Local\Temp\IPMx7\WIN7\ibexusb.inf" -Flags 20 -KeyPath "Software\Intel\Difx64"

                        Using RegDeleteKeyEx

            !!!         ERROR 0xE0000246: DriverPackageInstall generated an unexpected error

             

            Which led me here. This turned out to be an error for two reasons. First, after manually running the command in an "run as administrator" window (same error result), thinking it related to my anti-virus (turned off), and from another blog granting my user administrative rights to files in an install folder and trying to reintsall inf files and drivers from C:\Windows\winsxs vs my copied infinst_autol.exe expansion (as found from log in C:\Users\David Samuels\AppData\Local\Temp\IPMx7\WIN7 folder).....that there was an easier solution as the reason this error actually happens is a permissions problem.

             

            To access the proper windows system folders - you have to be TrustedInstaller service - not just in the administrator group...or you have to be the actual "Administrator" account. To become actual administrator on your own laptop, Open a command window "run CMD.exe as administrator", the execute command

            > net user administrator /active:yes

             

            This creates a local PC Administrator account with no password. Coincidentally it has proper permissions to windows directories for installing drivers. Log in as this user, go to device manager and update the USB hub and any other drivers. if updating the USB root - it doesn't replace it right away as the system cant disable the in memory running driver  - you have to update, then restart the system, log in as administrator and repeat at the next lower layer with issues.

             

            Once completed - log in as yourself again and disable the administrator account n a command window with > net user administrator /active:no

             

            This in my case enabled all my USB 2.0 and 3.0 devices and everything works properly again - I hope this helps many of you to resolve your own issues that were difficult to find and resolve.

             

            Regards,

             

            Dave Samuels