1 2 3 Previous Next 60 Replies Latest reply on Nov 26, 2012 10:33 AM by gullfaraz

    DP67BG: Unsuccessful BIOS update to 2053


      DP67BG BIOS version 2053 was released today and I tried to update. I had already updated from 1900 to 1979 and 2040, using the "F7" procedure, without problems.


      There were no problems during the update, but after, the machine didn't boot. There was the "two long beeps - silence - two long beeps" indicating that there was a problem with the video initialization. I tried the "Back to BIOS" button but nothing worked.

      Fortunately I was able to fix the machine putting back the old BIOS (2040) using the recovery procedure.


      It seems there is some incompatibility with my video card: EVGA GeForce GTX 550Ti.

      I don't have any other PCIe video card to check.


      A little more info:

      - I didn't restore the BIOS to factory settings before update, and after recovery all my settings were there untouched.

      - The "Video" option in BIOS was set to Manual. After recovery I changed back to Auto (default), tried the update again and had the same problems.



      I'd like to describe in detail the BIOS recovery procedure because the documentation seems to be a little vague.


      1) put the recovery BIOS (the same used in F7 procedure, with a .BIO extension) on the root folder of a pendrive. I think it is recommended a pendrive with an activity LED.

      2) turn off AC power, unplug any other USB device

      3) put the BIOS configuration jumper in Recovery mode (on DP67BG it is just beside the "skull", Recovery mode requires to take out the jumper completely)

      4) plug the USB drive, turn the computer on

      5) the pendrive will be accessed, there is no image on screen (at least in my case that had a video problem)

      6) the computer will reboot, don't unplug the drive!!!!

      7) the pendrive will be accessed again, and after a while (longer than a normal POST) the Intel screen should appear.

      8) a BIOS update screen should appear, watch progress

      9) The process ends when a message about reboot is shown, and after that, another message telling to put the BIOS jumper back in place

      10) turn off AC power, put the BIOS in Normal mode, unplug the USB drive and that's all.

        • 1. Re: DP67BG: Unsuccessful BIOS update to 2053

          This happened to me as well -- at least I think the same thing happened... the flashing process proceded without errors, the updater rebooted the system upon completion and... beep beep for several cycles.  Back to Bios Button doesn't work either. 


          I hope to hell its recoverable.  For the record, my GPU is a GTX 460 -- made by MSI ( A Cyclone 1024MB).  So it looks like if you want flash to 2053 and you have a nVidia card, hold off.   I'm going to stick an old AMD HTPC style card I have in there before I attempt to rescue the ROM.

          • 2. Re: DP67BG: Unsuccessful BIOS update to 2053

            Well, I put my AMD card in and at first I got the same deal, two beeps and post code 82 (or is it 28? my board is upside down).  Then, on subsequent cycles, I actual get into the BIOS after an error message about unsuccessful posting attempts.


            So don't try to flash to 2053 at all.  I'm going to try to flash back to 2040 now.  I hope it works.  Shame on the BIOS/UEFI department  -- I think something funky going on.

            • 3. Re: DP67BG: Unsuccessful BIOS update to 2053

              I had no problem updating from 2040 to 2053.  I didn't even bother changing my BIOS settings to the default settings.  I just updated the BIOS using the Windows installer version and that was it.  It did hang at the Starting Windows screen the first time the PC restarted, after the BIOS was updated, but that also happened to me the last time I updated the BIOS to 2040 using the Windows intaller.  I just manually rebooted the PC and it then restarted fine and when I got to the desktop a window popped up saying that the BIOS update was successful.  For the record I also have a GTS 250 Nvidia graphics card and I had no problems updating.

              • 4. Re: DP67BG: Unsuccessful BIOS update to 2053

                I am also unable to successfully update to revision 2053. The flash process appears to complete successfully, however the system is unable to boot afterward and simply emits 2 long beeps as rsnetto posted. I also have a EVGA GeForce GTX 550Ti adapter.

                • 5. Re: DP67BG: Unsuccessful BIOS update to 2053

                  It's interesting that the only case of success was using whe Windows updater. I never tried it, as I said, I always used the "F7" procedure (putting the .BIO in a pendrive then pressing F7 during boot to enter the update screen).


                  Other important point is the memory settings. Mine were not default, I put in XMP-1600, provided with the memory modules.


                  I didn't understand how ckryan recovered the system. It was also with the Recovery method (changing jumper, putting the .BIO on a USB stick etc)?

                  • 6. Re: DP67BG: Unsuccessful BIOS update to 2053

                    My memory is also at XMP-1600 and I have my 2500K overclocked to 4.5GHz and I kept those settings when I updated to 2053 and I had no problems.  Before BIOS update 2040, I used to always update the old-fashioned way by using F7.  For some reason last time around I was having trouble getting F7 to work so I decided to give the Windows installer a try and it worked great and it was super-easy too!  That's why I also used the Windows installer this time around for BIOS 2053.  Maybe you should try updating the BIOS again using the Windows version?


                    Keep in mind with the Windows installer that it will automatically power down the PC and restart it on it's own after you start the update process.  Don't get scared if it doesn't power back on immediately...it could take a few seconds.

                    • 7. Re: DP67BG: Unsuccessful BIOS update to 2053

                      I did use the windows installer.


                      I was able to reflash, but I would say that you should enter the BIOS and look at the top to make sure you're at 2053.


                      I have had a problem several times where the flash would complete successfully, but then I'd check in the BIOS and I would still be listed at the previous version.  This was especially noticible with 2040 since it added some new features not there previously.  In fact, today I tried again to flash to 2053 and thought it had succeeded since I didn't get the no video error -- but I looked in the BIOS and it was still at 2040.  So you may want to double check.


                      I've also noticed that some of the newer versions don't have available .iso files either.

                      Didn't they used to have them?

                      • 8. Re: DP67BG: Unsuccessful BIOS update to 2053

                        If you only have the two beeps, then you shouldn't have an issue with reflashing back to 2040.  Rsetto's directions at the top are valid.. but if you want the original PDF from Intel, just look around a little.

                        • 9. Re: DP67BG: Unsuccessful BIOS update to 2053

                          I have faced the same problem. I did use the windows installer.

                          BIOS 2053 + nVidia GTX580 not working. Changeover on old nVidia 7800GTX has given the chance to boot.

                          • 10. Re: DP67BG: Unsuccessful BIOS update to 2053

                            I do not believe the delivery method (Windows Express BIOS Update, UFD F7, etc.) is related to the update failures as I have exhausted all with no success (un-bootable, video-less board). Additionally both times I attempted the update all timings (CPU, RAM, etc.) were default. I did notice however that both times the update claimed to be successful and I rebooted to 2 beeps and no video the onboard port 80h POST code display stalled at "EB". "EB" is a BDS (Boot Device Selection) code indicating the BIOS is calling available option ROMs.The only option ROM loading during my boot phase is the RST ROM for RAID which I have enabled.


                            Does anyone else experiencing the 2053 update failure have RAID enabled per chance?        

                            • 11. Re: DP67BG: Unsuccessful BIOS update to 2053

                              I have faced the same problem. I did use the windows installer.

                              BIOS 2053 + nVidia GTX460SE not working.

                              I left a single memory module and the pc boots without problems.

                              • 12. Re: DP67BG: Unsuccessful BIOS update to 2053

                                I feel special!  I must be the only one that was able to update to 2053.  I wonder why I had no problem?  I have an NVidia GPU and an SSD but no RAID.



                                • 13. Re: DP67BG: Unsuccessful BIOS update to 2053

                                  I left 1 of 4 ram modules in, swiched GPUs from a GTX 460 to an AMD 4555, unplugged my SSD boot drive and two SSDs in RAID, everything.


                                  Once I could flash back to 2040 every thing was fine, but it took several hours to get to that point where I could.


                                  It looks like (to me) some kind of PCIe enumeration problem, posibly just with certain boards (maybe they used a couple different vendors for a certain part).


                                  Maybe it's just a problem with nVidia GF1xx boards like 460s and 560s ect.


                                  Who knows?


                                  But really, all you really need is 2040. The only reason I upgraded was for what was described in the notes as Intel Rapid Storage Technology Support (I think), not even sure what changes they made, but I'm using three SSDs, two of which are in RAID.


                                  I may try some more flashing experiments.

                                  • 14. Re: DP67BG: Unsuccessful BIOS update to 2053

                                    Thanks for that Wasabipeas.


                                    I don't think it has anything to do with the distribution method either, but I'm going to keep digging, cause now I'm curious.


                                    I wasn't using XMP profiles, but instead had the memory set to MANUAL 1600mhz timings and what not, which may have been the problem.  Before I could get to just two beeps (video), first I had to figure out why I had three(memory problems).  Once I was able to get the memory set to 1067mhz manually, I could switch GPUs and flash the BIOS back.  I know the 2053 BIOS had been completely installed since I could put the AMD card in, put the bios jumper to "configure", turn it on, wait a couple auto reboots, and I could get into the BIOS.


                                    You have to remove the battery for 4 hours in order to get the board to lose settings (which is pretty impressive).  That's what in Intel enthusiast liason told me on HardForum.com anyway.


                                    I'm glad that for the most part every one could flash back to 2040, but for a while my board was bricked.

                                    1 2 3 Previous Next