1 2 3 4 Previous Next 50 Replies Latest reply on Dec 27, 2014 11:16 AM by rauloraulon

    Intel Smart Response Technology Issue

    RunicEvil

      I recently had this working perfectly until I upgraded to new hard drives. So I understand the process of how to set everything up. Make sure you are in Raid in bios, install windows, tell the program you want to use your SSD to boost your HDD. (The process in a nutshell). So down to the problem.

       

      I open up the Intel Rapid Storage Technology program.

      I click the Accelerate tab.

      I go down to the "Enable acceleration" link and click it.

      It ask me for my settings, I select them. (Fairly simple with one SSD and one HDD.)

      -I chose Full disk and Maximized mode in case anyone is curious. I also tried all the combinations to see if it would work any other way.

      I then click the "OK" button.

       

      This is where the issue is.

       

      It brings me back to the Accelerate tab saying:

      Accelerated device: None Select device

      Acceleration mode: None

       

      BUT, the SSD is cached.

       

      The little bit of trouble shooting I attempted was:

      -Restart the computer (obvi).

      -Reinstall the Intel Rapid Storage Technology program.

       

      System Specs:

      Asus Maximus 4 Gene-Z (It's a Z68)

      i7 2600k

      Corsair memory: CMZ8GX3M2A1600C9R

      Corsair SSD Sata 3: CSSD-F60GB3-BK

      WD Black 2TB: WD2002FAEX

        • 1. Re: Intel Smart Response Technology Issue
          wjones14

          I set a new system up with this the other day, using the Intel DZ68DB motherboard, an Intel 320 Series 40GB SSD, and a 1TB Western Digital Caviar Black hard drive.  I installed it like you said:  set the BIOS chipset mode to RAID, install OS on the hard drive, then load the latest Intel drivers for the network, chipset, and RAID RST. I also updated the BIOS to the 11-Aug-2011 0029 version.

           

          I'm not sure if this will help or not, but this is what I'm seeing in the Rapid Storage Technology app after enabling SRT (in Enhanced mode):

           

          rst_accel_view.png

          rst_manage_view.png

          rst_status_view.png

          • 2. Re: Intel Smart Response Technology Issue
            RunicEvil

            Yeah, I've done those things as well. The one thing I want to avoid is a reformat of my system drive. Here are some screens of what I'm looking at.

             

            Is there something I can attempt to reinstall or check into updating. I'm pretty sure I have everything up to date. BIOS and IRST. Anything else?

             

            http://i65.photobucket.com/albums/h220/runicevil/IRST1.png

            http://i65.photobucket.com/albums/h220/runicevil/IRST2.png

            http://i65.photobucket.com/albums/h220/runicevil/IRST3.png

            • 3. Re: Intel Smart Response Technology Issue
              Bafico

              I'm having the identical problem using Intel DZ68DB board, i7-2600k, Intel 311 SSD, and the same WD HDD. The one thing that is common to both our configurations is the HDD.

               

              RST seems to ignore the selection of that hard drive to be accelerated, but provides no error message.

               

              I'm wondering if there is anything unique about this WD drive that might be causing this?

              • 4. Re: Intel Smart Response Technology Issue
                RunicEvil

                That's very good to know. I new to these boards, but does Intel look through these and offer help? If not I'll send a message to them so they're at least aware of the issue. I know two people with a hard drive that won't accelerate isn't really going to call any attention, but it can't hurt to try.

                • 5. Re: Intel Smart Response Technology Issue
                  Tofof

                  I also have this issue, but no common hardware.

                   

                  Seagate ST2000dl001 HDD

                  OCZ Solid 3 60gb SSD

                  P8Z68-V pro mobo

                  Core i5 2500

                   

                  Maddening.  I've tried uninstalling and reinstalling the sata rst driver, the software (including permutations with the 'management engine') etc.  Nothing seems to get anything other than the same 'accelerated device: none' result, regardless of settings chosen for acceleration.

                  • 6. Re: Intel Smart Response Technology Issue
                    Bafico

                    I stumbled across a "solution" that has been working for over a week. Thinking it might have something to do with WD implementation of SATA III, I took an older WD with SATA II and hooked it up. Sure enough, it was recognized and was now Accelerated. Proof positive I thought that the interface was the issue. So I disabled the acceleration and was about to shut down the computer when I gave the SATA III drive one last try. Surprise - it was now recognized and was Accelerated. I've powered off/on several times and it stays Accelerated. I have no idea why this would work, but it does.

                    Hope this helps,

                    Mike

                    • 7. Re: Intel Smart Response Technology Issue
                      Tofof

                      No luck here, but that tip did help further troubleshooting.  I hooked up (hot swapped, even) an older 1 TB hdd and had no problems getting it to become accelerated - worked first try.  However, it was still impossible for me to get the desired system drive to do anything other than return to 'accelerated device: none'.

                       

                      For what it's worth, both drives report the same status during boot-up: "non-raid drive" (in green, the 'ready to go' state).

                      • 8. Re: Intel Smart Response Technology Issue
                        JohnnyC

                        I am having the exact same problem.  Just out of curiosity, do you have a EFI or BIOS System partition on the same hard drive you can't enable SRT?

                         

                        My drive (drive 2) contains a System Partition (100MB) that is created by windows during installation.

                         

                        ComputerManager.PNG

                         

                        I believe I read somewhere that SRT only works on drives with a single volume.  I was able to enable it on the other two drives with no problems, but can't do my system drive.  I am going to try to delete the System Partition and see what happens.  It normally contains some drivers, bit locker startup files and windows recovery (if you don't have the disk), so maybe it isn't needed.  I will try it and worse case, have to install windows over.

                         

                        -JohnnyC

                        • 9. Re: Intel Smart Response Technology Issue
                          RunicEvil

                          I've had acceleration working on one drive with 4 partitions. Don't think the system folder will do that. I've been told by intel there might be a conflict at the meta data level. I don't know what that means. It sounds pretty lame. He said a reformat might be the only solution. But make sure to try other drives before you go reinstalling your entire computer. I'm going to give the drive trick a try this weekend. If this doesn't work then I'm busting out the Windows 7 CD.

                          • 10. Re: Intel Smart Response Technology Issue
                            Tofof

                            The only drive that's worked for me thus far has been a single partition drive.  For what it's worth, it was a drive from a non-efi system.

                             

                            I've tried a 2TB and a 500gb drive, in uefi mode (which makes 3 partitions during win7 install - system, a special uefi "MSR (Reserved)" partition, and the primary partition), and neither of those has worked.

                             

                            The 3-partition uefi 2tb cannot be accelerated even when it's not actually the system drive (when I'm running off the 500 gb).  The older 1-partition 1tb drive can be accelerated using either of the other two drives as the system drive.

                             

                            I just tried installing win7 to the 500gb in /non/-efi mode (with the 2 partition setup mentioned by JohnnyC) and that worked!  It took a second, but even clicking 'ok' on the dialog at least produced the win7 busy-circle-mouseicon for a couple seconds.  I waited patiently another 30s and the system drive displayed accelerated.  (The first time I tried, it looked like it had failed again - I was not patient enough.  I went to reset the ssd - which ended up producing an error because it was actually in the middle of turning acceleration /on/ ... but that actually gave me a dialog box about please reboot and try again).

                             

                            Edit: To accomplish the 'non-efi mode' I refer to, I went into my bios's boot menu and booted off the CD, rather than the CD in uefi mode.  At least in my bios, harddrives and optical drives display twice, once as e.g. 'UEFI: p4 SD2001etc' and once simply as 'p4 SD2001etc'.  The former is what I had always done that failed, the latter is what worked.  Crucially, you can tell in the win7 install which you're in if you wipe out the HDD and then choose 'new' - you'll get a dialog about win7 making extra partitions.  If it makes your primary and a system partition, you're in the mode that worked for me.  If it makes your primary, a system partition and a third partition that mentions efi when you click on it for details, you're in the mode that didn't work for me.

                             

                            Yet another edit: Just remembered that, for what it's worth, I did the 'f6' procedure (that in win7 doesnt use f6, it's 'load driver' on the same hd configuration page) to preload the latest RST driver - 10.6.0.1022.  Doing that didn't seem to change anything (I had also done so on my install to the 500 in efi mode, which failed) but.. wanted to mention JIC.

                             

                            Yet Another Edit: Yes, repeating this procedure for my 2TB primary drive has it accelerated.  Strange that if this is a problem with bios mode it hasn't been noticed more often.

                            • 11. Re: Intel Smart Response Technology Issue
                              JohnnyC

                              Yes!  I have done the same thing (in a slightly different manner).  I have an ASUS motherboard and it has two options for booting from DVD, one normal one and one for UEFI.  If you select the UEFI, you get a GBT partition created with windows which has a 100MB EFI System Partition and a 128MB MSR (Microsoft Reserved Partition) in addition to the full partition.  This seems to have a problem with SRT. 

                               

                              When I booted from the standard DVD drive, it creates a standard BIOS System partition.  It is working with that!  As long as your boot disk is not greater than 2.2TB, you can stick with a standard BIOS System Partition, although the EFI partition setup does boot noticeably faster (SRT probably will speed up startup anyway).

                               

                              Hopefully, someone at intel monitors these forums and can tell us why SRT has a problem with EFI partitions or GBT Partitions and if and when it could be updated to work with it.

                               

                              -JohnnyC

                              • 12. Re: Intel Smart Response Technology Issue
                                JohnnyC

                                I did an online chat with Intel Technical SUpport.  They told me that SRT has not been tested with EFI partitions or drives larger than 2TB for a boot disk.  He said he would put in a problem report for me and I suggested that they add that information to the SRT documentation (with instructions how to install a BIOS System partition).  He included that in the problem report. 


                                Don't know if it will make a difference or if they will try to fix it, but you never know.

                                 

                                -JohnnyC

                                • 13. Re: Intel Smart Response Technology Issue
                                  RunicEvil

                                  So...if I have a 2TB drive it will work and if I have a 2.1 TB drive it will not work? The reason I ask is because my hard drive is 2TB (shows up as 1.8). I have hooked up in my system right now, 2 SSDs and 2 HDDs (500GB and 2000GB). I'm able to accelerate with both of my SSDs on my 500GB disk, but nether work on the 2000GB disk. So what is the largest disk I'm allowed to use with ISRT?

                                  • 14. Re: Intel Smart Response Technology Issue
                                    JohnnyC

                                    Hi Runic,

                                     

                                    I believe the exact amount is 2.2TB which is what the BIOS spec allows (I think, I forget where I saw this).  UEFI supports hard drives larger than 2.2TB, but SRT doesn't seem to support it (although they may choose to support it in the future).

                                     

                                    Do you know if you have a System partition on the 2TB drive?  You can go into the Computer Management Applet (under Administration tools) and check on the Disk Management section.  If it has an EFI partition (usually 100MB before the main 2TB partition), then that is the problem.  If it is a System BIOS partition, then it must be something else.


                                    If you look in the screenshot I posted earlier you can see the incorrect System EFI partition. It should look like this (check out my 279GB disk in both snapshots).

                                     

                                    Capture2.PNG

                                     

                                    If it is the former (an EFI partition), you will have to reinstall Windows.  In my Motherboard (ASUS P8V68-P Pro), there are actually two settings that show up for my only DVD drive in the UEFI (successor to BIOS), One says just the DVD Drive type and the other says UEFI and then the drive type.  You want to boot off the non-UEFI one.  If you have another MB, I believe Tofof had a description of another MB to do the same above.


                                    When you install Windows, delete both partitions on the 2TB disk, the EMI System Partition and the Main Partition.  Then select New to create a new partition.  If it mentions something about a GBT partition table (it will look like you have 3 partitions, 1 System (probably 100MB), 1 called MSR or Microsoft Reserved Partition (128MB) and then the main partition), then you booted from the wrong UEFI DVD drive setting.  If it just creates a small system drive along with the Main partition, you should be OK.  After installing windows, install the Intel Rapid Storage Drivers and the ISRT drivers and you should be able to accelerate the drive.

                                    Your symptoms were identical to mine, so I think this is the same problem you were having.

                                     

                                    -JohnnyC

                                    1 2 3 4 Previous Next