6 Replies Latest reply on Oct 19, 2011 7:10 PM by mintcore

    DZ68DB won't go to sleep

    wjones14

      In Windows 7 Home Premium, I press the button for the computer to go to sleep, and the lights and fans all go off, but then it immediately wakes up in about a second.  My previous Intel DP35DP board would go to sleep fine with Windows Vista, and it would wake by pressing any key.

       

      Is there some BIOS setting that won't allow the board to go to sleep, or some reason this configuration doesn't allow it?

       

      System:

       

      Intel DZ68DB motherboard

      Intel i5-2500K cpu

      Intel 320 Series 40GB SSD

      Western Digital Caviar Black 1TB hard drive

      Crucial DDR3-1333 8GB RAM

      XFX Radeon HD 6950 video card

       

      Configuration:

       

      SRT enabled in Enhanced mode, using SSD as cache for 1TB hard drive

      BIOS version:  DBZ6810H.86A.0029.2011.0811.1134

        • 1. Re: DZ68DB won't go to sleep
          rsnelson

          It sounds like it is trying to go to sleep but something is waking it back up.

           

          Try running "powercfg -LASTWAKE" in the command shell after the computer as come back to life.  This should tell you what device woke the computer up.  You then can disable this device from waking the system up with  powercfg -DEVICEDISABLEWAKE <devicename> or through the device manager.

          • 2. Re: DZ68DB won't go to sleep
            wjones14

            Thanks rsnelson...  Here is the result.  Is it safe to disable wake on this, or can it be done in the BIOS?  What would the exact command be if I did it in a command prompt?

             

            C:\Users\Bill>powercfg -LASTWAKE
            Wake History Count - 1
            Wake History [0]
              Wake Source Count - 1
              Wake Source [0]
                Type: Device
                Instance Path: PCI\VEN_8086&DEV_1503&SUBSYS_201B8086&REV_05\3&11583659&0&C8
                Friendly Name:
                Description: Intel(R) 82579V Gigabit Network Connection
                Manufacturer: Intel

             

            More info:

             

            From the Control Panel->Network->Intel(R) 82579V Gigabit Network Connection Properties window:

             

            Power Management tab shows a Wake on LAN section, with these options:

             

            Wake on Magic Packet (checked)

            Wake on Magic Packet from power off state (checked)

            Wake on Pattern Match (checked)

            Wake on Link (not checked)

            • 3. Re: DZ68DB won't go to sleep
              rsnelson

              Uncheck all the options in the control panel power management tab for the network adapter and try it again.

               

              If that doesn't work, then inspect the powercfg -LASTWAKE result to see if is the same device or not.

               

              I've used powercfg -DEVICEDISABLEWAKE <devicename> before and it will toggle the settings seen in the power management tab for devices in the device manager.  So you should be able to do it either way.

               

              You can also use powercfg -DEVICEQUERY wake_armed to show all devices which can wake up the computer.  Entries should disappear from the list as you disable them.

               

              I disabled my LAN and wireless keyboard/mouse and use the power button to wake the computer.  One slight move of the mouse would wake the thing up which is not what I wanted.

              • 4. Re: DZ68DB won't go to sleep
                wjones14

                Yes, unchecking the LAN wake options on the Network connection properties Power Management tab worked!  Thank you.  It works as you describe -- The keyboard and mouse do not wake the pc, but the power button does, and it is almost instantly, a second or less.

                 

                Just out of curiosity, how do you make it so a keypress or mouse click would wake the system?  (this is how it was with my previous Intel DP35DP and Vista 64-bit system -- moving the mouse would not wake it, but clicking the mouse button or pressing a key would.)

                 

                Thanks again.

                • 5. Re: DZ68DB won't go to sleep
                  rsnelson

                  I would suggest you go into the device manager, find your keyboard and mouse, and check to see if you have a power management tab where you can enable the wake up settings.  Sometimes you may have to also enable the parent device (such as when you have a wireless transciever).

                  • 6. Re: DZ68DB won't go to sleep
                    mintcore

                    I am having the same issue and I don't agree that turning off Wake-On-Lan is the right fix.  It doesn't answer the question of what is really causing the network device to wake the system.  WOL has a legitimate purpose and should not need to be turned off.  Down the road I do want the machine to be able to WOL but not every five minutes for no reason.

                     

                    In my case this is a new PC I built and I have a hard time believing that something on the network is sending a magic WOL packet every five minutes to this computer.  I have other Windows 7 machines with WOL enabled and don't have this issue.  How can this be debugged at the next level to figure out what is making the network device.

                     

                    I'll probably start a new thread on this since it is marked "answered".