3 Replies Latest reply on Sep 18, 2011 3:28 AM by vanaalten

    Disable IGP on i3-2100 - DH67CF

    Gerrit

      Hi,

       

      To reach the lowest power consumption on my headless server I completely want to disable graphics on my i3-2100/DH67CF combination.

      When I disable the IGP in the BIOS, my machine doesn't boot. Is it possible to disable all graphics?

        • 1. Re: Disable IGP on i3-2100 - DH67CF
          allan_intel

          I see you are using a processor with integrated graphics and you disable IGP in BIOS, the machine will not display any video, this is expected.

           

          The only way to disable the graphics portion will be installing a PCI Express video card but of course this will consume more computer resources = more power.

           

          Thanks


          Allan.

          • 2. Re: Disable IGP on i3-2100 - DH67CF
            Gerrit

            But that's just what I want. I want to completely disable Graphics because I'm not using it. It's a headless NAS running Fedora Linux.

            I don't use the CLI, i'm only SSH-ing into the NAS from another PC.

            The machine does 18W no in idle, but with the GPU off it should be lower.

            • 3. Re: Disable IGP on i3-2100 - DH67CF
              vanaalten

              A bit of a late reply perhaps, but:

              I've got exactly the same configuration here (DH67CF, i3-2100) running linux (Debian). I just went into the BIOS and switched video from 'always enable' to 'always disable', saved and reboot.

               

              Indeed no video, as expected, but power consumption went from 19W to 13W. I can still SSH into the machine and webserver still serves. So this works, just as expected and with very nice results.

               

              In case you want to have video back again: open the machine, move the BIOS jumper from 2-3 (normal) to 1-2 (configuration); go into the BIOS and set video back to 'always enable'. Save changes and exit BIOS. Then set the BIOS jumper back to 2-3 (normal).

               

              In your case: could it be that the hardware works correct, but that Fedora doesn't start because it is missing video? If so, here is my idea to debug:

              1) switch video to 'always disable';

              2) boot until you're sure the machine should be working (and try SSH just to be sure it fails)

              3) shutdown, re-enable video (see above), but after placing the BIOS jumper back to normal again, do NOT reboot yet.

              4) take a Linux live-CD (*), boot from that instead of your harddisk and launch a terminal.

              5) mount the partition of your harddisk that contains the /var/log files - and start examining them to determine if your machine had a problem starting without video. As I said - the same combination works flawless here, so I suspect your operating system.

               

              (*) I advice to use a recent Ubuntu live-CD, as you need something with a pretty recent kernel to get this system to work. And I had to disable 'splash' in my boot parameters, so change option 'splash' to 'nosplash' in the list of kernel parameters. If I remember correctly, you get a menu offering to install, run memtest or just boot. Hitting 'tab' on that option gives you the possibility to modify the boot parameters.

               

              Good luck!

               

              Edit: just noticed that disabling video apparently also switches off the power led of my machine, so I can't tell anymore whether it's on or off.