7 Replies Latest reply on May 9, 2012 10:42 AM by Sherv

    My new 310 mSATA 80 GB SSD hit by the 8 MB bug

    ssdfrustration

      I installed a brand new 310 mSATA 80 GB SSD into my new Lenovo Thinkpad X220 (Windows 7 professional) yesterday, with the latest BIOS. Everything seemed fine at first. Tried to move Windows 7 OS from the spinning HDD to the mSATA SSD using the intel data migration software. The software reported a disk error (as I remember, the error was supposed to on HDD not SSD), and prompt me to run CHKDSK /r. But after I ran CHKDSK /r (which took a long time), and rebooted the computer, the 80 GB SSD was shown to have only 8 MB capacity.

       

      The SSD is recognized by the BIOS with correct product code (SSDMW4MF080G2). Rebooting the computer (which now take a couple of minutes before it even gets to OS initiation) will sometimes reset the mSATA 80 GB to the correct size (diskpart reports 74GB). But the SSD cannot be initiated (using Disk Management) or partitioned (using DISKPART). There was one time that the computer saw the SSD as 74GB, but after wakeup from hibernation the SSD size became 8 MB. I can created a partition on the 8 MB volume, but even the 8MB cannot be formatted.

       

      I have seen some posts reporting 8 MB error on 320 SSD. I wonder if any 310 SSD owner have had similar problems?

        • 1. 8 MB bug in Action
          ssdfrustration

          The screen capture below shows the 8MB bug in action.

           

          After a reboot, the 310 mSATA SSD is recognized, but cannot be initiated/partitioned by disk management tool or DISKPART.

           

          After waking up from a standup (which stopped the spinning of HDD), DISKPART reads the 80 GB SSD as only 8 MB in size.

           

           

          SSD crash.png

          • 2. Re: 8 MB bug in Action
            ssdfrustration

            Tried to do a secure erase of the 310 mSATA SSD using Parted Magic. It bricked the drive.

             

            The drive is now completely locked. During the POST of booting, it requests for password of the drive (there wasn't any, of course) and won't preceed any further.

             

            The drive is now RMA back to the vendor. I'll see if I have better luck with the replacement.

            • 3. Re: 8 MB bug in Action
              w00thisButtonDo

              I have one x25-e and x25-m G1, that have similar behaviour.

              Password issue is also known bug for me.

              Thats why I was asking about upcoming firmware, does it coming for all series or not.

              • 4. Re: My new 310 mSATA 80 GB SSD hit by the 8 MB bug
                BDS73

                Any Intel SSD could potentially fail with an 8MB capacity signature due to various reasons.  The recent firmware update for the 320 series 8MB failure is specific to 320 and 320 only and is completly unrelated to any 8MB failures that may bee seen on other versions of Intel SSDs.  I would not expect to see a firmware update coming to address 8MB failure seen on previous gen SSDs. In the case of your particluar 310 failing I would recommend submitting for RMA.

                • 5. Re: 8 MB bug in Action
                  badboy64

                  I have a 160 GB X25-M G2 Postville (installed last fall) with similar issues. It ran as system/OS disc in a Dell XPS PC with Win 7 64 bit.

                  After I woke up the PC from the automatic “save energy" mode the system reported some errors (I can’t recall what exactly). Hence I rebooted the system. It reports first an AHCI failure on port 2 (where the SSD sits). After some investigation I found that the first error message was somewhat misleading because the real issue was the missing boot device. OK, I assumed something must be wrong with my SSD.

                  Additional investigations and tests (Parted Magic et al.) revealed the cause: 8MB and BAD_CTX! OK.I felt like sitting in the wrong/bad movie. All the threads and press reports I read so far were about the 320 series. Little to know indication that other Intel SSD’s may be/are affected by the same bug. Now I know better. A hard lesson.

                   

                  Ironically this all happened a few days after Intel finally released the firmware update for the well documented 8 MB bug on the 320 series.    What a coincidence....

                   

                  Since then I spend countless hours, not to say days, and tried to reactivate the SSD with all the hints and advices found in the 8 MB bug threads. Unsuccessful (in more detail: I was able to do a secure erase but I'm unable to format the SSD. The format process takes forever and after 100% completion it says formatting unsuccessful) It looks like this will be another RMA case. Great! Based on some other reports such an RMA process most probably will take weeks. A PC without system disc for weeks, nice outlook.

                  • 6. Re: 8 MB bug in Action
                    ssdfrustration

                    An Update.

                     

                    The replacement 310 mSATA SSD came on Monday. Installed, and it has been running smoothly for 6 days. Everything is fine so far.

                    • 7. Re: My new 310 mSATA 80 GB SSD hit by the BAD_CTX 8 MB bug
                      Sherv

                      I've also got the BAD_CTX 8MB bug in my Intel 310 mSATA SSD! It was only 2 days old when it died :-( I tried doing a Secure Erase using the Intel SSD Toolbox, but it said my device is frozen, and since it is an mSATA device and therefore inside my laptop, I'm not even sure if it can handle being unplugged & plugged back in while Windows is running! And since I don't live in USA it is difficult for me to send it back to Intel for RMA.

                       

                      So I will try the other Secure Erase methods:

                       

                      Cheers,

                      Shervin.