3 Replies Latest reply on Aug 9, 2011 6:48 PM by omnidroidvx9

    DH57DD not working properly with 16GB of RAM


      I just assembled a new computer using a DH57DD board and was dissapointed to find out that I wasn't able to use all 16GB of RAM I purchased for it. I purchased 2 Kingston 8GB dual channel kits with model number KVR1333D3N9K2/8G to use for this build.  I am using a core i5 650 CPU and using only the onboard video, audio, LAN, etc.  No expansion cards. 


      When trying to use all 16GB of this RAM, the machine crawls.   The First time I tried to install and OS, it took 20 minutes to boot the install disc and gave me error messages, but it didn't say anything about the RAM being bad.  This happened with both an attempted Windows 7 64 bit and Fedora 15 64 bit install.  What's strange is the board will post normally and I can get in to the BIOS.  The BIOS shows all 16GB at the correct speeds and timings. 


      My solution has been to take one of the dual channel kits out.  The machine works fine with just 4GB or 8GB using either the blue or black DIMM's on the board.  I tried both RAM kits too and they all work normally as long as I am using only 1 or 2 sticks of RAM. I haven't tried it with 3 sticks.  I also tried updating to the latest BIOS version and that did not help either. 


      Is there a specific brand/model of RAM that will allow me to use 16GB or is there a BIOS setting I can tweak to make my current RAM work?