4 Replies Latest reply on Aug 13, 2011 9:50 PM by techniq

    Problems installing Network Connections in Win7-64bit

    techniq

                  I am attempting to install the latest wired network drivers (PROWin7_64_v16.4.exe) on my DP55WG computer using Windows 7 Ultimate, 64-bit.  My bios version is KGIBX10J.85A.5893.2010.1116.0001.  I have 2 such computers that are essentially identical except one has a RAID 10 array and the other does not.  The installation goes fine on the one without the RAID array.  But it stalls on the RAID computer.  I have no reason to suspect the RAID array as being part of the problem and I doubt that it is.  I only mention it because it is the only significant difference between the two machines.

                  On the RAID computer, I tried the install in both the normal way and as administrator.  In either case the installation seems to go fine up to the point of getting through a “validating install” message.  Then I get “removing applications” above my progress bar which probably means that the installation went fine and now it wants to remove my old driver.  Then I get an “Intel Network Connections” dialog box that says, “The feature you are trying to use is on a CD ROM or other removable disk that is not available.”  There is a browse button and a “use source” box with a “1” in the box.

                  When I hit browse, the file it is looking for is identified as PROSETDX.msi.  This file is on my mother board disk in several folders.  Folder “1” is not on the disk.  I tried to use that disk and I tried folders named Win7_64 and another named Win7_x64.  Both contained their versions of the file, but neither would install.

                  Instead, when I browse for it and hit OK, I get another “Network Connections” dialog box that says:  “The file ..path...PROSETDX.MSI    is not a valid installation package for the product.  Try to find the installation package PROSETDX.MSI in a folder from which you can install.”

                  At that point, I have to cancel out.  After hitting “Cancel”, I get “Error 1714.  The older version of Intel Network Connections cannot be removed…”  When I OK that, I get the InstallShield Wizard telling me that my system was not modified and I can only abort.

                  Since the CD didn’t work, I searched my hard disk and found the file in 2 different places.  One was under C:\users\ and the other under C:\Documents and Settings\ and the both ended in \AppData\Local\Temp\pftB7BC.tmp\APPS\PROSETDX.  I started over again, got to the same place, and tried those versions of PROSETDX.msi also, but the result was the same. 

                  After my first contact with Intel chat, I was advised to insure that I have the latest chipset drivers and try again.  I installed them as INF_allOS_9.2.0.1030.exe.  I also, uninstalled the network driver I was using, and tried again to install the new driver with the same result.  I am now back to the standard Windows driver.

                  On my second contact with Intel Chat, I was advised to reinstall Windows.  I don’t want to spend 2 weeks updating this driver, so I’m looking for a different solution.  I think someone who knows how the Windows installer is supposed to work can get me through this.  Please help!!

        • 1. Re: Problems installing Network Connections in Win7-64bit
          v.kamphuis

          In this dir there also should be driver?:

           

          AppData\Local\Temp\pftB7BC.tmp\APPS\PROSETDX

           

          If there a drivers you should copy them to the desktop and try install them manualy with device manager from windows.

          • 2. Re: Problems installing Network Connections in Win7-64bit
            techniq

            The file was there at one time, and I tried exactly what you suggested.  Unfortunately, I got the same result.

            • 3. Re: Problems installing Network Connections in Win7-64bit
              techniq

                          Since I couldn’t get help from Intel (other than advice to reinstall the O/S), I have been working with a very nice man named Alex Zhaozx at Microsoft TechNet.  He found this article for me: http://www.intel.com/support/network/sb/CS-029916.htm.  This is an article written by Intel to address this problem, but for some reason Intel was not inspired to tell me about it.  Following the article was an arduous task, but it identified PROSet as the culprit and almost worked.  I have decided to not bother Alex anymore and instead I am asking Intel to put some more effort into this.

                          It is IRRESPONSIBLE for Intel to let this go on.  Intel created this mess by making PROSet impossible to uninstall with standard methods.  Many people are struggling with this, and I know you have the ability to make us an easy fix.  Intel’s solution so far:  “Take 2 weeks off from work and reinstall everything on your computer.”  Please!

                          The article describes how to uninstall PROSet.  Something like that should work, but it only “almost” worked for my version of Windows.  I had to resort to the register editing procedure in the article.  After being as meticulous as possible with the many edits, only one thing changed.  Instead of getting the browse box, I got the following message:  “The installed version of PROSet is not supported for upgrades.  You must uninstall it before installing the new version.”  That clearly identifies the problem as an older version of PROSet.  I have since found many postings on the internet with people having the same problem, but where there was a solution it didn’t work for me – probably because they were working with an earlier version of Windows.

              The reason the procedure didn’t work for me is probably due to the fact that the article was not written for my version of Windows and I was forced to make some assumptions when editing the registry keys – See below. 

              If you know of a commercial uninstall utility that works for PROSet on Win7, 64-bit, I am open to making the purchase, so please let me know.

               

              Here are the problems I had with the procedure as published by Intel for Vista and below:

              *           Steps 1-5 caused me to have to System Restore in order to get my network back.  After uninstalling from Device Manager, I had no driver and could still not uninstall my old version Network Connections.  Therefore I tried the registry edits.

              *           Step C:  Couldn’t find any keys that fit the description.  However, the description was unclear in terms of how I should recognize the name.  Should it be “Network Connections”, “Intel 82578DC”, “Gigabit”?  I did find “Microsoft Teredo Tunneling Adapter” and that could have been it, but I decided to not take a chance on that one.

              *           Step D:  Couldn’t find any keys that fit the description. 

              *           Step E:  Same comment as Step C.

              *           Step F:

                          HKEY_LOCAL_MACHINE\Software\Intel\SupportedDevices did not exist.  However, HKEY_LOCAL_MACHINE\Software\Intel\ Prounstl\ SupportedDevices did exist and I assumed that to be what was intended.

                          HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iANSMiniport did not exist.

                          HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iANSProtocol did not exist.

              *           Step G:

                          After ..\Intel\DMIX\ there was a key not mentioned:  ..\Intel\DMIX\CL.  I left that there.

                          ..\Intel\NCS2\Scripts\ was not there.

              • 4. Re: Problems installing Network Connections in Win7-64bit
                techniq

                     This is embarrassing, but I must eat some crow on this one.  The solution was very simple.  I had not installed the latest version of Intel Chipset Installation Utility prior to my installing the driver.  I am posting this (embarrassing or not) in hopes that it might help someone else who could be struggling with this.

                     In my own defense, I must ask why nothing prompted me to do that.  I found out after hours of desperate experimentation.  I guess one of the error messages was my clue.  If so, it was too cryptic.