2 Replies Latest reply on Aug 8, 2011 2:55 AM by lenky0401

    Does linux kernel 2.4.x can not support sandy bridge?

    lenky0401

      Hi,
          I have a new PC with a Sandy Bridge processor (i7-2600) and a Intel 82576 nic and i am install Red Hat Linux 9 Desktop (Kernel 2.4.20) on it. Now i am found the nic interrupt mode is XT-PIC (as shown in /proc/interrupts) and the igb driver cannot work. I have to use the kernel 2.4.20 on the Sandy Bridge platform for some reasons, so i want to change the interrupt mode from XT-PIC to IO-APIC-level. How can I do that?