4 Replies Latest reply on Oct 24, 2011 9:41 AM by spearson

    Intel Desktop Utility does not show - DH67BL

    Fatbit

      Right after I built my latest PC with DH67BL board over a month ago, IDU was working and showing. After a week, IDU did not show when invoked. It seemed to come up, spinning the blue circle icon for a while, then disappeared. I checked Task Manager and saw that the utility had been started but appeared to be stuck somehow.

       

      I checked around and found a possible solution: update the BIOS to the latest firmware. I promptly downloaded and installed the latest BIOS version (0125 7/5/2011) and IDU version (3.1.4.031a 4/27/2011). Now, IDU worked and showed its GUI as it should.

       

      A couple of weeks later, IDU stopped showing. Same symptoms as before. I decided to re-install IDU. Uninstallation got stuck. I went into Task Manager and manually deleted the IDU related processes. Now, uninstallation went through to completion and IDU was re-installed afresh.

       

      Reboot. IDU now runs and shows properly. What the heck has been going on? Why is IDU so flaky?

       

      ALSO: I noticed that, during the time IDU was having trouble displaying itself, the Intel Integrator Toolkit did not work. After changing the BIOS settings in the Integrator Toolkit, I clicked Update button to flash the BIOS but received the error message: "The BIOS is corrupted, or there are hardware problems." Quite alarming, but untrue. I suspected the Integrator Toolkit simply was not able to access the BIOS because certain low-leveḷ driver functions were not responding properly. After I re-installed the Desktop Utility, both it and the Integrator Toolkit work fine.

       

      Does this indicate that some low-level driver stuff somehow get corrupted and then get cleaned up by IDU re-installation?

       

      http://i.imgur.com/tUdLK.jpg

       

      Edited by Fatbit on 8/2/2011 to add observations regarding Intel Integrator Toolkit.

        • 1. Re: Intel Desktop Utility does not show - DH67BL
          Jose_Intel

          Firstly, thank you for providing us with this information.

           

          We have seen some problems when launching the Intel(R) Desktop Utilities, and we are working to identify the cause of the problem. We expect a new version of the software will take care of the problem.

           

          We will take the problem you had with the ITK into account, again, thank you for your details.

          • 2. Re: Intel Desktop Utility does not show - DH67BL
            spearson

            Have you tried Intel(R) Desktop Utilities 3.2.0.038a???

            • 3. Re: Intel Desktop Utility does not show - DH67BL
              Flying_Kiwi

              spearson wrote:

               

              Have you tried Intel(R) Desktop Utilities 3.2.0.038a???

              Please excuse me for jumping in here but while you're here, I have (but with other hardware) the old problem of the Windows control buttons on the top right not highlighting properly when the mouse rolls over them. This is still occuring when my display is set to 150% in Windows 7.

               

              If you have any involvement with (or are also part of) the team who developed the latest version of Intel Rapid Storage Technology drivers, THAT app does not have this problem. Perhaps you can integrate your efforts into just the one combined IDU and IRST application (that has fully working and not just flickering illumination of the minimise and close buttons at 150% Display settings)? I know I'd love to see such an app and I think theres a natural reason for why they should be integrated - ie people who want one, generally want both. Perhaps you can point this post out to the senior managers responsible for such decisions - thanks for listening!

              • 4. Re: Intel Desktop Utility does not show - DH67BL
                spearson

                Even with the latest version of IDU, there's a problem - an incompatibility (interoperability) issue between Intel(R) Integrator Toolkit (ITK), Intel(R) Integrator Assistant (IIA) and Intel(R) Desktop Utilities (IDU). There is a component that is shared between these applications. The latest version of this component is included within the latest releases of IDU, but an older verson is used in ITK/IIA. If ITK and/or IIA is installed after IDU, this older version will cause both applications to not work properly. We are working to address this issue as quickly as we can. In the meantime, please install IDU after ITK/IIA. If you want to upgrade the version of ITK/IIA that you are using, uninstall IDU first, install the upgrade and then reinstall IDU...