0 Replies Latest reply on Jul 28, 2011 1:06 PM by perrkathy@gmail.com

    cant open angry birds get GL2.0

    perrkathy@gmail.com

      how can i run angry birds with GL.2.0 GL.2.1 GL2.2 and GL.2.3 opens as error