8 Replies Latest reply on Jul 31, 2011 5:21 PM by xps1645user

    Windows 7 (SP1) Wireless Network Functionality Broken (User Interface)

    xps1645user

      I have a Dell XPS1645. I recently did a complete Windows 7 (ultimate) reinstall and went through updates through SP1 and successfully reinstalled all other software, etc. and, well, things were pretty good again.  Wireless networking was perfect and I then installed some home media software. I was, and am still, connecting to my wireless router and serving media files via wireless off my XPS1645 PC.

       

      Please see notes, below, as to my CURRENT configuration in regards to Intel support on my PC.

       

      Unfortunately I ran into a "My WiFi" problem, which is, I guess now, a secondary issue here. I carefully updated to Intel® WiFi Link 5300 13.5.0.0. Wireless was working well. All Intel tests passed. However "My WiFi" was not working with a message that "no supported adapter was found". I was unable to click "options" or anything else in the My WiFi console with that message. Via Googleing and here I was unable to find any help with this error message. Still, all Windows 7 functions like list of wireless network connections and facilities available through the Network connection and sharing center were available.

       

      Left again to nothing else but the futility of trying uninstall/reinstall on Windows, I gradually "rolled back" as I could. Unistalling/reinstalling WiFi Link 5300 13.5.0.0 didn't do it. Finally, back as far as I could go I reinstalled Network: Intel Intel Intel(R) WiFi Link 5300 DRVR Version  : A00  for Studio XPS Laptop Studio XPS 1645 Windows 7 64-bit from the Dell drivers installation CD.

       

      After reinstalling A00 my Windows 7 user interface functionality was broken, That is, the list of wireless networks never appears in the popup from the Network status bar icon and no wireless network appear in the mange wireless networks link from the Network and Sharing page and no wireless connections appear on the Network Connections page. Now diagnostics don't get past the hardware test. However my wireless is there and working!

      Please, I have exhausted trying tricks though the Windows 7 Control Panels, etc. I found no 5100/5300 files on Intel website that helped. A WiDi update that might have been useful failed due to my hardware configuration.  From googling it seems no one else has this problem. I can't find anything on Windows 7 similar to the XP "ZeroConfig" installation. System restore prior to reinstall of the original driver fails saying a "file is missing".Windows system restore gives NO information as to what that file is except to say that a virus scanner probably caused the failure, which it did not (how many times do we get LIED to?). I find I can not do a Windows 7 repair install being told I now have a version higher than the repair install version to be upgraded to.

       

      Is there someone out there with the solution to this problem?

       

       

       

       

       

      Dell XPS1645 Windows 7 Ultimate

       

      ATI Mobility Radeon HD 4670
      Current Driver Installed
      8.692.1.0

       

      Intel Chipset Software Installation Utility (Chipset INF)
      Product Detected
      Intel® 6, 5, 4, 3, 900 Series Chipsets
      Current Version Installed
      9.2.0.1025
      This version is valid.

       

      Audio Driver for Intel Desktop Board
      Product Detected
      ATI High Definition Audio Device
      Current Driver Installed
      5.0.7000.9

       

      Wireless Networking (WiFi)
      Product Detected
      Intel® WiFi Link 5300
      Current Intel® PROSet/Wireless WiFi Connection Utility Installed
      13.5.0.0
      Your driver is current.

        • 1. Re: Windows 7 (SP1) Wireless Network Functionality Broken (User Interface)
          PudgyOne

          When you reinstalled Windows 7, did you use the Dell DataSafe disks or Windows 7 disks?

           

          If Windows 7 disk, did you install the notebook system utility(if applicable) and the chipset drivers first? If not, the rest of the drivers will fail to install. How to Download and Install Drivers in the Correct Order

           

          As for the My WiFi Technology, try the instructions located at...

           

          Installing My Wi-Fi Technology

           

          The pictures from the mink(s) help you install it.

           

           

          Rick

          • 2. Re: Windows 7 (SP1) Wireless Network Functionality Broken (User Interface)
            xps1645user

            THANK YOU PO.

             

            My reply would be much more comprehensive  but that reply was wiped out because my reply was wiped out when I clicked a link in your "replying to" box to check one final detail and it opened in the same window and back didn't repost my text. I would graciously ask the administartors to open all links in new windows. For now I'll cut to the chase ...

             

            There is no  ICS_s64.exe option to enable or include WMI support as per the "Installing My Wi-Fi Technology" link you pointed out (thank you very much) . Could this be the problem?

             

            Also as to "Click start, all programs, Intel ProSet Wireless, Intel My WiFi Technology. You can then enable the technology from there." I believe I cannot do this because the OPTIONS is unclickable.

             

            I did receive a reply from my email to Dell suggesting some rather complicated reinstalls that I might try later depending on what comes about.

            • 3. Re: Windows 7 (SP1) Wireless Network Functionality Broken (User Interface)
              PudgyOne

              Windows 7 64-bit drivers (5100 and 5300 adapters)

              Follow the instructions in this thread.

               

              Installing My Wi-Fi Technology

               

              When installing, click custom and make sure to select them or it will not install automatically.

               

               

              Rick

              • 4. Re: Windows 7 (SP1) Wireless Network Functionality Broken (User Interface)
                xps1645user

                THERE IS NO OPTION TO INCLUDE "WMI Support". NO OPTION TO INCLUDE "WMI Support" appears and thus cannot be selected.

                 

                Rick:

                 

                I have removed my current  5300 wireless. I re-booted. I downloaded the setup exactly as instructed from http://downloadcenter.intel.com/confirm.aspx?httpDown=http://downloadmirror.intel.com/19862/eng/ICS_s64.zip&lang=eng&Dwnldid=19862&ProductID=3062&ProductFamily=Wireless+Networking&ProductLine=Intel%C2%AE+WiFi+Products&ProductProduct=Intel%C2%AE+WiFi+Link+5300+and+Intel%C2%AE+WiFi+Link+5100+productseng using a browser that is alwways cleared of all cache and private date on prior exit, extracted the files, ran the setup procedure, used CUSTOM and selected ALL options, again, exactly as I have done over and over here, every time, and, as every other time and still now, THERE IS NO OPTION TO INCLUDE "WMI Support". NO OPTION TO INCLUDE "WMI Support"  appears and thus cannot be selected..

                 

                I cannot seem to post an image here. I have attached a screen shot to an email to you.

                 

                Paul

                 

                If we cannot laugh at this, then, well, perhaps we cannot laugh at all :-)

                • 5. Re: Windows 7 (SP1) Wireless Network Functionality Broken (User Interface)
                  PudgyOne

                  It's really funny because I'm just a person trying to help and you attached the file and email it to Intel. Probably a mailbox that's not monitored.

                   

                  The screenshots in the other thread were from my old system. I have a new comp[uter and if I go to Start, control panel, programs and features, click on Intel ProSet/Wireless WiFi Software, then click on change. Choose modify.

                   

                  Do you see anything now?

                   

                   

                  Rick

                  • 6. Re: Windows 7 (SP1) Wireless Network Functionality Broken (User Interface)
                    xps1645user

                    Everything is the same in the de/re/install CP addf remove programs 5300 13.0.0. procedure.. There is NO 'istall WMI' option in the correct 5300  that I have used like the example you linked to specific for the (simailar) 5100 series.

                     

                    An issue here, I guess, is SHOULD there be "Install WMI support" in the 5300 13.0.0. setup procedure? I hope some of our readers could please answer that question.

                     

                    Our discussion has at least conviinced me of certain things.

                     

                    1) My reinstall was beacause of an insurmountable boot problem caused when I had no option but to to power off after a Widows re-booted screen freeze caused by an annoying self-resurecting pop-up 'update availablle' message. Although explorer was sluggish, MS updates were messy, etc., Everything else including drivers, except maybe the sound driver, were OK.

                    2) the reinstall of windows and the drivers and driver updates were done perfectly according to other sources and in review of your helpful link as to the correct order.

                    3) All hardware was tested by both CD and Dell resouce center diagnostics perfectl. Everything has been running now MUCH BETTER than ever. EVERYTHING is still running extremely, except WiFi now ...

                    4) following the correct procedures at the Intel website 5300 13.0.0. was successfully updated except that My WiFi was unfunctional as described in my original post here.

                    5) when I probably foolishly "went back as far as the resource CD" for the 5300 I broke additional Windows wireless functionality, in my original post.

                     

                    It's very strange because wireless seems to be working correctly At least a working 5300 adapter shows up in Network Connections. Howeever still NO available wireless connections windows can be summoned up and the Intel diagnostics and WiFi reported no adapter found. .

                     

                    I think I need to find what it is in Windows 7 /Wireless 5300 that IS BROKEN.  My windows system administration skills are a bit lacking. Any help from users to track this down would be greatly appreciated. Where to look?

                    • 7. Re: Windows 7 (SP1) Wireless Network Functionality Broken (User Interface)
                      PudgyOne

                      If this is the Studio XPS 1645, like your username is...

                       

                      Did you try the Intel(R) WiFi Link 5300 drivers from Dell's website?

                       

                      Did you try the drivers from the drivers disk that came with your computer?

                       

                       

                      Rick

                      • 8. Re: Windows 7 (SP1) Wireless Network Functionality Broken (User Interface)
                        xps1645user

                        Are either driver you mention the problem driver reported or a more recent version? What are you talking about? Read my posts.

                         

                        I have posted a question to the community and I am receiving umteenth USELESS replies from you including confusing links to a procedure to install a 5100 series driver when the driver in question is a 5300 series (and the procedures just don't compare), an outdated driver installation order set, silly hints of reinstall procedures being also found under control panel, and nonsense questrions infering update procedures may not have been followed when you have absolutely no cause to do that.

                         

                        I am asking the administrator of the board to close this thread. I have received no useful responses to solving my problem.