3 Replies Latest reply on Jul 29, 2011 7:17 PM by GregC

    Is SSD suported by a Gateway GT5662 NVIDIA® GeForce® 6150SE chipset?

    GregC

      Hi,

       

      I attempted to add a 320 series 300GB drive to my about 5 years old Gateway GT5662 NVIDIA® GeForce® 6150SE chipset. This is an AMD design, I believe.

       

      While the new drive boots there are two problems which make me to believe the SSD drive is not functioning properly:

       

      1. The drive is not being recognized by the Toolbox program, hence no "optimization" and the other utilities are not available (this system is running Vista).
      2. The drive copy (perfomed with the fully blown version of Acronis True Image) shows huge discrepancy in the amount of data on the drive: original about 173GB, copy about 103GB.

       

      I am not sure the board is AHCI-capable. I tried to enable AHCI by flipping the registry values, as mentioned in other posts on this site, but I can't see the MSAHCI driver being used.

       

      So here is the question: does anybody have an SDD drive running on such, or similar system?

       

      Thanks,

      Greg

        • 1. Re: Is SSD suported by a Gateway GT5662 NVIDIA® GeForce® 6150SE chipset?
          DuckieHo

          That's is an NVIDIA chipset... not AMD.  It does not suppport AHCI.

           

          The SSD is most likely running properly but you will have to contact HP/NVIDIA for the storage controller information.

          • 2. Re: Is SSD suported by a Gateway GT5662 NVIDIA® GeForce® 6150SE chipset?
            GregC

            Hi,

             

            I posted the full story here: http://communities.intel.com/message/133578#133578

             

            Here is a recap:

             

            My 2007 vintage system has an ASUS motherboard with an nVidia chipset and runs Vista. There is no support for the AHCI protocol in the BIOS, it knows about SATA, SCSI and RAID. Enabling AHCI support by flipping the registry entries did not make the drive being recognized by the tool. After extensive browsing of internet pages I concluded that the only way to get my SSD being recognized and driven by AHCI is to install a modern SATA controller, all of them seem to have support for AHCI by now. An older SATA controller by Asus, which was higly recommended is not being sold anymore.

             

            I went with HighPoint Rocket 620 Dual Port SATA 6BG PCI Express. The system accepted it and I could see that Vistan picked up some AHCI drivers for it but my SSD was still not recognized by the Tool and there were actually no AHCI drivers anywhere in Storage Controllers. I went to look for suitable drivers and found them under "Marvell 91xx SATA 6G Controller 1.2.0.100...". But no luck... I got the drives actually running in RAID mode and still no AHCI! After more looking I have found slightly outdated "Marvel 9xxx AHCI Sata Controller 1.0.0.1008" driver dated 8/11/2009. Installed that one and BINGO!

             

            The Toolkit now recognizes the drive as an Intel SSD drive. I can see its attributes and information. The only selection still not working is the "Intel SSD Optimizer" which claims "The tool is not supported on the selected drive".

             

            So.... I can run the system and it is blazingly fast but I will have to stop and go back to my old HDD unless I find a way to TRIM the drive. And this is the subject of a separate post, any ideas?

             

            Thanks, Greg

            • 3. Re: Is SSD suported by a Gateway GT5662 NVIDIA® GeForce® 6150SE chipset?
              GregC

              Anf finally I got a resolution: in Device Manager, Storage  Controllers, I did an update on the Marvell driver. I yanked it out and  replaced by a generic MS "Standard AHCI 1.0 Serial ATA Controller". That  gave me a few scary popup from Vista, left the Marvell controller in a  suspicious state (according to Vista) and produced a buch of entries  under IDE ATA/ATAPI controllers. But one of them is "Standard AHCI 1.0  Serial ATA Controller" and the Toolbox allows me to run and schedule the  optimization!

               

              The system is so fast that my VPN client refuses to connect now. But this would be another story....

               

              Greg