7 Replies Latest reply on Oct 28, 2011 9:20 PM by parsec

    Intel Rapid Storage Technology runs 320 series SSD at 1.5Gb/s




      Has anyone encountered this issue:


      I have a system that is based upon the Core i7-2600K and an ASUS P8Z68 motherboard. I am using a 160GB Intel 320 series SSD drive as the system boot drive. It is attached to the Intel SATA controller. I also have two Hitachi 3TB HDDs (6Gbps) drives in RAID 0 attached to the Intel SATA controller, a LG Blu-Ray burner and an Asus DVD burner attached to the Intel controller as well.


      The system is running Windows 7 SP1 Ultimate (64-bit). I have the newest SATA firmware available from ASUS (in system BIOS 0501) and the newest Intel RST drivers loaded ( have the controller set to RAID mode and the RAID drivers were F6 loaded during the Windows 7 installation. They have been subsequently upgraded to the above mentioned version.


      When loading the Intel RST application and checking the status of the drives, everything looks good, except that the 320 series SSD is identified as having only a 1.5Gbps SATA transfer rate instead of a 3.0Gbps that it should have. I checked on this drive because it seemed to be running slower on this Sandy Bridge Z68 system than in another system I have with an older chipset.


      All the other drives are identified with the proper SATA transfer rate and seem to be running just fine.



        • 1. Re: Intel Rapid Storage Technology runs 320 series SSD at 1.5Gb/s

          hi dwlevy,


          You're not alone. I'm having the same issue as you. My system is slightly different than yours but basically are same kind of trouble.


          Motherboard: ASUS P5E with latest BIOS

          O/S: Windows 7 Ultimate SP1 x64

          SSD: Intel X25-M 80GB G2 with latest BIOS install on motherboard SATA port 1, tried different ports are same result.


          The SSD drive used to have max speed connection on my older setup, with P35 ICH9 chipset. Max. Read speed can up to 250MB/s and Write speed up to 80MB/s.

          New setup with X38 ICH9R on ACHI mode (Intel Rapid Storage Technology: iata_enu_10.6.0.1022), also tried older version with no luck. All others drivers were installed properly, without any "!" or "?" in device manager. (all stuff were installed on flesh windows installation, not by disk cloning)


          Right now it is running at SATA: 1.5GB/s, Max. Read speed at 130MB/s and Write speed up to 80MB/s. So it's the read speed having a major problem. I test it with HD tach, HD tune. all showing the same result. Is there a work around to solve this issue? Intel please do something to help us out. I'm sure it's not a user fault, it must be related to the driver or Intel Rapid Storage Technology.


          See images as proof:



          Thank you and best regards,


          July 28 2011

          • 2. Re: Intel Rapid Storage Technology runs 320 series SSD at 1.5Gb/s

            Seems the RST drivers (and/or firmware) are likely the cause of this issue. My old system (which is now my wife's current system) uses the Intel Matrix Storage Technology drivers instead of the RST drivers. While I never ran explicit benchmarks to test the actual difference in throughput between the two systems, the Windows Experience Rating for the 320 series SSD on my new system is 7.2, while the Experience rating for the same 320 series SSD in my wife's system is 7.7.

            • 3. Re: Intel Rapid Storage Technology runs 320 series SSD at 1.5Gb/s

              Exactly what I think. After I removed RST driver, re-test the SSD speed. Every thing was back to normal, read and write both at full speed (3.0GB/s).

              Since without the properly driver my system turn to unstable, "ATAPI error with host controller", transfer files between other HDs suffer greatly. It's time for Intel to response and do something.

              • 4. Re: Intel Rapid Storage Technology runs 320 series SSD at 1.5Gb/s

                Interesting, I am running a X25-M 160GB G2 on the same motherboard as you FungYW.  However, the drive certainly runnins in SATA 3Gb/s mode.


                Which older RST driver did you attempt?


                You want to run RST drivers instead of Matrix RAID drivers for TRIM support.

                • 5. Re: Intel Rapid Storage Technology runs 320 series SSD at 1.5Gb/s

                  ATAPI errors indicate a problem with your CD/DVD drive and have nothing to do with the SSD.  Many (MANY!!!) CD/DVD drives do not properly work with AHCI (and even less so if the option ROM is set to RAID mode).  The drives will "function", but will start randomly spitting out errors, experience issues, etc..  These issues manifest themselves as the SATA controller having to reset PHYs or experience timeouts on ports, which causes the entire controller (not just that one port) to sometimes stall.


                  You will say "the issue I'm reporting is with the SSD being capped at SATA150 speeds not SAT300" -- but what I'm saying is that by setting the controller to AHCI mode with a CD/DVD drive attached to the same controller, you may actually be causing problems with the controller to happen.


                  So here's a test: if you enable AHCI, unplug your CD/DVD drive, and use the Intel RST drivers, do you still see the same bad performance?  (You shouldn't see *ANY* ATAPI errors in your log after doing this.  Again, ATAPI is for CD/DVD drives, not SSDs or hard disks).

                  • 6. Re: Intel Rapid Storage Technology runs 320 series SSD at 1.5Gb/s

                    To  Koitsu,


                      Thank you for your reply. I don't think the error was caused by my LG BD writer. It just run in different interferce, that's why it came out with error. SATA/IDE mode vs SATA/AHCI mode. It run fine without error when it's on AHCI mode with RST driver installed, reading and writing are all fine.


                    There is a RST bug that cause my SSD run in 1.5GB/S(SATA1), I mention it all run fine in P35 ICH9 chipset, it doesn't came with RAID function and no need to install RST driver. Forget to mention that my system is run in plain AHCI mode, without any disk array.


                      Now I'm waiting for Intel reply. Hope they are not just sitting there and do nothing. Futhermore Intel diver doesn't support/compatible with their own line of SSD is a joke!

                    • 7. Re: Intel Rapid Storage Technology runs 320 series SSD at 1.5Gb/s

                      Well, I have four X-25M G2 80GB SSDs, a 120GB 510, and a Crucial M4, spread over several PCs. My P67 board PC has three SSDs in it, a 510, a G2, and the M4.  Of course using IRST, actually newer versions from Intel rather than from my board's manufacture (even my Intel board...)  I've never had any change or drop of SATA interface speed. SATA chipsets are only ICH10R and P67, but across socket 775, 1366, and 1155 boards.


                      FungYW, what AHCI driver are you using?  The problem could be the option ROM for your ICH9 chipset.  I tried to find your P5 board on ASUS' website, not there.  The only P5 board they do list does not have any SATA drivers listed for downloading, that is strange.


                      Don't forget when you say the IRST driver does not work, it does not work for you apparently, but has always worked fine for me and many others.