12 Replies Latest reply on Jul 13, 2012 12:05 PM by joezeppy

    Cannot install IRST 10.6.0.1022

    wchris

      currently running with IRST 10.1.0.1008

       

      trying to install latest 10.6.0.1022 fails with message "does not meet requirements"

       

      what requirement changed between  10.1.0.1008 and 10.6.0.1022 ?

       

      Thanks

        • 1. Re: Cannot install IRST 10.6.0.1022

          My hardware is the Intel® 965 Express Chipset Family - ICH8.

           

          Compared to the last IRST, this one has no INF support.  It's missing:

           

          %PCI\VEN_8086&DEV_2821&CC_0106.DeviceDesc% = iaStor_Install, PCI\VEN_8086&DEV_2821&CC_0106
          %PCI\VEN_8086&DEV_2829&CC_0106.DeviceDesc% = iaStor_Install, PCI\VEN_8086&DEV_2829&CC_0106

           

          PCI\VEN_8086&DEV_2821&CC_0106.DeviceDesc    = "Intel(R) ICH8R/DH/DO SATA AHCI Controller"
          PCI\VEN_8086&DEV_2829&CC_0106.DeviceDesc    = "Intel(R) ICH8M-E/M SATA AHCI Controller"

           

          And this is weird - becasue the older ICH7  (945 Chipset) is supported.  I just updated the SATA AHCI driver on my 945 box.

           

          That could also be your problem.  I wonder why Intel left it out for ICH8? The download site says it's good for my chipset.

          1 of 1 people found this helpful
          • 3. Re: Cannot install IRST 10.6.0.1022
            wchris

            Thank you for the info ... but it's still not totally clarified

             

            ICH8 support is dropped ... but acccording to the readme file provided with

            Version 10.6.0.1022,  ich7 is still supported http://downloadmirror.intel.com/20215/eng/Readme.txt

            So maybe the readme is wrong ... or someone at intel just forgot to allow installation for ICH7 ?

             

            Intel(R) Rapid Storage Technology is designed to provide
            functionality for the following Storage Controllers:
                RAID Controllers:
                - Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller
                - Intel(R) Mobile Express Chipset SATA RAID Controller 
                - Intel(R) ICH7MDH SATA RAID Controller
                - Intel(R) ICH7R/DH SATA RAID Controller  
                  
                AHCI Controllers:
                - Intel(R) Desktop/Workstation/Server Express Chipset SATA AHCI Controller
                - Intel(R) Mobile Express Chipset SATA AHCI Controller
                - Intel(R) 5 Series/3400 Series SATA AHCI Controller
                - Intel(R) 5 Series 4 Port SATA AHCI Controller
                - Intel(R) 5 Series 6 Port SATA AHCI Controller
                - Intel(R) ICH10D/DO SATA AHCI Controller
                - Intel(R) ICH10R SATA AHCI Controller
                - Intel(R) EP80579 SATA AHCI Controller
                - Intel(R) ICH9M-E/M SATA AHCI Controller
                - Intel(R) ICH9R/DO/DH SATA AHCI Controller
                - Intel(R) ICH7M/MDH SATA AHCI Controller
                - Intel(R) ICH7R/DH SATA AHCI Controller
               
            ************************************************************
            * 2.  SYSTEM REQUIREMENTS
            ************************************************************

            1.  The system must contain one of the Intel controllers listed in
                section 1 above and one of the following processors:
                - Intel(R) vPro
                - Intel(R) Celeron
                - Intel(R) Pentium   
              

            2.  The system must be running on one of the following
                operating systems:
                - Microsoft Windows 7*
                - Microsoft Windows 7* x64-bit Edition**
                - Microsoft Vista*
                - Microsoft Vista* x64-bit Edition**   
                - Microsoft Windows Server* 2008
                - Microsoft Windows Server* 2008 x64-bit Edition**
                - Microsoft Windows XP* Home Edition
                - Microsoft Windows XP* Professional
                - Microsoft Windows XP* x64-bit Edition**
                - Microsoft Windows Server* 2003
                - Microsoft Windows Server* 2003,
                  Web x64-bit Edition**
                - Microsoft Windows Server* 2003,
                  Standard x64-bit Edition**
                - Microsoft Windows Server* 2003,
                  Enterprise x64-bit Edition**
                - Microsoft Windows Media Center* Edition

             

            my DELL precision T5400 meets with a 3Ghz quad core XEON running windows vista 32 with an ICH7 raid mobo meets all the requirements.

             

            At least the error message should tell me what requirement i do not meet, the installer obviously knows the info so why not share it with the user ?

            • 4. Re: Cannot install IRST 10.6.0.1022

              Please read that article and another linked article in that article. They must have had a few problems with ICH8R/M that they did not have with ICH7. I'm at a loss to explain why they continued to support ICH7 after dropping support for the newer ICH8, but that is what they did.

               

              See this also.

               

              If you have ICH8R or M, you'll have to stick with the old 10.1.0.1008 from this point on. IHC7 can use the latest. Go figure.

              • 6. Re: Cannot install IRST 10.6.0.1022

                Try this (corrected again).

                 

                In any event, IHC7 continues to be supported, but not 8.

                • 7. Re: Cannot install IRST 10.6.0.1022
                  wchris

                  Hi Chris,

                   

                  Thanks for the links. it ryed to install  .1056 and .1057, both complain i do not meet requirements

                   

                  My best guess is that the raid bios provided by DELL is too old ... but without the installer telling me what's the problem i can't be sure.

                   

                  if found a newer bios here http://www.station-drivers.com/page/intel%20raid.htm

                   

                  my current raid bios is 5.6.6.1001     ^^

                   

                  the utility to flash the optional rom is called cmdtools2, but seems difficult to find and download

                   

                  also after reading the forum I found out some people flashing the bios broke their raid ... and I don't want to loose my data ... that would be the oposite of raid purpose. It seems logical that if the new raid rom stores raid data differently from previous version the raid volums must be rebuilt ... but intel doen't provide support for raid bios update so it's way too risky.

                   

                  I'll drop the idea until i get clear confirmation that i can safely flash from 5.6.6.1001 raid optional rom to 10.5.1.1070. And it's something i'll probably never get ^^

                   

                  anyway my secong problem with RST reporting verify errors has improved and i finaly get 0 errors ... so i cross fingers RST will save my data if one drive fails

                   

                  Thank you

                   

                  PS: I close my search, but if an intel raid ingeneer wants to add something he is welcome

                  • 8. Re: Cannot install IRST 10.6.0.1022
                    chrone

                    i hope intel will change its mine and start to support ich8r again in the next version. i'm still using asus p5b-deluxe wifi/ap with ich8r using ahci mode.

                    • 9. Re: Cannot install IRST 10.6.0.1022

                      Go here and read down the line.

                       

                      There's some good info there - especially from Fernando 1. The big take-away is that after so many years of development, it's questionable if you'd get any performance gain from and upgrade anyway.  See post 1070 for the quote. IOW, Intel was probably not not focused on ICH8 in their last release.

                       

                      The new one really focused on "SSD Caching". We like to think new is better, but that's questionable.

                       

                      If you have RAID, according to Fernando 1, the new RST driver will work.

                      • 10. Re: Cannot install IRST 10.6.0.1022
                        jluisllv

                        I think that the problem should be in the installation file (INF) that does not include 82801HR (ICH8R). We must wait for it to correct the installation file.

                         

                        My log say:

                        ...

                        [Checkin requirements]

                        Checking for admin rights

                        Admin rights OK

                        Checking OS

                        OS check OK

                        Checking .NET configuration

                        .NET check OK

                        ...

                        Didn't find any INF's that match active hardware

                        ...

                         

                        Thank you

                        • 11. Re: Cannot install IRST 10.6.0.1022
                          chrone

                          they really need should fix this.

                           

                          emailed intel asia pacific technical support back then regarding this matter, they told me to contact asus since i'm using p5b-deluxe wifi-ap. i knew asus would throw me back at intel again since intel was the one who produced the rst driver. felt like a pingpong ball at that moment, really didn't help at all. :\

                           

                          if ich7r still supported then ich8r should too, you listen to me intel!

                          • 12. Re: Cannot install IRST 10.6.0.1022
                            joezeppy

                            So what do we do when trying to build AHCI support into an XP image where I need support for new hardware that requires 11.0, plus old hardware that requires 10.1?