2 Replies Latest reply on Aug 1, 2011 12:03 PM by jackphelps

    Bootable USB thumb drive not detected


      Hi ~ I have a D410/NM10 desktop board with which I'm trying to boot into a bootable Linux USB thumb drive (up to date version of Ubuntu). The drive works on two other computers I've tested without issue as long as I've configured the bios correctly. On this board I get a "A bootable device has not been detected" error when trying to boot.


      I've set what I believe are the relevant bios settings as follows:

      Boot menu type: advanced

      Boot to optical devices: enable

      Boot to removeable devices: enable

      Boot to network: disable

      USB boot: enable

      Boot USB devices first: enable

      USB mass storage emulation type: auto  ***I've also tried both "all removeable" and "all fixed"

      UEFI boot: disable


      In the Advanced section of the bios, USB ports and USB Legacy are all enabled.


      When I connect a windows HDD over sata it boots into Windows fine. The USB stick lights up and flickers when the computer is turned on and I've tried each of the four ports, so it shouldn't be a port problem.


      Any suggestions? Am I doing something impossible?


      For reference, I'm trying to run a kiosk off linux, and am electing to use a USB drive rather than a regular drive because of size, cost, and ease of installation and duplication. I'm not really used to working with hardware though, so I'm feeling a tad out of my depth.


      Thanks in advance for any help anyone can provide!