0 Replies Latest reply on Jul 11, 2011 10:07 PM by MCloud

    massive cpu activity when raid drives are plugged in

    MCloud

      I recently built a new system which consists of the following:

       

      Antec 300 case, Corsair 650 W power supply, Gigabyte GA-Z68XP-UD4 motherboard, nVidia 8400 GS Graphics card, 8 GB corsair DDR 1600 RAM, 2 DVD players and 6 hardrives. OS is Win7 Pro x64

       

      I have the hard drives configured in pairs 2 Raid1 pairs and 1 raid0 pair.  the boot raid1 is a pair of 500 GB seagates (new but have had a couple of installs on them, reformatted, wipe deleted before latest install), the 2nd raid1 is a pair of hitachi 1.5TB drives (brand new not even formatted as of now), and the raid0 is a pair of WD 250 GB drives (older, reformatted)

       

      What I see is massive cpu activity 60-90% on the task manager cpu usage monitor, with no task (except system idle) showing more than 1% activity.  The activity is so great (or something else is going on) that all OS operations such as mouse clicks, task switching, calling up the task manager, pressing ctrl-alt-del, etc,. take many minutes to respond if they respond at all.  Shut down can take hours, if it doesn't fail altogether.

       

      After much struggle I have been able to turn the problem on and off by booting with or without either (or both) of the non-boot raid drives.  With only the boot raid1 pair there is no problem over many days.  If I connect either of the other raid pairs in about 35-45 minutes my system becomes unuseable.

       

      This behavior is with no other software installed, just a raw Win7 pro x64 install, no windows update, not even the graphics card driver installed (just using OS provided driver).  I have run Kaspersky anti-virus on the system and it found nothing.

       

      Obviously this is massively not ok.

       

      I had a previous system which was only different in having a different motherboard (Asus P5QC) and different RAM DDR2-800's, and 4 of the dirves were different (the WD's were the same), but the raid configuration was the same and this system worked fine for two years.  Then I had some kind of electrical event which knocked it out and I had to rebuild it.

       

      My first re-build used an asus P8P67 (intel p67 controller) and it exhibited exactly the same apparent behavior as I described above.  In trying to find what the cause was at that time, I reformatted the 2nd raid1 pair (a pair of seagate 1TBs), the massive cpu activity occured during that process, and although the format operation completed (apparently) succesfully, trying to exit the OS didn't work.  Powering the system off caused the next boot to fail in an endless loop that stopped just shy of the OS start, but including the Intel controller screen.  Doing a clear rtc on the motherboard did not fix the problem and instead led to even the intel controller screen not appearing in the endless loop.  So that motherboard was toast.  Tried again with another P8P67 and again formatting the drives led to an inability to exit the OS, and failure to reboot.  So tried a different vendor, gigabyte which is the system I described above.  Somewhere in all of this I started figuring out how the problem manifested, and didn't do any more format operations.  In fact I have yet to initialize either of the non-boot raid pairs because as I say I now realize that my problem starts as soon as I plug them in.

       

      It could be that there is some kind of wildly horrible virus that hides in reserved tracks on the hard drive, but if so why don't I have a problem when I have the drive most likely to have this virus connected which is my boot drive which as I say, by itself works fine.  I have tried to get these drives as clean as possible before each install, by reformating and wipe deleting, but I was only able to do that on the boot pair.  So I went out an bought a new pair of 'big drives', and also a new pair of smaller faster ones thinking this might be the problem.  But before I installed the 2nd pair I thought to try switching the extra raid drives in or out of the system, and found that to completely control the issue, so I haven't yet bothered to install the 2nd pair -- I'd rather get my money back if I can.

       

      My bet is on either a driver/OS problem, or a hardware problem.  Obviously the driver/OS is the best guess.  I have a question in to Microsoft, but I'm also asking here.

       

      If anyone has seen anything like this... please help.